Cyberduck Mountain Duck CLI

#7914 closed defect (fixed)

Interoperability with Oracle Storage Cloud

Reported by: jprice Owned by: dkocher
Priority: normal Milestone: 4.5
Component: openstack Version: 4.4.4
Severity: normal Keywords: openstack password chars
Cc: Architecture: Intel
Platform: Windows 7

Description

If I enter an Openstack secret key which contains a special character, it seems the correct password is not sent to the Openstack service. On trying to connect I receive an error message: "Connection Failed. Found. 302 Found."

On Windows 7, when using Curl I have to put the password/secret key value in double quotes in order for it to be accepted by the OpenStack service (Oracle Storage Cloud). Inclusion of a special character in the password is mandatory.

In the Cyberduck secret key field I do not see any way to do the equivalent. I guess that the special character in the password is not being sent to the storage service correctly.

I have tried doing the same using Cloudberry explorer and authentication and connection is successful.

Can you confirm the problem please?

Attachments (3)

Openstack password error.JPG (43.0 KB) - added by jprice on Apr 29, 2014 at 12:38:50 AM.
Error on connection failure (password containing special char)
Upload-error-message.JPG (54.6 KB) - added by jprice on Apr 30, 2014 at 1:00:55 PM.
error on upload of file to Oracle Storage Cloud by File > Upload or upload button
cyberduck.log (23.6 KB) - added by jprice on May 9, 2014 at 3:01:32 PM.

Download all attachments as: .zip

Change History (22)

Changed on Apr 29, 2014 at 12:38:50 AM by jprice

Error on connection failure (password containing special char)

comment:1 Changed on Apr 29, 2014 at 8:54:22 AM by dkocher

  • Component changed from core to openstack
  • Milestone set to 4.5
  • Owner set to dkocher
  • Summary changed from Openstack Storage user password with special characters not accepted to 302 Found response for user password with special characters

comment:2 Changed on Apr 29, 2014 at 8:55:09 AM by dkocher

Please post the transcript from the log drawer (⌘-L) and the output when connecting with curl -v.

comment:3 Changed on Apr 29, 2014 at 9:21:29 AM by dkocher

  • Status changed from new to assigned
  • Summary changed from 302 Found response for user password with special characters to Interoperability with Oracle Storage Cloud

The issue does not seem to be connected to the chosen password but an interoperability issue with the identity service. Oracle Storage Cloud does only support legacy authentication but the latest version of Cyberduck defaults to Keystone authentication (2.0) by default.

POST /v2.0/tokens HTTP/1.1
Accept: application/json
Content-Type: application/json
Content-Length: 130
Host: storage.us2.oraclecloud.com
Connection: Keep-Alive
User-Agent: Cyberduck/0 (Mac OS X/10.9.2) (x86_64)
 HTTP/1.1 302 Found
 Date: Tue, 29 Apr 2014 09:18:01 GMT
 Server: Oracle-Application-Server-11g
 Location: https://cloud.oracle.com/404.html
 Content-Length: 244
 Keep-Alive: timeout=5, max=100
 Connection: Keep-Alive
 Content-Type: text/html; charset=iso-8859-1

comment:5 follow-up: Changed on Apr 29, 2014 at 9:38:22 AM by dkocher

The login works if you use the Openstack Swift (Swauth HTTPS) profile. Use ServiceName-IdentityDomain:UserName for the Username.

comment:6 Changed on Apr 29, 2014 at 11:20:46 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

We have updated the documentation.

comment:7 in reply to: ↑ 5 Changed on Apr 29, 2014 at 1:11:11 PM by jprice

Replying to dkocher:

The login works if you use the Openstack Swift (Swauth HTTPS) profile. Use ServiceName-IdentityDomain:UserName for the Username.

Many thanks. Confirmed login is OK. Thanks for the doc and profile also - very good.

I can now download from a container on the Oracle storage cloud, but I do not seem to be able to upload. Selecting a local file (eg C:\test) and then upload, with the container contents displayed, results in attempt to upload, followed by: "File not found C:\test. Please contact your web hosting provider for assistance."

This appears to show that the local (source) file cannot be found. Is this correct and why might that be please? I can confirm that I am able to upload files to the container outside of Cyberduck.

comment:8 Changed on Apr 30, 2014 at 12:58:07 PM by jprice

I have now been able to upload files to Oracle Storage Cloud, using CyberDuck, but only by drag-and-drop. In this case the file uploads but does not appear in the transfers dialogue. It does get uploaded however.

Using the upload button, or trying file > upload still gives the error mentioned above.

Last edited on Apr 30, 2014 at 1:05:13 PM by jprice (previous) (diff)

Changed on Apr 30, 2014 at 1:00:55 PM by jprice

error on upload of file to Oracle Storage Cloud by File > Upload or upload button

comment:9 follow-up: Changed on Apr 30, 2014 at 1:05:51 PM by jprice

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 in reply to: ↑ 9 Changed on May 9, 2014 at 8:11:51 AM by dkocher

Replying to jprice:

Create a container first (Ctrl-N) to upload objects into. Fix to validate Upload action in r14527.

comment:11 Changed on May 9, 2014 at 8:11:57 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:12 Changed on May 9, 2014 at 9:44:58 AM by jprice

I previously had tested, trying to upload to a container created with CyberDuck - it does not function for me if using the upload button, or File > upload. The only way that I can upload to a container is by copy/paste in CyberDuck which works fine. Also no transfers show in the transfers window. The problem is that using the Upload button in the UI, or file > upload results in the error described previously.

I can also use CloudBerry to upload with no problem. As an aside I found that CyberDuck would not upload at all to a container created by CloudBerry (different creation options perhaps?) but would upload to a new container created by CyberDuck on the same storage.

comment:13 follow-up: Changed on May 9, 2014 at 10:15:01 AM by jprice

I have just verified again. I can create a new container as before. I cannot upload a local file to the new container using the upload button or File > Upload. I can upload to it using copy+paste. The error is as mentioned above ie. Selecting a local file (eg C:\test) and then upload, with the container contents displayed, results in attempt to upload, followed by: "File not found C:\test. Please contact your web hosting provider for assistance."

comment:15 in reply to: ↑ 13 ; follow-up: Changed on May 9, 2014 at 1:35:11 PM by dkocher

Replying to jprice:

I have just verified again. I can create a new container as before. I cannot upload a local file to the new container using the upload button or File > Upload. I can upload to it using copy+paste. The error is as mentioned above ie. Selecting a local file (eg C:\test) and then upload, with the container contents displayed, results in attempt to upload, followed by: "File not found C:\test. Please contact your web hosting provider for assistance."

This looks like a different issue. Can you upload the same file to other servers?

comment:16 in reply to: ↑ 15 Changed on May 9, 2014 at 1:51:01 PM by jprice

Replying to dkocher:

Replying to jprice:

I have just verified again. I can create a new container as before. I cannot upload a local file to the new container using the upload button or File > Upload. I can upload to it using copy+paste. The error is as mentioned above ie. Selecting a local file (eg C:\test) and then upload, with the container contents displayed, results in attempt to upload, followed by: "File not found C:\test. Please contact your web hosting provider for assistance."

This looks like a different issue. Can you upload the same file to other servers?

The problem occurs whichever file I try to upload, ie. any file on my laptop. The only way that I can upload any file is by using copy/paste in CyberDuck, and then I can upload any file, but there is no parallel upload capability and uploads do not show in the transfers dialog when using copy/paste to upload. I can upload the same files using the upload dialogs of other upload tools.

Hence it seems to be a problem related to uploading any file to Oracle storage cloud using CyberDuck. I have not tried other servers, as I only have access to Oracle Storage Cloud at present. You should be able to reproduce the problem by attempting to upload a file to Oracle Storage Cloud, using CyberDuck on Windows.

Otherwise I will get a trial access to another storage cloud and test again. Thanks.

comment:17 follow-up: Changed on May 9, 2014 at 2:01:38 PM by dkocher

Do you have the same error when you drag & drop files from Explorer to the browser window?

comment:18 follow-up: Changed on May 9, 2014 at 2:02:05 PM by dkocher

Please attach the file cyberduck.log in the application support directory.

comment:19 in reply to: ↑ 18 Changed on May 9, 2014 at 2:57:28 PM by jprice

Replying to dkocher:

Please attach the file cyberduck.log in the application support directory.

I can say that the only entry in that file from today's attempt to upload to the new container JP2 is the following line:

2014-05-09 11:08:13,963 [Thread-0] ERROR ch.cyberduck.core.Cache - Lookup failed for [file]-/JP2 in cache

Looking back there are similar errors in the past. Ignore the error relating to Z:\ drive, that was when I tested with a Samba mounted filestore. Apart from that one case all other attempts were using local files. JP2, JP etc. are containers on the storage cloud.

comment:20 in reply to: ↑ 17 Changed on May 9, 2014 at 2:58:54 PM by jprice

Replying to dkocher:

Do you have the same error when you drag & drop files from Explorer to the browser window?

No ... that is what works ... drag/drop from Windows Explorer window to the container JP2 in the CyberDuck UI works OK.

Changed on May 9, 2014 at 3:01:32 PM by jprice

Note: See TracTickets for help on using tickets.
swiss made software