Cyberduck Mountain Duck CLI

#7923 closed defect (worksforme)

Attempt to set invalid working directory after failed connection attempt

Reported by: narrationsd Owned by: yla
Priority: normal Milestone: 4.4.5
Component: core Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 8

Description

I was on an original ftp site, in a folder called /missionbeach, where everything worked fine.

I then used the Bookmarks button to change to a different ftp site. This authenticated and tried to open, but then gave me an error alert, complaining that /missionbeach was not a valid folder name on the new site.

After I accepted the error alert, then the proper ftp site opened uneventfully, at its root level as it should.

I haven't seen this before, often enough switching ftp sites this way, so probably you have a regression here.

Other things have cleaned up without being listed, so I think you are on a good path for another release version here. I enjoy CyberDuck a lot, not least for its name ;)

This is actually on 4.5, just downloaded, so I noted as Nightly Build in your form here, since 4.5 hasn't made it into the dropdown.

Attachments (1)

directoryfail.png (72.1 KB) - added by narrationsd on May 1, 2014 at 9:06:05 AM.
picture of misdirection to directory from previous site

Download all attachments as: .zip

Change History (11)

comment:1 Changed on May 1, 2014 at 8:53:34 AM by dkocher

I cannot replicate this problem.

Changed on May 1, 2014 at 9:06:05 AM by narrationsd

picture of misdirection to directory from previous site

comment:2 Changed on May 1, 2014 at 9:11:08 AM by narrationsd

Ok, I lost my message in attaching a picture of the problem, so once again briefly:

  • at first I could not duplicate either. But it happened.
  • it may be significant that I have different kinds of secure ftp between the two sites: one is sftp, and the other ftps - FTP-SSL, and I think explicit.
  • I got Cyberduck pretty confused switching between sites and testing, when one of the sites wouldn't answer because of a CloudFlare DNS change.
  • finally it recovered, and I looked at the ftps site, where the /missionbeach directory exists
  • then I clicked the tiny icon to see bookmarks, and double-clicked on the sftp site.
  • in the attached png, you can see the fail alert with its details.
  • accepting the alert, then everything proceeds and works fine as far as I know.

it's late here, so hope I am clear, and grüss...

comment:3 Changed on May 9, 2014 at 7:24:46 AM by dkocher

  • Platform set to Windows 7

comment:4 Changed on May 9, 2014 at 7:27:29 AM by narrationsd

Yes, actually it's Windows 8.1, all latest updates.

Sorry if I missed where to say that...

comment:5 Changed on May 9, 2014 at 7:30:45 AM by dkocher

  • Milestone set to 4.4.5
  • Owner set to dkocher
  • Platform changed from Windows 7 to Windows 8
  • Status changed from new to assigned

comment:6 Changed on May 9, 2014 at 8:02:06 AM by dkocher

  • Owner changed from dkocher to yla
  • Status changed from assigned to new

comment:7 Changed on May 14, 2014 at 8:03:27 AM by dkocher

  • Summary changed from bad path on changing ftp sites to Attempt to set invalid working directory after failed connection attempt

comment:8 Changed on May 14, 2014 at 8:37:08 AM by dkocher

Added test in r14601.

comment:9 Changed on Jun 3, 2014 at 9:41:41 AM by dkocher

  • Milestone 4.4.5 deleted

comment:10 Changed on Jun 3, 2014 at 1:59:52 PM by dkocher

  • Milestone set to 4.4.5
  • Resolution set to worksforme
  • Status changed from new to closed

We have been unable to replicate this issue.

Note: See TracTickets for help on using tickets.
swiss made software