Cyberduck Mountain Duck CLI

#7933 closed defect (fixed)

Chunked downloads result in zero sized file

Reported by: dafresh Owned by: dkocher
Priority: normal Milestone: 4.4.5
Component: s3 Version: 4.4.4
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

Hello,

I discover that when a .txt file is uploaded to a S3 bucket, CyberDuck cannot download it back, but it workds fine with s3cmd.

Headers defined on the .txt files at the upload seems to be :

  • Content-Encoding: gzip
  • Content-Type: text/plain

For info "file" cmd on Mac determines it as " UTF-8 Unicode text".

A workaround to download back the file is to :

  • modify Content-Type to "application/octet-stream"
  • delete the Content-Encoding header

Except if I miss something, it seems there is a glitch with some files type and associated headers ;-)

On the other hand, why Content-Encoding is defined to "gzip" ?

Cheers,

Cédric

Attachments (2)

upload.log (1.5 KB) - added by dafresh on May 4, 2014 at 8:43:05 PM.
upload log
download.log (1.6 KB) - added by dafresh on May 4, 2014 at 8:43:18 PM.
download log

Download all attachments as: .zip

Change History (15)

Changed on May 4, 2014 at 8:43:05 PM by dafresh

upload log

Changed on May 4, 2014 at 8:43:18 PM by dafresh

download log

comment:1 follow-up: Changed on May 5, 2014 at 9:03:12 AM by dkocher

  • Milestone set to 4.4.5
  • Resolution set to worksforme
  • Status changed from new to closed

I don not understand and cannot reproduce the issue.

  • The Content-Encoding is only about the compressed content over the wire.
  • The Content-Type does not change the file transfer in any way.
  • The Finder.app will determine UTF-8 Unicode text because of the .txtextension in the filename.

It might be a server issue if the content is advertised to be compressed over the wire but is in fact sent as plain text.

comment:2 in reply to: ↑ 1 Changed on May 5, 2014 at 10:02:28 AM by dafresh

Replying to dkocher:

I don not understand and cannot reproduce the issue.

Could you please clarify which point you don't understand ?

  • The Content-Encoding is only about the compressed content over the wire.

Did know that, ok.

  • The Content-Type does not change the file transfer in any way.

It seams it does, because when I change it I can download the file.

  • The Finder.app will determine UTF-8 Unicode text because of the .txtextension in the filename.

I do not agree, "file" cmd goes read the meta-data and head of files, the extension does play any role here. An example with 1 text and one pdf :

$ file file.txt test.pdf 
file.txt: UTF-8 Unicode text
test.pdf: PDF document, version 1.5
$ mv file.txt file
$ mv test.pdf test
$ file file test 
file: UTF-8 Unicode text
test: PDF document, version 1.5

It might be a server issue if the content is advertised to be compressed over the wire but is in fact sent as plain text.

Note that it works well with other clients like s3cmd, DragonFly, so this tend to exclude the "server side" issue, don't you agree ?

comment:3 follow-up: Changed on May 6, 2014 at 4:39:54 PM by dafresh

Hello Dkocher,

I forget to give this info when the download fail : the file is created localy, but is empty.

Still looking for a possible resolution of this issue, and I would like insist on facts that the download with other largely used s3 clients (s3cmd and DragonDisk) works well, so everything makes think that there is a problem with CyberDuck on at least my context at the download or file creation on my disk.

I plane to check my drive and do the same test on a Windows platform, will let you inform.

It would be great if you can try to reproduce it or at least give me some pointers that could help ?

Cheers,

Cédric

comment:4 Changed on May 6, 2014 at 6:29:27 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:5 in reply to: ↑ 3 Changed on May 6, 2014 at 6:34:21 PM by dkocher

  • Status changed from reopened to new
  • Summary changed from [S3] Issue with .txt file and setted headers to Chunked downloads result in zero sized file

Replying to dafresh:

Hello Dkocher,

I forget to give this info when the download fail : the file is created localy, but is empty.

Thanks for the additional information. There is an issue with transfers not taking place when the Content-Length header is missing (the case for chunked transfers).

Last edited on May 6, 2014 at 6:34:58 PM by dkocher (previous) (diff)

comment:6 Changed on May 6, 2014 at 6:40:31 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r14564.

comment:7 Changed on May 6, 2014 at 8:55:37 PM by dafresh

Good news.

It seems it is related with my previous opened case #7906, I think I need to improve a bit my "reporting skill".

Thanks for the great works,

Cédric

Last edited on May 13, 2014 at 9:30:21 AM by dkocher (previous) (diff)

comment:8 Changed on May 12, 2014 at 8:21:56 PM by dafresh

Hello,

Issue seems still present with r14580.

Thanks !

comment:9 Changed on May 13, 2014 at 8:28:13 AM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed on May 13, 2014 at 1:46:45 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Additional fix in r14596.

comment:11 Changed on May 13, 2014 at 1:54:23 PM by dkocher

Added test in r14597.

comment:12 follow-up: Changed on May 14, 2014 at 3:51:36 PM by dafresh

I confirm, works with r14615 .

Thanks !

comment:13 in reply to: ↑ 12 Changed on May 14, 2014 at 6:44:08 PM by dkocher

Replying to dafresh:

I confirm, works with r14615 .

Thanks !

Thanks for testing.

Note: See TracTickets for help on using tickets.
swiss made software