Cyberduck Mountain Duck CLI

#7942 closed defect (worksforme)

Sometimes doesn't upload files when using Sublime Text 3

Reported by: rafael maiolla (2) Owned by:
Priority: normal Milestone: 4.4.5
Component: core Version: 4.4.4
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

I don't know if editing the file using Sublime Text has anything to do with the bug, but it is the editor I'm currently using.

The problem is that sometimes, Cyberduck doesn't identify that the file has changed and it doesn't upload it.

I'm currently using Cyberduck, but everytime I save a file, I need to check in the Cyberduck log to make sure it has upload the file. I don't know what is causing it and not in what conditions it is not uploading.

I'm editing js files using Sublime Text 3 with the following plugins:

  • DocBlockr
  • Emmet
  • FileDiffs
  • SublimeLinter
  • SublimerLinter-jshint

Sublime Text 3 - Settings User

	"auto_complete_commit_on_tab": true,
	"bold_folder_labels": true,
	"caret_style": "phase",
	"color_scheme": "Packages/User/Monokai (SL).tmTheme",
	"default_line_ending": "unix",
	"ensure_newline_at_eof_on_save": false,
	"font_size": 10,
	"highlight_line": true,
	"highlight_modified_tabs": true,
	"ignored_packages":
	[
		"Vintage"
	],
	"indent_guide_options":
	[
		"draw_normal",
		"draw_active"
	],
	"scroll_past_end": false,
	"shift_tab_unindent": true,
	"show_encoding": true,
	"show_line_endings": true,
	"show_tab_close_buttons": false,
	"spell_check": true,
	"tab_size": 4,
	"translate_tabs_to_spaces": true,
	"trim_trailing_white_space_on_save": true

Change History (11)

comment:1 Changed on May 8, 2014 at 2:26:59 PM by dkocher

  • Description modified (diff)
  • Summary changed from Cyberduck sometimes doesn't upload files when using Sublime Text 3 to Sometimes doesn't upload files when using Sublime Text 3

comment:2 Changed on May 9, 2014 at 7:51:03 AM by dkocher

I tried to replicate the issue but haven't seen this issue so far. Please note that we do not upload the file if the checksum (the content) did not change.

comment:3 Changed on May 9, 2014 at 7:51:14 AM by dkocher

  • Milestone set to 4.4.5

comment:4 Changed on May 9, 2014 at 7:51:54 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 follow-up: Changed on May 12, 2014 at 5:01:43 PM by rafael maiolla (2)

Maybe the atomic_save is causing this problem.

Please note that it works fine for Sublime Text 2 but not on Sublime Text 3

comment:6 Changed on May 12, 2014 at 5:52:05 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:7 in reply to: ↑ 5 Changed on May 12, 2014 at 5:55:00 PM by dkocher

Replying to rafael maiolla (2):

Maybe the atomic_save is causing this problem.

Please note that it works fine for Sublime Text 2 but not on Sublime Text 3

I have wrongfully tested with Sublime Text 2 although the ticket mentions this is only an issue with version 3. The atomic save could very well be the cause of the problem as it possibly removes the original file and creates a new file upon save. I suggest to set

"atomic_save": false

in the meantime.

comment:8 Changed on May 12, 2014 at 6:20:47 PM by rafael maiolla (2)

I had tested that before opening this ticket, but maybe Sublime Text 3 is also bugged, because I set "atomic_save": false in my configuration and that didn't make any difference.

comment:9 Changed on May 16, 2014 at 9:13:35 AM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

I have tested again with Sublime Text 3 but I am not able to reproduce the issue.

comment:10 Changed on Aug 13, 2014 at 7:26:12 PM by dkocher

#8174 closed as duplicate.

comment:11 Changed on Oct 7, 2014 at 4:23:45 PM by dkocher

#8211 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software