Cyberduck Mountain Duck CLI

#7979 closed defect (duplicate)

Unsupported Content-Coding: unknown error

Reported by: miwasaki Owned by: dkocher
Priority: high Milestone: 4.4.5
Component: webdav Version: 4.4.4
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description (last modified by dkocher)

I can connect webdav server from cyberduck. But, I cannot open file following error occur.

PROPFIND /content/dav/st/xxxxx/Documents/Nov.txt HTTP/1.1
Depth: 1
Content-Type: text/xml; charset=utf-8
Content-Length: 99
Host: stbeehive.oracle.com
Connection: Keep-Alive
User-Agent: Cyberduck/4.4.4 (Mac OS X/10.9.3) (x86_64)
Accept-Encoding: gzip,deflate
HTTP/1.1 207 
Date: Tue, 27 May 2014 00:01:02 GMT
Server: Oracle-Application-Server-10g
Content-Length: 737
Keep-Alive: timeout=15, max=93
Connection: Keep-Alive
Content-Type: text/xml; charset="UTF-8"
GET /content/dav/st/xxxxx/Documents/Nov.txt HTTP/1.1
Host: stbeehive.oracle.com
Connection: Keep-Alive
User-Agent: Cyberduck/4.4.4 (Mac OS X/10.9.3) (x86_64)
Accept-Encoding: gzip,deflate

Attachments (2)

duckerr.jpg (23.7 KB) - added by miwasaki on May 27, 2014 at 11:24:28 AM.
duckerr2.jpg (31.5 KB) - added by miwasaki on May 27, 2014 at 11:27:51 AM.

Download all attachments as: .zip

Change History (12)

comment:1 Changed on May 27, 2014 at 8:39:16 AM by dkocher

  • Description modified (diff)
  • Milestone changed from 4.5 to 4.4.5

comment:2 Changed on May 27, 2014 at 8:43:29 AM by dkocher

Please post the error message displayed.

Changed on May 27, 2014 at 11:24:28 AM by miwasaki

comment:3 Changed on May 27, 2014 at 11:26:26 AM by miwasaki

"Unsupported Content-Coding: unknown."

I had used same server and configuration before upgrade.

Changed on May 27, 2014 at 11:27:51 AM by miwasaki

comment:4 Changed on May 27, 2014 at 11:31:49 AM by miwasaki

if click "continue", dialog "duckerr2.jpg" appear.

I can use Windows webdav function of same server, probably CyberDuck have a problem on this version.

comment:5 Changed on May 27, 2014 at 7:10:31 PM by dkocher

The server is sending a Content-Coding header that has a different value than gzip, deflate or identity.

comment:6 Changed on May 27, 2014 at 7:10:46 PM by dkocher

  • Summary changed from Open webdav file error, encoding issue to Unsupported Content-Coding: unknown error

comment:7 Changed on May 30, 2014 at 8:38:37 AM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #6248.

comment:8 Changed on May 30, 2014 at 8:40:43 AM by dkocher

This is an interoperability issue caused by a thirdparty server software bug. Use the hidden preference to disable HTTP compression.

defaults write ch.sudo.cyberduck http.compression.enable false

comment:9 follow-up: Changed on May 30, 2014 at 11:55:57 AM by miwasaki

I already checked this hidden parameter and does not resolve issue...

comment:10 in reply to: ↑ 9 Changed on Jun 12, 2014 at 12:27:32 PM by dkocher

Replying to miwasaki:

I already checked this hidden parameter and does not resolve issue...

In #8015.

Note: See TracTickets for help on using tickets.
swiss made software