Cyberduck Mountain Duck CLI

#8006 closed defect (fixed)

Interoperability with fatcow FTP Server

Reported by: chermeier Owned by: dkocher
Priority: normal Milestone: 4.5
Component: ftp Version: 4.4.4
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Hello, I can log into my account perfectly fine, but when attempting to display the contents of one of my directories, I get the following error message:

NOOP
425 Unable to build data connection: Connection refused
CWD /public_html/awcfilms.com/wp-content
200 NOOP command successful
TYPE A
200 NOOP command successful
PASV
250 CWD command successful
PORT 10,0,0,4,196,69
200 Type set to A
MLSD
227 Entering Passive Mode (66,96,160,149,123,123)

Please tell me what I need to do to get my directories to display. I did not have this issue before I updated.

Thank you, Cheryl

Attachments (2)

trueLog.txt (1.4 KB) - added by dottore on Jun 16, 2014 at 4:06:57 PM.
dottore - set ftp.command.stat to true, use bookmark to access ftp site
falseLog.txt (3.5 KB) - added by dottore on Jun 16, 2014 at 4:07:25 PM.
dottore - set ftp.command.stat to false, use bookmark to access ftp site

Download all attachments as: .zip

Change History (36)

comment:1 Changed on Jun 10, 2014 at 7:53:37 AM by dkocher

  • Component changed from core to ftp
  • Description modified (diff)
  • Owner set to dkocher

comment:2 Changed on Jun 10, 2014 at 9:08:13 AM by dkocher

#7998 closed as duplicate.

comment:3 Changed on Jun 11, 2014 at 2:05:43 PM by dkocher

Please post the full transcript from the log drawer (⌘-L).

comment:4 Changed on Jun 14, 2014 at 7:53:04 PM by gestler

I'm having a similar issue with three of my bookmarked sites that previously worked. In one case, the file list that opens contains only the names of folders but none of the .php files nor the contents of any of the folders. Here's the content of the alert:

NOOP
200 PORT command successful
CWD /images
200 NOOP command successful
TYPE A
250 CWD command successful
PASV
200 Type set to A
PORT 192,168,1,2,237,128
227 Entering Passive Mode (65,254,248,197,103,203)
MLSD
200 PORT command successful

= = =

Last edited on Jun 14, 2014 at 9:08:18 PM by dkocher (previous) (diff)

comment:5 Changed on Jun 15, 2014 at 4:48:01 PM by gestler

Just a follow-up. I downloaded and installed FileZilla and the site is performing as it should with that application.

comment:6 Changed on Jun 16, 2014 at 7:33:01 AM by blitzkrieg917

im having same issue…it was working fine then it stopped working (4.4.3), i didnt change any settings in cyberduck and it gave me they 200 Type set to A. Connection Failed error…then i updated to 4.4.5 and now get connection failed 250 cwd thing…i too used filezilla and my webhost file manager and can upload just fine and see directories….cyberduck does not show all the files in one of my directories even if i refresh but they appear in filezilla etc.

comment:7 Changed on Jun 16, 2014 at 3:37:44 PM by dkocher

#8026 closed as duplicate.

comment:8 Changed on Jun 16, 2014 at 3:38:40 PM by dkocher

#8023 closed as duplicate.

comment:9 Changed on Jun 16, 2014 at 3:43:21 PM by dkocher

#8018 closed as duplicate.

comment:10 Changed on Jun 16, 2014 at 3:48:50 PM by dkocher

Attempted fix with r14782 to fail fast on interoperability issues. Require 200 reply code for NOOP.

comment:11 Changed on Jun 16, 2014 at 3:49:06 PM by dkocher

Attempted fix with r14783 to fail fast on interoperability issues. Require 215 reply code for CWD.

comment:12 Changed on Jun 16, 2014 at 3:49:23 PM by dkocher

Please update to the latest snapshot build available.

comment:13 follow-up: Changed on Jun 16, 2014 at 3:57:27 PM by gestler

Updated to latest snapshot build but still unable to see .php files or folder contents.

comment:14 in reply to: ↑ 13 Changed on Jun 16, 2014 at 3:58:03 PM by dkocher

Replying to gestler:

Updated to latest snapshot build but still unable to see .php files or folder contents.

Thanks for your reply. Can you please post the current transcript from the log drawer (⌘-L).

comment:15 Changed on Jun 16, 2014 at 4:02:41 PM by gestler

Here are the contents of the log frawer when I attempt to open one of the folders on my site

NOOP
213--rw-r--r--   1 1564466  15000        5635 Aug 17  2013 about.php
 -rw-r--r--   1 1564466  15000       10807 Jun  9 13:13 adoptees.php
 -rw-r--r--   1 1564466  15000         474 Aug 17  2013 analyticstracking.php
 -rw-r--r--   1 1564466  15000        2086 Dec 11  2013 application.php
 -rw-r--r--   1 1564466  15000       12608 Jun 14 12:32 available_cats.php
 -rw-r--r--   1 1564466  15000        2575 Apr 13 22:25 community.php
 -rw-r--r--   1 1564466  15000        4048 Apr 13 22:25 donate.php
 -rw-r--r--   1 1564466  15000        4186 Aug 27  2012 faq.php
 -rw-r--r--   1 1564466  15000         909 Aug  1  2011 footer.php
 -rw-r--r--   1 1564466  15000        6978 Aug 17  2013 foster.php
 -rw-r--r--   1 1564466  15000        3383 Apr 13 22:25 fundraising.php
 -rw-------   1 1564466  15000          53 Aug  1  2011 google7499cde44ef18bee.html
 -rw-r--r--   1 1564466  15000        3697 Aug 11  2012 header.php
 -rw-r--r--   1 1564466  15000       18941 Jun 14 12:32 index.php
 -rw-r--r--   1 1564466  15000       11221 Apr 24  2012 indexold.php
 -rw-r--r--   1 1564466  15000        5280 Aug 17  2013 mission.php
 -rw-r--r--   1 1564466  15000        2694 Apr 29 23:02 more_kittens.php
 -rw-r--r--   1 1564466  15000       10312 Jun 24  2013 news.php
 -rw-r--r--   1 1564466  15000        3990 Aug 17  2013 paws.php
 -rw-r--r--   1 1564466  15000        2859 Aug 27  2012 picture_album.php
 -rw-r--r--   1 1564466  15000        1980 Aug 17  2013 pie_order_form.php
 -rw-r--r--   1 1564466  15000        9975 Apr 13 22:24 pop_in_the_news.php
 -rw-r--r--   1 1564466  15000        7113 Jan  5 20:09 rehobeth.php
 -rw-r--r--   1 1564466  15000        3779 Aug 27  2012 sponsor.php
 -rw-r--r--   1 1564466  15000       15897 Jun  6 11:46 tails.php
 -rw-r--r--   1 1564466  15000       71346 Jun  6 11:46 tailsdetails.php
 -rw-r--r--   1 1564466  15000       10162 Apr 13 22:25 thanks.php
 -rw-r--r--   1 1564466  15000        5696 Feb 13 21:22 tnr.php
 -rw-r--r--   1 1564466  15000        5169 Aug 17  2013 volunteer.php
213 -rw-r--r--   1 1564466  15000        3795 Apr 13 22:25 wishlist.php
220 fatcow FTP Server Ready
USER bowwow
331 Password required for bowwow
PASS ********
230 User bowwow logged in
FEAT
211-Features:
 SITE MKDIR
 MFF modify;UNIX.group;UNIX.mode;
 REST STREAM
 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
 UTF8
 LANG en-US*
 EPRT
 SITE SYMLINK
 EPSV
 SITE UTIME
 MDTM
 SITE RMDIR
 TVFS
 SITE COPY
 MFMT
 SIZE
211 End
OPTS UTF8 ON
200 UTF8 set to on
SYST
215 UNIX Type: L8
STAT /css
212-Status of /css:
 drwxr-xr-x   2 1564466  15000           4 Jul 25  2011 .
 drwxr-x---  13 1564466  15000          44 Jun 13 18:36 ..
 End of status
212 -rw-r--r--   1 1564466  15000        5930 May  2 13:29 screen.css
NOOP
213 -rw-r--r--   1 1564466  15000        3409 Jul 13  2012 superfish.css
220 fatcow FTP Server Ready
USER bowwow
331 Password required for bowwow
PASS ********
230 User bowwow logged in
FEAT
211-Features:
 SITE MKDIR
 MFF modify;UNIX.group;UNIX.mode;
 REST STREAM
 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
 UTF8
 LANG en-US*
 EPRT
 SITE SYMLINK
 EPSV
 SITE UTIME
 MDTM
 SITE RMDIR
 TVFS
 SITE COPY
 MFMT
 SIZE
211 End
OPTS UTF8 ON
200 UTF8 set to on
SYST
215 UNIX Type: L8
STAT /cgi-bin
212-Status of /cgi-bin:
 drwxr-xr-x   3 1564466  15000           4 Jan 19 19:56 .
 drwxr-x---  13 1564466  15000          44 Jun 13 18:36 ..
 drwxr-xr-x   2 1564466  15000           2 May 25  2009 tmp
 End of status
212 -rw-r--r--   1 1564466  15000        9859 Jan 19 19:56 adoptees.php
Last edited on Jun 16, 2014 at 4:15:43 PM by dkocher (previous) (diff)

comment:16 Changed on Jun 16, 2014 at 4:05:46 PM by gestler

. . . and here are the log drawer contents when first opening the connection:

220 fatcow FTP Server Ready
USER bowwow
331 Password required for bowwow
PASS ********
230 User bowwow logged in
FEAT
211-Features:
 SITE MKDIR
 MFF modify;UNIX.group;UNIX.mode;
 REST STREAM
 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
 UTF8
 LANG en-US*
 EPRT
 SITE SYMLINK
 EPSV
 SITE UTIME
 MDTM
 SITE RMDIR
 TVFS
 SITE COPY
 MFMT
 SIZE
211 End
OPTS UTF8 ON
200 UTF8 set to on
SYST
215 UNIX Type: L8
PWD
257 "/" is the current directory
STAT /cgi-bin
212-Status of /cgi-bin:
 drwxr-xr-x   3 1564466  15000           4 Jan 19 19:56 .
 drwxr-x---  13 1564466  15000          44 Jun 13 18:36 ..
 drwxr-xr-x   2 1564466  15000           2 May 25  2009 tmp
 End of status
212 -rw-r--r--   1 1564466  15000        9859 Jan 19 19:56 adoptees.php
NOOP
200 NOOP command successful
STAT /
212-Status of /:
 drwxr-x---  13 1564466  15000          44 Jun 13 18:36 .
 drwxr-x---  13 1564466  15000          44 Jun 13 18:36 ..
 drwxrwxr-x   2 99       15000           2 Jun 13 18:36 .trellix
 drwxr-xr-x   3 1564466  15000           4 Jan 19 19:56 cgi-bin
 drwxr-xr-x   2 1564466  15000           4 Jul 25  2011 css
 drwxr-xr-x   5 1564466  15000           5 Dec  5  2013 data1
 drwxr-xr-x   2 1564466  15000          10 Jul 13  2012 engine1
 drwxr-xr-x   3 1564466  15000           4 Jun 28  2012 ie6update
 drwxr-xr-x   3 1564466  15000         384 Jun 14 12:31 images
 drwxr-xr-x   2 1564466  15000          12 Oct 23  2011 js
 drwxr-xr-x   3 1564466  15000           3 Mar 22 22:20 old
 drwxr-xr-x   2 1564466  15000          27 May 20 23:13 pdf
 drwxr-xr-x   2 1564466  15000         914 Jun 16 04:35 stats
 End of status
212 -rwxr-xr-x   1 1564466  15000           3 May 25  2009 .membership

Last edited on Jun 16, 2014 at 4:16:22 PM by dkocher (previous) (diff)

Changed on Jun 16, 2014 at 4:06:57 PM by dottore

dottore - set ftp.command.stat to true, use bookmark to access ftp site

Changed on Jun 16, 2014 at 4:07:25 PM by dottore

dottore - set ftp.command.stat to false, use bookmark to access ftp site

comment:17 Changed on Jun 16, 2014 at 4:10:59 PM by dottore

I had the same experience as gestler.

  • download and install snapshot build
  • set ftp.command.stat true
  • launch cyberduck
  • directory listing fails
  • close cyberduck
  • set ftp.command.stat false
  • launch cyberduck
  • directory listing works fine.
Last edited on Jun 16, 2014 at 4:27:25 PM by dkocher (previous) (diff)

comment:18 Changed on Jun 16, 2014 at 4:17:36 PM by dkocher

  • Summary changed from Error when attempting to display a directory to Interoperability with fatcow FTP Server

comment:19 Changed on Jun 16, 2014 at 5:09:59 PM by gestler

Could someone provide detailed instructions for changing the ftp.command.stat to "true"?

In response to the comment about accessing the site via a bookmark, I attempted that but still do not see the .php files.

Last edited on Jun 18, 2014 at 11:31:04 AM by dkocher (previous) (diff)

comment:20 Changed on Jun 16, 2014 at 5:53:38 PM by dottore

to set ftp.command.stat to false (which will make cyberduck list directories correctly) do the following: quit cyberduck

launch terminal (in the utilities folder).

in the terminal window type the following:

defaults write ch.sudo.cyberduck ftp.command.stat false

hit enter.

launch cyberduck

that's it.

to set it to true, replace "false" with "true" and repeat.

you must relaunch cyberduck after doing this to see the effect.

Last edited on Jun 16, 2014 at 7:46:35 PM by dkocher (previous) (diff)

comment:21 Changed on Jun 16, 2014 at 6:10:37 PM by gestler

Thanks. That resolved the issue for me.

comment:22 Changed on Jun 16, 2014 at 8:39:57 PM by dkocher

The root cause of this issue is the server sending a malformed reply that includes a terminated reply line in between.

comment:23 Changed on Jun 16, 2014 at 8:41:20 PM by dkocher

#8028 closed as duplicate.

comment:24 Changed on Jun 16, 2014 at 8:42:28 PM by dottore

nice detective work!!

We can use the hidden default until FatCow gets its act together. Thanks!!!

comment:25 follow-up: Changed on Jun 17, 2014 at 12:52:57 AM by Superman

The solutions presented so far are only temporary. Eventually, it goes back to incorrectly listing the directories. This is really frustrating.

comment:26 follow-up: Changed on Jun 17, 2014 at 4:06:40 AM by blitzkrieg917

if this prob is a result of some recent update, is there a version we can download thats 4.4.3 or less till the prob gets fixed

comment:27 Changed on Jun 17, 2014 at 5:35:17 AM by dottore

Superman -- what do you mean by temporary?? You say it goes back to incorretly listing directories, but I don't see that on my system.

Maybe you are working with a different web server? or have a somewhat different issue?

I am using FatCow and using cyberduck to ftp to/from a FatCow hosted website. I have entered

defaults write ch.sudo.cyberduck ftp.command.stat false

in a terminal window. After doing that I have been able to use cyberduck without any problems with my website on FatCow.

I ask this because its important for the person working on the problem to know any details that might be different for each of us.

Version 0, edited on Jun 17, 2014 at 5:35:17 AM by dottore (next)

comment:28 Changed on Jun 17, 2014 at 10:32:37 AM by dkocher

#8029 closed as duplicate.

comment:29 in reply to: ↑ 26 Changed on Jun 17, 2014 at 10:33:21 AM by dkocher

Replying to blitzkrieg917:

if this prob is a result of some recent update, is there a version we can download thats 4.4.3 or less till the prob gets fixed

Previous releases can be found on http://cyberduck.io/changelog/.

comment:30 Changed on Jun 17, 2014 at 10:34:12 AM by dkocher

#8030 closed as duplicate.

comment:31 Changed on Jun 17, 2014 at 12:57:51 PM by dkocher

#8033 closed as duplicate.

comment:32 in reply to: ↑ 25 Changed on Jun 18, 2014 at 11:31:45 AM by dkocher

Replying to Superman:

The solutions presented so far are only temporary. Eventually, it goes back to incorrectly listing the directories. This is really frustrating.

That should not be the case if you disable the use of STAT.

comment:33 Changed on Jun 18, 2014 at 11:32:44 AM by dkocher

  • Milestone set to 4.5
  • Resolution set to fixed
  • Status changed from new to closed

Give precedence to use MLSD if available as a workaround in r14803.

comment:34 Changed on Jun 18, 2014 at 3:54:09 PM by blitzkrieg917

went back to using 4.4.2 and my directory looks and acts like it should

Note: See TracTickets for help on using tickets.
swiss made software