Cyberduck Mountain Duck CLI

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8009 closed defect (fixed)

Keeps asking for private key password

Reported by: josot Owned by: dkocher
Priority: normal Milestone: 4.5
Component: sftp Version: 4.4.5
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

Where 4.4.4 worked fine (either retreiving the password from the Apple Keychain or using ssh-agent, I'm not sure...), with 4.4.5 I need to enter my private key password on every connection.

I use ssh-agent and I check the "Add to Keychain" box, but the password keeps being requested...

Change History (9)

comment:1 Changed 4 years ago by dkocher

  • Milestone set to 4.5
  • Summary changed from in v4.4.5, sftp with PKA keeps asking for private key password to Keeps asking for private key password
  • Version set to 4.4.5

comment:2 Changed 4 years ago by dkocher

Can you reproduce this issue with the latest 4.5 snapshot build available?

comment:3 Changed 4 years ago by josot

The issue still exists in 4.5 (snapshot)

comment:4 Changed 4 years ago by dkocher

  • Status changed from new to assigned

comment:5 Changed 4 years ago by dkocher

Regression in r14642.

comment:6 Changed 4 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r14795.

comment:7 Changed 4 years ago by josot

Installed snapshot 4.5 (14799) and the issue is resolved.

Great!

comment:8 Changed 4 years ago by dkocher

#8079 closed as duplicate.

comment:9 Changed 4 years ago by oldmankit

This fixes it, thank you!

Note: See TracTickets for help on using tickets.
swiss made software