Cyberduck Mountain Duck CLI

#8023 closed defect (duplicate)

Interoperability with fatcow FTP Server

Reported by: dottore Owned by: dkocher
Priority: high Milestone: 4.5
Component: ftp Version: 4.4.5
Severity: major Keywords:
Cc: Architecture:
Platform: Mac OS X 10.6

Description (last modified by dkocher)

This may not be a cyberduck problem, but its weird and I need help.

I connect to my ftp site (hosted by FatCow). I am using bookmark when I do so and I authenticate without any error messages. The browser opens and shows me my home director. But -- instead of showing me both files and directories, I see only directories. E.g. the browser shows cgi-bin, log, listmanager, etc., which are all directories. the little folder icon is next to each of them. but none of my files show. E.g. index.html is not listed.

I bravely click on one of the directories, to navigate to that directory and again, I see only the directories in that directory. I click refresh -- sometimes I see nothing (as if the directory is empty), sometimes I see only the files and sometimes I see only the directories. It seems random.

Occasionally I get a pop up window with something like this:

NOOP
213--rw-r--r--   1 2313745  15000        9403 May 18 01:09 Bibliography.html
 -rw-r--r--   1 2313745  15000       12289 May 18 01:11 Camas_Field.html
 -rw-r--r--   1 2313745  15000        9135 May 18 01:09 Defiance.html
 -rw-r--r--   1 2313745  15000       17230 May 19 14:16 Home.html
 -rw-r--r--   1 2313745  15000       44005 May 18 22:02 InvasiveSpecies.html
 -rw-r--r--   1 2313745  15000        7765 May 18 01:09 Jenkins.html
 -rw-r--r--   1 2313745  15000       17412 May 18 22:01 Links.html
 -rw-r--r--   1 2313745  15000       18176 May 18 01:09 Mulch.html
 -rw-r--r--   1 2313745  15000        8168 May 19 14:16 RoxhillPark.html
 -rw-r--r--   1 2313745  15000        9510 May 19 14:16 family.html
 -rw-r--r--   1 2313745  15000        5441 May 19 14:16 feed.xml
 -rw-r--r--   1 2313745  15000         306 May 18 01:09 index.html
 -rw-r--r--   1 2313745  15000       15346 May 18 01:09 myPropagationResults.html
 -rw-r--r--   1 2313745  15000       17258 May 19 14:16 nativePlantInfo.html
 -rw-r--r--   1 2313745  15000       14717 May 18 01:09 photosFromMyPreviousGarden.html
 -rw-r--r--   1 2313745  15000       11106 May 19 14:16 plantID.html
213 -rw-r--r--   1 2313745  15000       11913 May 18 01:09 songs.html
STAT /dp
200 NOOP command successful
CWD /dp
212-Status of /dp:
 drwxr-xr-x  21 2313745  15000          39 May 18 01:53 .
 drwxr-x---  14 2313745  15000          24 May 20 11:08 ..
 drwxr-xr-x   2 2313745  15000          16 May 18 01:09 Aerials_files
 drwxr-xr-x   2 2313745  15000          13 May 18 01:09 Bibliography_files
 drwxr-xr-x   2 2313745  15000          15 May 18 01:09 Camas_Field_files
 drwxr-xr-x   2 2313745  15000          18 May 18 01:09 Defiance_files
 drwxr-xr-x   2 2313745  15000          24 May 18 22:01 Home_files
 drwxr-xr-x   2 2313745  15000          95 May 18 22:02 InvasiveSpecies_files
 drwxr-xr-x   2 2313745  15000          14 May 18 01:09 Jenkins_files
 drwxr-xr-x   2 2313745  15000          15 May 18 22:01 Links_files
 drwxr-xr-x   2 2313745  15000           4 May 18 01:09 Media
 drwxr-xr-x   2 2313745  15000          13 May 18 01:09 Mulch_files
 drwxr-xr-x   2 2313745  15000          13 May 18 22:01 RoxhillPark_files
 drwxr-xr-x   3 2313745  15000           6 Sep  1  2011 Scripts
 drwxr-xr-x   2 2313745  15000          16 May 18 22:01 family_files
 drwxr-xr-x   2 2313745  15000          11 May 18 01:09 myPropagationResults_files
 drwxr-xr-x   2 2313745  15000          17 May 18 22:01 nativePlantInfo_files
 drwxr-xr-x  11 2313745  15000          11 May 18 01:11 photoPages
 drwxr-xr-x   2 2313745  15000          30 May 18 01:09 photosFromMyPreviousGarden_files
 drwxr-xr-x   2 2313745  15000          15 May 18 22:01 plantID_files
 drwxr-xr-x   2 2313745  15000          19 May 18 01:09 songs_files
 End of status
212 -rw-r--r--   1 2313745  15000        8633 May 18 01:09 Aerials.html
TYPE A
213--rw-r--r--   1 2313745  15000        9403 May 18 01:09 Bibliography.html
 -rw-r--r--   1 2313745  15000       12289 May 18 01:11 Camas_Field.html
 -rw-r--r--   1 2313745  15000        9135 May 18 01:09 Defiance.html
 -rw-r--r--   1 2313745  15000       17230 May 19 14:16 Home.html
 -rw-r--r--   1 2313745  15000       44005 May 18 22:02 InvasiveSpecies.html
 -rw-r--r--   1 2313745  15000        7765 May 18 01:09 Jenkins.html
 -rw-r--r--   1 2313745  15000       17412 May 18 22:01 Links.html
 -rw-r--r--   1 2313745  15000       18176 May 18 01:09 Mulch.html
 -rw-r--r--   1 2313745  15000        8168 May 19 14:16 RoxhillPark.html
 -rw-r--r--   1 2313745  15000        9510 May 19 14:16 family.html
 -rw-r--r--   1 2313745  15000        5441 May 19 14:16 feed.xml
 -rw-r--r--   1 2313745  15000         306 May 18 01:09 index.html
 -rw-r--r--   1 2313745  15000       15346 May 18 01:09 myPropagationResults.html
 -rw-r--r--   1 2313745  15000       17258 May 19 14:16 nativePlantInfo.html
 -rw-r--r--   1 2313745  15000       14717 May 18 01:09 photosFromMyPreviousGarden.html
 -rw-r--r--   1 2313745  15000       11106 May 19 14:16 plantID.html
213 -rw-r--r--   1 2313745  15000       11913 May 18 01:09 songs.html
PASV
250 CWD command successful
PORT 192,168,0,100,252,237
200 Type set to A
MLSD
227 Entering Passive Mode (65,254,248,192,155,242)

I have a feeling that the problem is NOT with cyberduck, but can you help me understand what is going on so I can talk intelligently to my web host???? Or is there some setting in preferences that I need to set (I've looked and seen nothing).

I know the website is OK because I can access the files using a web browser (e.g. safari).

help!!!! I need to update my website tonight and I'm stuck.

Attachments (1)

comLineFTP.txt (1.6 KB) - added by dottore on Jun 15, 2014 at 4:12:13 AM.
shows command line FTP working successfully

Download all attachments as: .zip

Change History (10)

Changed on Jun 15, 2014 at 4:12:13 AM by dottore

shows command line FTP working successfully

comment:1 Changed on Jun 15, 2014 at 4:21:19 AM by dottore

OK, this just might be a cyberduck problem (or operator error on my part).

  • I am able to use FTP from the UNIX command line. See the attached file comLineFTP.txt. Notice that in my home directory the command 'ls' returns both files and directories.
  • Using cyberduck I tried to send commands to the server. I assume these are supposed to be ftp commands. I.e. I clicked Go->Send Command... a window pops up. I enter ls into the command line. I click send. I get:
     220 fatcow FTP Server Ready
USER davidperasso

331 Password required for davidperasso
PASS ********
230 User davidperasso logged in
FEAT
211-Features:
 EPSV
 SITE UTIME
 MDTM
 SITE RMDIR
 TVFS
 SITE COPY
 MFMT
 SIZE
 SITE MKDIR
 MFF modify;UNIX.group;UNIX.mode;
 REST STREAM
 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
 UTF8
 LANG en-US*
 EPRT
 SITE SYMLINK
211 End
OPTS UTF8 ON
200 UTF8 set to on
SYST
215 UNIX Type: L8

SITE ls

500 'SITE LS' not understood

I'm not sure if cyberduck is supposed to send 'SITE ls' or 'ls' but it obviously doesn't return the directory listing.

Last edited on Jun 15, 2014 at 6:46:57 AM by dkocher (previous) (diff)

comment:3 Changed on Jun 15, 2014 at 4:23:07 AM by dottore

  • Severity changed from blocker to major

comment:4 Changed on Jun 15, 2014 at 6:40:32 AM by dkocher

  • Component changed from core to ftp
  • Description modified (diff)
  • Owner set to dkocher

comment:5 Changed on Jun 15, 2014 at 6:57:09 AM by dkocher

This looks like an interoperability issue with the use of STATfor directory listings. Can you try disabling it with the hidden preference.

comment:6 Changed on Jun 15, 2014 at 3:33:29 PM by dottore

Using a terminal window I entered:

defaults write ch.sudo.cyberduck ftp.command.stat false

and restarted cyberduck.

directory listing behavior is OK now!!!!! thanks.

Will I have to do this every time I reboot my system?

Do you have any idea why this is now a problem. I have been using cyberduck with the same web host for two years with no problems and suddenly this happens. I would like to be able to feedback to my web host provider and let them know that they did something that caused a problem (assuming its them). Its FatCow in case you want to talk to them directly.

thanks.

Last edited on Jun 16, 2014 at 3:39:07 PM by dkocher (previous) (diff)

comment:7 Changed on Jun 16, 2014 at 3:42:25 PM by dkocher

  • Milestone set to 4.5
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from bizarre browser behavior to Directory listing failure caused by `STAT` response handler failure

Duplicate for #8006.

comment:8 Changed on Jun 16, 2014 at 3:49:44 PM by dkocher

Please update to the latest snapshot build available.

comment:9 Changed on Jun 16, 2014 at 4:17:17 PM by dkocher

  • Summary changed from Directory listing failure caused by `STAT` response handler failure to Interoperability with fatcow FTP Server
Note: See TracTickets for help on using tickets.
swiss made software