Cyberduck Mountain Duck CLI

#8032 closed defect (thirdparty)

Interoperability with Archive (ZIP) feature

Reported by: Dirk Owned by: dkocher
Priority: normal Milestone: 4.5.2
Component: sftp Version: 4.4.5
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

Cyberduck stopped creating zip-archives, a function I've been using for years and never had any trouble with. I did not change settings nor the host. I'm using a sftp (ssh.strato) connection. The menu is not greyed out. It just does not create zip archives. I have no problems downloading folders or performing any other task.

Attachments (2)

LogDrawer.rtf (2.6 KB) - added by Dirk on Jun 17, 2014 at 1:12:18 PM.
Transcript from log drawer
LogDrawer2.rtf (450 bytes) - added by Dirk on Jun 18, 2014 at 3:01:35 PM.

Download all attachments as: .zip

Change History (18)

comment:1 Changed on Jun 17, 2014 at 12:34:24 PM by dkocher

  • Component changed from core to sftp
  • Owner set to dkocher

comment:2 Changed on Jun 17, 2014 at 12:56:47 PM by dkocher

Please post the transcript from the log drawer (⌘-L).

comment:3 Changed on Jun 17, 2014 at 12:56:53 PM by dkocher

  • Milestone set to 4.5

Changed on Jun 17, 2014 at 1:12:18 PM by Dirk

Transcript from log drawer

comment:4 Changed on Jun 17, 2014 at 2:04:59 PM by dkocher

Can you reproduce this issue with the latest snapshot build available?

comment:5 follow-up: Changed on Jun 17, 2014 at 8:13:46 PM by Dirk

I updated to version 4.5 (14801), however, the same problem occurs.

comment:6 in reply to: ↑ 5 Changed on Jun 18, 2014 at 10:19:50 AM by dkocher

Replying to Dirk:

I updated to version 4.5 (14801), however, the same problem occurs.

Please post the current transcript from the log drawer (⌘-L).

Changed on Jun 18, 2014 at 3:01:35 PM by Dirk

comment:7 follow-up: Changed on Jun 18, 2014 at 3:02:59 PM by Dirk

I added the current log drawer. Please also note that the new version of the programme opens two identical windows when starting the programm.

comment:8 in reply to: ↑ 7 Changed on Jun 18, 2014 at 3:06:39 PM by dkocher

Replying to Dirk:

I added the current log drawer. Please also note that the new version of the programme opens two identical windows when starting the programm.

zip error: Nothing to do! (try: zip -qr /WordPress_03.zip . -i /WordPress_03)
5 OPENDIR
6 READDIR
7 READDIR
8 CLOSE

comment:9 Changed on Jun 19, 2014 at 3:01:46 PM by dkocher

From the zip error output it looks like there is no such folder WordPress_03 in /.

comment:10 Changed on Jun 19, 2014 at 3:44:20 PM by Dirk

That's really odd, because there obviously is such a folder. My blog runs on this folder, I can open the folder with Cyberduck, change documents etc. I also downloaded the entire folder with Cyberduck after not being able to create a zip and download the zip.

comment:11 Changed on Jun 26, 2014 at 1:24:28 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Can you login to the server using ssh in Terminal.app and enter the same command

zip -qr /WordPress_03.zip.zip WordPress_03

We cannot reproduce this issue on multiple systems with different versions of zip installed.

comment:12 Changed on Jul 24, 2014 at 10:09:53 PM by Dirk

When I use Send Command entering

zip -r WordPress_03.zip WordPress_03

a zip file of the folder WordPress_03 is created. When I use Create Archive>WordPress_03.zip no zip of the folder WordPress_03 is created.

comment:13 Changed on Jul 25, 2014 at 12:26:49 PM by dkocher

  • Milestone changed from 4.5 to 4.5.2
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from Archive (zip) feature not working anymore to Interoperability with Archive (ZIP) feature

comment:14 Changed on Jul 29, 2014 at 4:17:02 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from reopened to closed

The -qoption is just to suppress informational messages and comment prompts. What does zip -v output?

comment:15 Changed on Jul 30, 2014 at 12:43:15 PM by Dirk

When entering

zip -v WordPress_03.zip WordPress_03

the result is

  adding: WordPress_03/	(in=0) (out=0) (stored 0%)
total bytes=0, compressed=0 -> 0% savings

When trying a second time:

updating: WordPress_03/	(in=0) (out=0) (stored 0%)
total bytes=0, compressed=0 -> 0% savings

comment:16 Changed on Jul 30, 2014 at 12:47:30 PM by Dirk

In addition to my last comment: After entering the

zip -v WordPress_03.zip WordPress_03

a zip file is created that only contains an empty WordPress_03 folder.

Note: See TracTickets for help on using tickets.
swiss made software