Cyberduck Mountain Duck CLI

#8038 closed defect (worksforme)

NoSuchMethodError in CMSSignedData class

Reported by: prembo Owned by:
Priority: highest Milestone:
Component: core Version: 4.4.5
Severity: blocker Keywords: stuck, not working
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

Hi,

I recently upgraded to Mavericks. My Cyberduck (Version 4.4.5 - 14720), which was purchased through iTunes, now gets stuck on opening. All I can see is the menu bar at the top.

I can't open a new connection (the menu item is greyed out) and clicking on "New Connection" does nothing either. I can open the Activity and Transfers windows, but can only see the progress spinner spinning.

I have tried removing Cyberduck and reinstalling via iTunes. Still no difference.

Any ideas?

Thank you. Prembo

Attachments (1)

cyberduck_4-4-5_Mavericks-console-output.log (22.0 KB) - added by prembo on Jun 19, 2014 at 7:48:27 AM.
Sample of errors relating to Cyberduck extracted from Mavericks Console.app.

Download all attachments as: .zip

Change History (11)

comment:1 Changed on Jun 18, 2014 at 6:09:11 AM by prembo

PS There is nothing in the log drawer. And the only way I can quit it is to force quit.

Last edited on Jun 18, 2014 at 6:23:01 AM by prembo (previous) (diff)

comment:2 Changed on Jun 18, 2014 at 10:10:42 AM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:3 Changed on Jun 18, 2014 at 10:11:09 AM by dkocher

  • Summary changed from Cyberduck gets stuck on opening - OSX Mavericks to Menu items greyed out and progress spinner

comment:4 follow-up: Changed on Jun 19, 2014 at 7:47:24 AM by prembo

Unfortunately System.log is empty. But I've attached some errors to Cyberduck logged (found by searching for Cyberduck in Console).

Changed on Jun 19, 2014 at 7:48:27 AM by prembo

Sample of errors relating to Cyberduck extracted from Mavericks Console.app.

comment:5 Changed on Jun 19, 2014 at 1:49:40 PM by dkocher

  • Summary changed from Menu items greyed out and progress spinner to NoSuchMethodError in CMSSignedData class

comment:6 in reply to: ↑ 4 Changed on Jun 19, 2014 at 1:50:38 PM by dkocher

Replying to prembo:

Unfortunately System.log is empty. But I've attached some errors to Cyberduck logged (found by searching for Cyberduck in Console).

Caused by: java.lang.NoSuchMethodError: org.bouncycastle.cms.CMSSignedData.getCertificates()Lorg/bouncycastle/util/Store;
	at ch.cyberduck.core.aquaticprime.ReceiptVerifier.verify(ReceiptVerifier.java:80)
	at ch.cyberduck.core.aquaticprime.Receipt$Factory.open(Receipt.java:51)
	at ch.cyberduck.core.aquaticprime.Receipt$Factory.open(Receipt.java:85)
	at ch.cyberduck.core.aquaticprime.LicenseFactory.find(LicenseFactory.java:107)
	at ch.cyberduck.ui.cocoa.MainController.applicationShouldTerminateAfterDonationPrompt(MainController.java:1307)
	at ch.cyberduck.ui.cocoa.MainController.applicationShouldTerminate(MainController.java:1296)
	... 25 more

comment:7 Changed on Jun 19, 2014 at 1:52:37 PM by dkocher

Duplicate for #7931.

comment:8 Changed on Jun 19, 2014 at 1:53:34 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Refer to Incompatibilities. Make sure no libraries (*.jar dependencies) are installed in /Library/Java/Extensions or ~/Library/Java/Extensions respectively. In particular a any Bouncycastle version.

comment:9 Changed on Jun 20, 2014 at 8:16:15 AM by prembo

Interesting - removed it and it seems to be working again. I wonder why this has become an issue on Mavericks + 4.4.5 but not Lion + previous versions of Cyberduck?

comment:10 Changed on Mar 4, 2015 at 12:51:22 PM by dkocher

Fixed in r17096 with setting the extension directories to only include lib/ext from the bundled runtime.

Note: See TracTickets for help on using tickets.
swiss made software