Cyberduck Mountain Duck CLI

#8041 closed defect (thirdparty)

Hang during file transfer

Reported by: toby00001 Owned by: dkocher
Priority: high Milestone:
Component: sftp Version: 4.4.5
Severity: blocker Keywords: sftp, transfers
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

I am suddenly having issues with file transfers (to, from and between sftp servers).

Cyberduck hangs when I try and drag files to, from and between server windows. Also, when I open up Cyberduck and open the Transfers window, a spinning progress icon remains in the centre of the window and nothing happens and usually it hangs.

Attachments (1)

Cyberduck_2014-06-19-080836_Tobys-MacBook-Pro.hang (665.3 KB) - added by toby00001 on Jun 19, 2014 at 3:11:28 PM.
Hang log

Download all attachments as: .zip

Change History (14)

comment:1 Changed on Jun 19, 2014 at 1:54:57 PM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:2 Changed on Jun 19, 2014 at 1:55:14 PM by dkocher

  • Summary changed from SFTP Transfer Issues to Spinning progress icon in Transfer window

comment:3 Changed on Jun 19, 2014 at 3:08:23 PM by toby00001

I just tried recreating the issue, the only thing in the system.log relating to Cyberduck is this:

Jun 19 08:05:01 Tobys-MacBook-Pro.local Cyberduck[1385]: [background-1] ERROR ch.cyberduck.core.serializer.impl.PlistReader - Invalid bookmark file:FinderLocal{bookmark=null, path='/Users/Toby/BTSync/Settings/Cyberduck/Bookmarks/6c58ae72-944d-45c8-ad8f-4db024889bf6.duck'}
Jun 19 08:05:05 Tobys-MacBook-Pro.local WindowServer[125]: _CGXSetWindowBackgroundBlurRadius: Invalid window 0xffffffff
Last edited on Jun 19, 2014 at 3:11:57 PM by dkocher (previous) (diff)

comment:4 Changed on Jun 19, 2014 at 3:13:55 PM by toby00001

Also had this in the system.log after I force quit Cyberduck. Have attached the hang log it refers to.

Jun 19 08:08:33 Tobys-MacBook-Pro com.apple.launchd.peruser.501[399] (ch.sudo.cyberduck.21856[1385]): Exited: Terminated: 15
Jun 19 08:08:36 Tobys-MacBook-Pro.local spindump[1451]: Saved hang report for Cyberduck version 4.4.5 (14721) to /Library/Logs/DiagnosticReports/Cyberduck_2014-06-19-080836_Tobys-MacBook-Pro.hang

comment:5 Changed on Jun 19, 2014 at 3:21:49 PM by dkocher

It looks like you have changed the hidden configuration option application.support.path to point to the BitTorrent Sync folder. Do you still have the same issue if you revert this setting with

defaults delete ~/Library/Preferences/ch.sudo.cyberduck.plist application.support.path
Last edited on Jun 23, 2014 at 8:10:18 PM by dkocher (previous) (diff)

comment:6 Changed on Jun 19, 2014 at 3:22:05 PM by dkocher

  • Summary changed from Spinning progress icon in Transfer window to Interoperability with BitTorrent Sync

comment:7 follow-up: Changed on Jun 19, 2014 at 3:30:00 PM by toby00001

I've had it that way for months. BTSync is just synchronizing my Cyberduck settings between computers, just like one would do with Dropbox.

I just tried completely shutting down BTSync and it didn't help at all.

comment:8 in reply to: ↑ 7 Changed on Jun 20, 2014 at 7:56:14 AM by dkocher

Replying to toby00001:

I've had it that way for months. BTSync is just synchronizing my Cyberduck settings between computers, just like one would do with Dropbox.

I just tried completely shutting down BTSync and it didn't help at all.

Did you try removing the preference to see if it makes a difference?

comment:9 Changed on Jun 23, 2014 at 7:23:42 PM by toby00001

Resetting the preferences didn't help. The only solution I have found is uninstalling and reinstalling Cyberduck every time I have this issue, which is of course inconvenient.

comment:10 Changed on Jun 24, 2014 at 7:06:31 AM by dkocher

I have tried to reproduce the issue with BitTorrent Sync installed but didn't have any issues. Note that application.support.path is no more documented because it will not work when running sandboxed (currently only applies to the Mac App Store version).

comment:11 Changed on Jul 1, 2014 at 2:17:18 AM by toby00001

BitTorrent Sync really isn't the issue here, but thank you for trying to reproduce the issue.

I have tried completely removing BTSync from my system and still have the issue. It comes up after a failed SFTP transfer. Once I have experienced a failed transfer Cyberduck is unable to perform any future transfers until I completely uninstall and reinstall.

comment:12 Changed on Jul 17, 2014 at 9:36:33 AM by dkocher

  • Summary changed from Interoperability with BitTorrent Sync to Hang during file transfer

comment:13 Changed on Jul 17, 2014 at 9:37:48 AM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

My only other wild guess is that the installed Avast virus scanner is the culprit. Please try if deinstalling it makes a difference.

Note: See TracTickets for help on using tickets.
swiss made software