Cyberduck Mountain Duck CLI

#8046 closed defect (worksforme)

copying HTTP link for FTP file may contain wrong URL in href

Reported by: dneuge Owned by: dkocher
Priority: normal Milestone:
Component: interface Version: 4.4.3
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.8

Description

CyberDuck confused two files with each other when constructing an HTTP link to one file which was newly uploaded to an expanded subdirectory on our FTP server. Link text showed the correct URL but when pasted into Apple Mail the href attribute linked the text to another file in the same directory. The error was consistent across CyberDuck restarts/computer reboots but fixed itself upon entering the directory by double-click (some cache/index refresh happening?). Links generated by clicking files from the expanded parent directory were correct afterwards.

The issue is only relevant when pasting into an HTML/RTE-capable editor (such as Apple Mail) and following the link by clicking it or copying the target URL via context menu (but not when copying the rich text). When pasting into a text-only editor/field such as a browser address bar, only the correct URL (same as link text, not HTML/RTF) will be used.

CyberDuck version: 4.4.3 (changelog up to 4.4.5 doesn't indicate changes regarding this issue) / Mac OS X version: 10.8.5

Change History (1)

comment:1 Changed on Jun 20, 2014 at 12:59:46 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I can't explain what went wrong here. We only copy plain text to the clipboard but no HTML or rich text.

Note: See TracTickets for help on using tickets.