Cyberduck Mountain Duck CLI

#8049 closed defect (worksforme)

Connection pool shutdown in account thread

Reported by: barrychapman Owned by: dkocher
Priority: high Milestone: 4.5
Component: cloudfiles Version: 4.4.5
Severity: critical Keywords: connection failure
Cc: Architecture: Intel
Platform: Windows 7

Description (last modified by barrychapman)

When connecting to cloudfiles with 4.4.5, it just goes back to a blank screen. Attached is debug log:

2014-06-21 02:26:09,129 [account-1] INFO  ch.cyberduck.core.ssl.CertificateStoreX509TrustManager - Certificate for storage101.hkg1.clouddrive.com trusted in Keychain
2014-06-21 02:26:09,716 [account-1] DEBUG ch.cyberduck.core.http.DisabledX509HostnameVerifier - Hostname verification disabled for storage101.hkg1.clouddrive.com handled in system trust manager
2014-06-21 02:26:09,716 [account-1] DEBUG org.apache.http.impl.conn.HttpClientConnectionOperator - Connection established 192.168.1.68:50553<->119.9.64.232:443
2014-06-21 02:26:09,716 [account-1] DEBUG org.apache.http.impl.execchain.MainClientExec - Executing request HEAD /v1/MossoCloudFS_040c30d3-1521-4bcf-bf7e-f47b796c7990 HTTP/1.1
2014-06-21 02:26:09,716 [account-1] DEBUG org.apache.http.impl.execchain.MainClientExec - Target auth state: UNCHALLENGED
2014-06-21 02:26:09,716 [account-1] DEBUG org.apache.http.impl.execchain.MainClientExec - Proxy auth state: UNCHALLENGED
2014-06-21 02:26:09,716 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 >> HEAD /v1/MossoCloudFS_040c30d3-1521-4bcf-bf7e-f47b796c7990 HTTP/1.1
2014-06-21 02:26:09,716 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 >> X-Auth-Token: xxxxxxxxxxxxxxxxxxxxx
2014-06-21 02:26:09,716 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 >> Host: storage101.hkg1.clouddrive.com
2014-06-21 02:26:09,717 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 >> Connection: Keep-Alive
2014-06-21 02:26:09,717 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 >> User-Agent: Cyberduck/4.4.4 (14505) (Windows 7/6.1) (x86)
2014-06-21 02:26:09,717 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 >> Accept-Encoding: gzip,deflate
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << HTTP/1.1 204 No Content
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << Content-Type: text/plain; charset=utf-8
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << X-Account-Object-Count: 0
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << X-Timestamp: 1403332048.72126
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << X-Account-Bytes-Used: 0
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << X-Account-Container-Count: 0
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << X-Put-Timestamp: 1403332048.72126
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << Content-Length: 0
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << X-Trans-Id: xxxxxxxxxxxxxxxx-xxxxxxxxx
2014-06-21 02:26:10,012 [account-1] DEBUG org.apache.http.headers - http-outgoing-1 << Date: Sat, 21 Jun 2014 06:27:28 GMT
2014-06-21 02:26:10,013 [account-1] DEBUG org.apache.http.impl.execchain.MainClientExec - Connection can be kept alive indefinitely
2014-06-21 02:26:10,013 [account-1] DEBUG org.apache.http.impl.conn.PoolingHttpClientConnectionManager - Connection [id: 1][route: {s}->https://storage101.hkg1.clouddrive.com:443] can be kept alive indefinitely
2014-06-21 02:26:10,013 [account-1] DEBUG org.apache.http.impl.conn.PoolingHttpClientConnectionManager - Connection released: [id: 1][route: {s}->https://storage101.hkg1.clouddrive.com:443][total kept alive: 0; route allocated: 0 of 2147483647; total allocated: 0 of 2147483647]
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - HTTP/1.1 204 No Content
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - Content-Type: text/plain; charset=utf-8
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - X-Account-Object-Count: 0
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - X-Timestamp: 1403332048.72126
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - X-Account-Bytes-Used: 0
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - X-Account-Container-Count: 0
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - X-Put-Timestamp: 1403332048.72126
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - Content-Length: 0
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - X-Trans-Id: xxxxxxxxxxxxxxxx-xxxxxxxxxxxxxxxx
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - Date: Sat, 21 Jun 2014 06:27:28 GMT
2014-06-21 02:26:10,013 [account-1] DEBUG org.apache.http.impl.execchain.MainClientExec - Cancelling request execution
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.openstack.SwiftSession - Signing key is null
2014-06-21 02:26:10,013 [account-1] DEBUG org.apache.http.client.protocol.RequestAddCookies - CookieSpec selected: best-match
2014-06-21 02:26:10,013 [account-1] DEBUG org.apache.http.client.protocol.RequestAuthCache - Auth cache not set in the context
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - HEAD /v1/MossoCloudFS_040c30d3-1521-4bcf-bf7e-f47b796c7990 HTTP/1.1
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - X-Auth-Token: xxxxxxxxxxxxxxxxxxxxxxx
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - Host: storage101.dfw1.clouddrive.com
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - Connection: Keep-Alive
2014-06-21 02:26:10,013 [account-1] INFO  ch.cyberduck.core.Session - User-Agent: Cyberduck/4.4.4 (14505) (Windows 7/6.1) (x86)
2014-06-21 02:26:10,013 [account-1] DEBUG org.apache.http.impl.conn.PoolingHttpClientConnectionManager - Connection request: [route: {s}->https://storage101.dfw1.clouddrive.com:443][total kept alive: 0; route allocated: 0 of 2147483647; total allocated: 0 of 2147483647]
2014-06-21 02:26:10,013 [account-1] ERROR ch.cyberduck.core.threading.LoggingUncaughtExceptionHandler - Thread account-1 has thrown uncaught exception:Connection pool shut down
java.lang.IllegalStateException: Connection pool shut down
	at org.apache.http.util.Asserts.check(Asserts.java:34)
	at org.apache.http.pool.AbstractConnPool.lease(AbstractConnPool.java:169)
	at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.requestConnection(PoolingHttpClientConnectionManager.java:217)
	at org.apache.http.impl.execchain.MainClientExec.execute(MainClientExec.java:158)
	at org.apache.http.impl.execchain.ProtocolExec.execute(ProtocolExec.java:195)
	at org.apache.http.impl.execchain.RetryExec.execute(RetryExec.java:86)
	at org.apache.http.impl.execchain.RedirectExec.execute(RedirectExec.java:108)
	at org.apache.http.impl.client.InternalHttpClient.doExecute(InternalHttpClient.java:186)
	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:72)
	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:214)
	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:160)
	at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:136)
	at ch.iterate.openstack.swift.Client.execute(Client.java:352)
	at ch.iterate.openstack.swift.Client.getAccountInfo(Client.java:577)
	at ch.cyberduck.core.openstack.SwiftSession$1.run(SwiftSession.java:144)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:57)
	at java.lang.Thread.run(Thread.java:935)


For what its worth, our server is in Chicago (ORD). I dont know if the fact it is connecting to HKG matters?

Thanks

Change History (5)

comment:1 Changed on Jun 21, 2014 at 6:33:16 AM by barrychapman

  • Description modified (diff)

comment:2 Changed on Jun 23, 2014 at 11:53:20 AM by dkocher

Can you post the full log. This looks to be partial and only show a failure for loading the account information which should not have any effect on the browser view.

comment:3 Changed on Jun 23, 2014 at 11:53:37 AM by dkocher

  • Summary changed from Cannot connect to cloudfiles with version 4.4.5 to Connection pool shutdown in account thread

comment:4 in reply to: ↑ description Changed on Jun 26, 2014 at 12:28:38 PM by dkocher

Replying to barrychapman:

For what its worth, our server is in Chicago (ORD). I dont know if the fact it is connecting to HKG matters?

We are always loading containers and account info from all regions.

comment:5 Changed on Jun 26, 2014 at 12:30:23 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue with the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software