Cyberduck Mountain Duck CLI

#8095 closed defect (thirdparty)

Error: Listing directory failed. Method Not Allowed.

Reported by: milligan Owned by: dkocher
Priority: high Milestone:
Component: webdav Version: 4.4.5
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 7

Description

I have been using Cyberduck unlicensed for a few weeks. Today I decided to make a donation, but now I cannot connect to the server where I need to upload files. When I try to connect, I receive an error message stating, Listing directory failed. Method Not Allowed. Help! Cyberduck is useless to me if I cannot access this server.

Attachments (2)

cyberduck-error.png (21.5 KB) - added by milligan on Jul 18, 2014 at 9:37:31 PM.
Error message received when attempting to connect to server
Cyberduck log file-8095.txt (2.1 KB) - added by milligan on Jul 21, 2014 at 6:20:05 PM.
Log file when connecting to WebDav server and attempting to open directory

Download all attachments as: .zip

Change History (13)

Changed on Jul 18, 2014 at 9:37:31 PM by milligan

Error message received when attempting to connect to server

comment:1 Changed on Jul 20, 2014 at 5:53:31 PM by dkocher

  • Platform set to Windows 8

Please post the transcript from the log drawer (Ctrl-L).

comment:2 Changed on Jul 20, 2014 at 5:53:41 PM by dkocher

  • Component changed from core to webdav
  • Owner set to dkocher

comment:3 Changed on Jul 20, 2014 at 5:53:51 PM by dkocher

See also #7227.

comment:4 Changed on Jul 21, 2014 at 3:24:35 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

You possibly have to specify an initial Path in the bookmark. Please contact your web hosting service provider for assistance.

comment:5 Changed on Jul 21, 2014 at 6:18:57 PM by milligan

Sorry, I wasn't available to respond to your comments on this issue over the weekend as I use Cyberduck on my work computer.

I've reviewed them and looked through the linked issues. The only comment that gave me direction was to specify an initial path in the bookmark. I tried this, but it didn't solve the problem. I don't receive the error message, but the directory contents do not list.

I've captured log information from when I connect initially to the WebDav server (which didn't work initially, but started working Friday after I had already logged the bug with Cyberduck). I've also captured the log when I try to open the directory I need to use (where I still get the error). There are significant differences, which no doubt account for the issue, but I'm not technical enough to understand how to fix it. I'm attaching a text file with both issues.

Please note that I am not on Windows 8. My computer is running Windows 7 Professional Service Pack 1. I wish I knew what version of Cyberduck I was using before I decided to make a donation, because that version was working for me.

Regards, Carolyn Milligan

Changed on Jul 21, 2014 at 6:20:05 PM by milligan

Log file when connecting to WebDav server and attempting to open directory

comment:6 Changed on Jul 21, 2014 at 7:04:03 PM by dkocher

  • Platform changed from Windows 8 to Windows 7

comment:7 Changed on Jul 21, 2014 at 7:05:46 PM by dkocher

That is a configuration issue with the web server which does not allow to connect with WebDAV to the path /euf/.

comment:8 follow-up: Changed on Jul 21, 2014 at 7:09:39 PM by milligan

Nothing has change on the web server configuration. I was able to connect to the euf directory before I donated to Cyberduck and installed the registration key. Now I can't. Only Cyberduck changed.

comment:9 in reply to: ↑ 8 ; follow-up: Changed on Jul 21, 2014 at 7:30:00 PM by dkocher

Replying to milligan:

Nothing has change on the web server configuration. I was able to connect to the euf directory before I donated to Cyberduck and installed the registration key. Now I can't. Only Cyberduck changed.

I doubt that. Please contact your web hosting service provider for assistance.

comment:10 in reply to: ↑ 9 ; follow-up: Changed on Jul 21, 2014 at 7:39:09 PM by milligan

Replying to dkocher:

Replying to milligan:

Nothing has change on the web server configuration. I was able to connect to the euf directory before I donated to Cyberduck and installed the registration key. Now I can't. Only Cyberduck changed.

I doubt that. Please contact your web hosting service provider for assistance.

On Friday, I connected to the WebDAV server and uploaded some image files to a sub-directory under /euf/. When I finished and exited Cyberduck, I decided to use the "Donate Now" option and get a registration key. (A decision based on the fact that I've been using Cyberduck for a couple of months and it was meeting my needs for uploading/downloading files to the WebDAV server for our web support platform. As soon as I applied the registration key, it changed my Cyberduck installation, and I haven't been able to connect to the /euf/ directory since then. I seriously doubt the problem is on our web server.

I'm extremely frustrated - I licensed Cyberduck and it changed from a perfectly useful client that was meeting my needs to a pain in my neck that is totally unusable.

comment:11 in reply to: ↑ 10 Changed on Jul 21, 2014 at 7:48:08 PM by dkocher

Replying to milligan:

Replying to dkocher:

Replying to milligan:

Nothing has change on the web server configuration. I was able to connect to the euf directory before I donated to Cyberduck and installed the registration key. Now I can't. Only Cyberduck changed.

I doubt that. Please contact your web hosting service provider for assistance.

On Friday, I connected to the WebDAV server and uploaded some image files to a sub-directory under /euf/. When I finished and exited Cyberduck, I decided to use the "Donate Now" option and get a registration key. (A decision based on the fact that I've been using Cyberduck for a couple of months and it was meeting my needs for uploading/downloading files to the WebDAV server for our web support platform. As soon as I applied the registration key, it changed my Cyberduck installation, and I haven't been able to connect to the /euf/ directory since then. I seriously doubt the problem is on our web server.

I'm extremely frustrated - I licensed Cyberduck and it changed from a perfectly useful client that was meeting my needs to a pain in my neck that is totally unusable.

The key does not change in any way the problem you are seeing. If you also upgraded to a newer version of Cyberduck in the same time, please install the prior version you had available from https://cyberduck.io/changelog/ and we can compare the transcript.

Note: See TracTickets for help on using tickets.
swiss made software