Cyberduck Mountain Duck CLI

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8096 closed defect (fixed)

Synchronize fails to add new local files

Reported by: jm Owned by: dkocher
Priority: high Milestone: 4.5.2
Component: sftp Version: 4.4.5
Severity: critical Keywords: synchronize upload missing file fail
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

Choosing to synchronize upload fails to upload missing files. Missing or new files are absent in the transfer window as if they are not recognized at all on the local folder. Changed (existing) files seem to synchronize ok when the upload synch is run.

Attachments (1)

togglelogdrawer.txt (151.4 KB) - added by jm 4 years ago.
toggle log drawer text

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by jm

toggle log drawer text

comment:1 Changed 4 years ago by ma

I can confirm this bug. I have tried cyberduck on two different mac computers, connecting to a Linux SFTP server. Cyberduck works well, but the synchronization function is failing.

comment:2 Changed 4 years ago by dude

Same issue here. If a file doesn't exist on the remote server, when I do synchronize it doesn't even show up in the list of files that can be synchronized. Hitting ok and synchronizing does not upload any files that don't already exist on the server.

OSX to Linux over SFTP

comment:3 Changed 4 years ago by dkocher

  • Milestone set to 4.5.2
  • Status changed from new to assigned

comment:4 Changed 4 years ago by dkocher

This regression is caused by the changeset r14609.

comment:5 Changed 4 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Fix and test in r14973.

comment:6 Changed 4 years ago by dkocher

  • Summary changed from Synchronize "Upload" fails to upload missing files to Synchronize fails to add new local files
Note: See TracTickets for help on using tickets.
swiss made software