Cyberduck Mountain Duck CLI

#8103 closed defect (duplicate)

SFTP connection fails after upgrading Cyberduck to Version 4.5 (14905)

Reported by: krusint Owned by: dkocher
Priority: highest Milestone: 4.5.1
Component: sftp Version: 4.5
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

After updating Cyberduck to version 4.5 (14905), through the Apple Software Update, my SFTP connection suddenly fails to connect. The error message is: "Connection failed" The Log Drawer is empty.

I tried re-creating a brand new SFTP connection with the same parameters and it fails to connect in the same way.

Nothing changed on the server side, server is up, and the SFTP connection was always connecting fine before this software update. I can still connect to the server from the command line (scp command) with no problems.

My connection is a SFTP connection, on the default port (22), using public key authentication (pem file).

Change History (6)

comment:1 Changed on Jul 23, 2014 at 9:23:50 PM by sbmck

I have the same problem .. I did the exact same things .. my SFTP no longer works.

comment:2 Changed on Jul 24, 2014 at 7:45:25 AM by narrationsd

Also failing on any connection here, on 14915 nightly and on 14910 release. Windows 8.1, and the error message is Connection failed, Permission denied: connect.

This started happening right after I let Cyberduck update itself to 14915. It persists when I removed 14915 and installed the release 14910.

I have just removed 14910, including deleting its folder in Program Files(x86). I note that Cyberduck let me remove it via Win8.1 Control Panel>Programs and Features, even though it was presently runnning. Perhaps consequently, the uninstaller left a lot of material in Cyberduck's folder; hence I deleted it. I think the uninstaller should not operate if Cyberduck is running, and should warn.

I then downloaded 4.4.5 14721 from oldapps.com, after checking that site. I also checked Norton File Insight for the downloaded installer, which is a community checksum/experience test.

All fine, so I installed it. This Cyberduck works as expected. Something in the process above lost my passwords and host credentials, which usually doesn't happen. The shortcuts were preserved. I'm putting the passwords back in and re-accepting host credentials.

This older (recent) version functions as a workaround until the present problems on Cyberduck release can be fixed.

Added: In fact I only lost the password and host credentials for the Bookmarked site I was using when Cyberduck originally updated. And that is also the first site I tried to open with the new bad releases. So this may be a clue to what is causing the no-connects, though it does not look like a bad password behavior when that happens.

I can also say I lost the password but not the host credentials to one other Bookmarked site. It's possible I tried to open that one just after the original fail occurred.

Last edited on Jul 24, 2014 at 8:31:06 AM by narrationsd (previous) (diff)

comment:3 Changed on Jul 24, 2014 at 11:14:36 AM by dkocher

  • Milestone set to 4.5.1
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #8102. Fixed in r14911. The 4.5.1 bugfix release is waiting to be approved for release in the Mac App Store. This issue does not affect the non-sandboxed version of Cyberduck available from our website.

comment:4 Changed on Jul 24, 2014 at 9:04:08 PM by narrationsd

  • Milestone 4.5.1 deleted

Ok, just to confirm that 4.5.1 succeeds now on Windows 8.1 --- back to expected operation, thanks.

By the way, judging by the website tooltip and the core.dll contained in it, the installer coming from cyberduck.ch is still the faulty 4.5.0.xxx.

comment:5 Changed on Jul 25, 2014 at 8:06:50 AM by dkocher

  • Milestone set to 4.5.1

Duplicate for #8102. Fixed in r14911. Please update to the latest snapshot build available.

comment:6 Changed on Jul 25, 2014 at 8:53:31 PM by Sassinak

The same problem exists on the Mac Store 4.5 version... It seems the downloaded version Version 4.5 (14905) works better.. so not sure what happened.

Looking in the logs, on the mac store version I see these errors, an will get the message that the original thread had.

7/25/14 12:45:47.118 PM sandboxd[125]: ([429]) Cyberduck(429) deny file-read-data /Users/docm/Library/Application Support/Firefox/Profiles
7/25/14 12:45:47.123 PM sandboxd[125]: ([429]) Cyberduck(429) deny file-read-data /Users/docm/Library/Application Support/Firefox/Profiles
7/25/14 12:46:04.291 PM sandboxd[125]: ([429]) Cyberduck(429) deny file-issue-extension /Applications/TextEdit.app
7/25/14 12:46:44.797 PM Cyberduck[429]: [main] ERROR ch.cyberduck.core.sftp.openssh.OpenSSHHostKeyVerifier - Cannot read known hosts file FinderLocal{bookmark=, path='/Users/docm/.ssh/known_hosts'}
7/25/14 12:47:19.152 PM sandboxd[125]: ([429]) Cyberduck(429) deny file-write-create /Users/docm/.ssh

Note: See TracTickets for help on using tickets.
swiss made software