Cyberduck Mountain Duck CLI

#8142 closed defect (duplicate)

Openstack Files Listings not showing files

Reported by: gudrun jobst Owned by: dkocher
Priority: high Milestone: 4.5.2
Component: openstack Version: 4.5.1
Severity: critical Keywords: can't download
Cc: Architecture: Intel
Platform: Windows XP

Description (last modified by david cole)

Hi, I can see the top layer of folders, then another layer of folders, but not anything below that and cannot download any files or folders. Using windows. Please help.

Attachments (1)

Untitled-1.jpg (482.9 KB) - added by gudrun jobst on Aug 4, 2014 at 1:48:11 PM.

Download all attachments as: .zip

Change History (3)

Changed on Aug 4, 2014 at 1:48:11 PM by gudrun jobst

comment:1 Changed on Aug 7, 2014 at 7:59:11 PM by david cole

  • Component changed from core to openstack
  • Description modified (diff)
  • Milestone set to 4.5.2
  • Owner set to dkocher
  • Severity changed from normal to critical
  • Summary changed from Doesn't show files to Openstack Files Listings not showing files

I'm seeing this issues on Mac OS X as well. The problem is the use of double slashes at the end of prefix that is passed by Cyberduck to the Object Store. I can see the double forward slashes in the log drawer in version 4.5.1 , but not in version 4.4.5. With double slashes, the proxy return no objects in the listing. Examples, from Curl:

$ curl  "https://proxy-01.example.com/v1/AUTH_abcdefg/dcc?format=json&prefix=BigParade//" -X GET -H "X-Auth-Token: deadbeefdeadbeef""[[BR]]
[] 

$ curl  "https://proxy-01.example.com/v1/AUTH_abcdefg/dcc?format=json&prefix=BigParade/" -X GET -H "X-Auth-Token: deadbeefdeadbeef"[[BR]]
[{"hash": "795f3365f01a1d4c1390324be8210fb4", "last_modified": "2014-06-05T16:58:43.208350", "bytes": 2200262, "name": "BigParade/IMG_0118.JPG", "content_type": "image/jpeg"}, <snip>
Last edited on Aug 10, 2014 at 4:32:28 PM by dkocher (previous) (diff)

comment:2 Changed on Aug 10, 2014 at 4:32:14 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #8094. Please update to the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software