Cyberduck Mountain Duck CLI

#8195 closed defect (worksforme)

File transfers are being truncated

Reported by: stewart adam Owned by: dkocher
Priority: normal Milestone: 4.6
Component: sftp Version: 4.5.2
Severity: critical Keywords:
Cc: Architecture:
Platform: Mac OS X 10.8

Description

I'm experiencing issues that look very similar to ticket #7641: I'm seeing files getting truncated over SFTP.

I can reproduce the issue across two different services I tested (Fedora 20 and CentOS 7 using sshd's internal-sftp subsystem) and the file gets truncated in exactly the same way each time.

Apart from the corruption when downloading/viewing the file, there is no other indication that the file transfer failed. If I upload the same file using scp, it the transfer completes normally.

Attachments (1)

Screen Shot 2014-08-26 at 3.19.43 PM.png (485.9 KB) - added by stewart adam on Aug 26, 2014 at 7:20:57 PM.
Sample file that is truncated

Download all attachments as: .zip

Change History (7)

Changed on Aug 26, 2014 at 7:20:57 PM by stewart adam

Sample file that is truncated

comment:1 Changed on Aug 26, 2014 at 7:22:31 PM by stewart adam

Attached image is a screenshot of the homepage for Reddit.com as of today. Interestingly, this upload fails to upload (transfers dialog shows "transfer incomplete") at exactly 294.9KB of 497.5KB every time.

comment:2 Changed on Aug 27, 2014 at 1:50:49 PM by dkocher

  • Component changed from core to sftp
  • Owner set to dkocher

comment:3 Changed on Aug 27, 2014 at 4:28:57 PM by stewart adam

  • Summary changed from SFTP file transfers are truncated (again?) to SFTP file transfers are being truncated again

Edited title as it was unintentionally snarky - I meant to say I wasn't sure if it was the same truncation issue again or not.

More testing details: also reproducible on CentOS 5 server. Reverting to v4.4.3 fixes it, so likely an issue with the new SFTP subsystem implementation introduced in 4.5.x.

comment:4 Changed on Sep 1, 2014 at 11:23:23 AM by dkocher

  • Milestone set to 4.5.3

comment:5 Changed on Sep 3, 2014 at 3:12:45 PM by dkocher

  • Summary changed from SFTP file transfers are being truncated again to File transfers are being truncated

comment:6 Changed on Oct 6, 2014 at 8:55:54 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

We cannot reproduce this issue manually and our integration tests are green. Please reopen if you have more information on how to reproduce the issue.

Note: See TracTickets for help on using tickets.
swiss made software