Cyberduck Mountain Duck CLI

#8270 closed enhancement (fixed)

Gestalt selector gestaltSystemVersion deprecation warning

Reported by: max76 Owned by: dkocher
Priority: low Milestone: 4.6.1
Component: core Version: Nightly Build
Severity: minor Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description (last modified by dkocher)

Gestalt has been deprecated since 10.8 and therefore it will return the wrong version number on 10.10. On Yosemite, Gestalt returns 10.9 instead of 10.10.

How to reproduce:

  1. Install OSX 10.10 Yosemite
  2. Start Cyberduck (any version)
  3. Watch the console logs

Starting Cyberduck on Yosemite OSX 10.10 leads to the following warnings in the console:

Cyberduck Version 4.5.3 (15087)

21/10/14 13:41:34,762 Cyberduck[356]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.0 instead of 10.10.0. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
21/10/14 13:41:34,763 Cyberduck[356]: 0   CarbonCore                          0x00007fff90e5bdc3 ___Gestalt_SystemVersion_block_invoke + 113
21/10/14 13:41:34,763 Cyberduck[356]: 1   libdispatch.dylib                   0x00007fff8cf20c13 _dispatch_client_callout + 8
21/10/14 13:41:34,763 Cyberduck[356]: 2   libdispatch.dylib                   0x00007fff8cf20b26 dispatch_once_f + 117
21/10/14 13:41:34,763 Cyberduck[356]: 3   CarbonCore                          0x00007fff90e044da _Gestalt_SystemVersion + 987
21/10/14 13:41:34,764 Cyberduck[356]: 4   CarbonCore                          0x00007fff90e040c7 Gestalt + 144
21/10/14 13:41:34,764 Cyberduck[356]: 5   librococoa.dylib                    0x000000010ecec89c UKGetSystemVersionComponents + 33
21/10/14 13:41:34,764 Cyberduck[356]: 6   librococoa.dylib                    0x000000010ece84d7 -[UKCrashReporter checkForCrash] + 155

Cyberduck Version 4.5.3 (15415)

21/10/14 13:53:57,436 Cyberduck[4499]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.0 instead of 10.10.0. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
21/10/14 13:53:57,438 Cyberduck[4499]: 0   CarbonCore                          0x00007fff90e5bdc3 ___Gestalt_SystemVersion_block_invoke + 113
21/10/14 13:53:57,438 Cyberduck[4499]: 1   libdispatch.dylib                   0x00007fff8cf20c13 _dispatch_client_callout + 8
21/10/14 13:53:57,438 Cyberduck[4499]: 2   libdispatch.dylib                   0x00007fff8cf20b26 dispatch_once_f + 117
21/10/14 13:53:57,438 Cyberduck[4499]: 3   CarbonCore                          0x00007fff90e044da _Gestalt_SystemVersion + 987
21/10/14 13:53:57,438 Cyberduck[4499]: 4   CarbonCore                          0x00007fff90e040c7 Gestalt + 144
21/10/14 13:53:57,438 Cyberduck[4499]: 5   librococoa.dylib                    0x000000010e73fddb UKGetSystemVersionComponents + 33
21/10/14 13:53:57,438 Cyberduck[4499]: 6   librococoa.dylib                    0x000000010e73b9df -[UKCrashReporter checkForCrash] + 135

Application is working properly, but I think messages in console should be avoided.

Change History (5)

comment:1 Changed on Oct 21, 2014 at 12:16:32 PM by dkocher

  • Description modified (diff)
  • Milestone 4.5.3 deleted
  • Type changed from defect to enhancement

comment:2 Changed on Oct 21, 2014 at 12:17:32 PM by dkocher

  • Summary changed from Yosemite Console log to Gestalt selector gestaltSystemVersion deprecation warning

comment:3 Changed on Oct 21, 2014 at 12:19:06 PM by dkocher

The problem is that NSProcessinfo operatingSystemVersion is only available in OS X v10.10 and later.

comment:4 Changed on Dec 8, 2014 at 11:07:25 AM by dkocher

  • Milestone set to 4.6.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:5 Changed on Dec 8, 2014 at 11:09:12 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r16061.

Note: See TracTickets for help on using tickets.
swiss made software