Cyberduck Mountain Duck CLI

#8320 closed defect (fixed)

Null pointer in TransferDictionary

Reported by: jesús quintana Owned by: dkocher
Priority: highest Milestone: 4.6.1
Component: core Version: Nightly Build
Severity: blocker Keywords: upload button, crash
Cc: jquintana@… Architecture:
Platform: Mac OS X 10.10

Description

Cyberduck 4.5.2 on Yosemite

  • important: crash sometimes only when i push upload button to choose files, at least 2 times a day.
  • other simply thing: on window transfer, the "charge icon" is always visible.

thank you very much

Attachments (3)

cr.rtf (114.0 KB) - added by jesús quintana on Nov 11, 2014 at 10:46:00 AM.
cr2.rtf (115.8 KB) - added by jesús quintana on Nov 12, 2014 at 1:48:12 PM.
crash reporter Versión 4.5.3 (15682)
cr3.rtf (113.1 KB) - added by jesús quintana on Nov 27, 2014 at 12:02:29 AM.
continues Versión 4.6.1 (15849)

Download all attachments as: .zip

Change History (24)

comment:1 in reply to: ↑ description ; follow-up: Changed on Nov 11, 2014 at 10:24:25 AM by dkocher

  • Summary changed from Crash on click upload button - 4.5.2 to Crashes clicking upload button

Replying to jesús quintana:

  • other simply thing: on window transfer, the "charge icon" is always visible.

Which icon do you mean?

comment:2 Changed on Nov 11, 2014 at 10:26:25 AM by dkocher

  • Milestone set to 4.5.3
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue with the latest snapshot build available. Please reopen this issue with the crash report attached.

Changed on Nov 11, 2014 at 10:46:00 AM by jesús quintana

comment:3 in reply to: ↑ 1 Changed on Nov 11, 2014 at 10:49:18 AM by jesús quintana

Replying to dkocher:

Replying to jesús quintana:

  • other simply thing: on window transfer, the "charge icon" is always visible.

Which icon do you mean?

the "ajax icon" on transfer window, always appear..., not only when there are uploads or downloads, always shows

i attached the crash report, this time was on third click to upload button,

thank you very much

comment:4 Changed on Nov 11, 2014 at 10:58:41 AM by dkocher

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	0x00007fff8b8c1282 __pthread_kill + 10
1   libsystem_c.dylib             	0x00007fff874d1b73 abort + 129
2   libc++abi.dylib               	0x00007fff879afa21 abort_message + 257
3   libc++abi.dylib               	0x00007fff879d79d1 default_terminate_handler() + 267
4   libobjc.A.dylib               	0x00007fff928d66c6 _objc_terminate() + 103
5   libc++abi.dylib               	0x00007fff879d50a1 std::__terminate(void (*)()) + 8
6   libc++abi.dylib               	0x00007fff879d4b30 __cxa_throw + 121
7   libobjc.A.dylib               	0x00007fff928d2808 objc_exception_throw + 341
8   com.apple.CoreFoundation      	0x00007fff87779ee5 __NSFastEnumerationMutationHandler + 309
9   com.apple.AppKit              	0x00007fff88399d74 -[NSView _recursiveSendViewDidChangeAppearance:] + 193
10  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
11  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
12  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
13  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
14  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
15  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
16  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
17  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
18  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
19  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
20  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
21  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
22  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
23  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
24  com.apple.AppKit              	0x00007fff88399d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
25  com.apple.AppKit              	0x00007fff88399a91 -[NSView setAppearance:] + 205
26  com.apple.AppKit              	0x00007fff8899c0fc -[NSThemeFrame setAppearance:] + 52
27  com.apple.AppKit              	0x00007fff8831851a -[NSWindow setAppearance:] + 44
28  com.apple.AppKit              	0x00007fff8887c033 +[NSSavePanel _crunchyRawUnbonedPanel] + 298
29  libjnidispatch.dylib          	0x000000010cd7894c ffi_call_unix64 + 76
30  libjnidispatch.dylib          	0x000000010cd78456 ffi_call + 630
31  libjnidispatch.dylib          	0x000000010cd6f2f5 Java_com_sun_jna_Native_ffi_1prep_1cif + 1621
32  libjnidispatch.dylib          	0x000000010cd6f7a2 Java_com_sun_jna_Native_invokeLong + 34
33  ???                           	0x00000001034f2a8e 0 + 4350487182
34  ???                           	0x000000010357566c 0 + 4351022700

comment:5 Changed on Nov 11, 2014 at 10:59:22 AM by dkocher

Can you reproduce this issue with the latest snapshot build available?

comment:6 Changed on Nov 11, 2014 at 11:13:56 AM by jesús quintana

Versión 4.5.2 (15055) continues..., on third click onupload button crash without report

comment:7 Changed on Nov 11, 2014 at 11:21:57 AM by jesús quintana

idem: Versión 4.5.3 (15682) on third click on upload button crash without report

mm why?....

comment:8 Changed on Nov 11, 2014 at 12:33:50 PM by jesús quintana

Versión 4.5.3 (15732) idem. always the third click.....

comment:9 Changed on Nov 11, 2014 at 12:40:22 PM by jesús quintana

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:10 Changed on Nov 11, 2014 at 4:07:11 PM by dkocher

  • Milestone 4.5.3 deleted
  • Owner set to dkocher
  • Status changed from reopened to new

comment:11 Changed on Nov 11, 2014 at 11:32:28 PM by jesús quintana

  • Cc jquintana@… added
  • Version changed from 4.5.2 to Nightly Build

comment:12 Changed on Nov 12, 2014 at 1:34:06 PM by dkocher

We cannot reproduce the issue here.

comment:13 Changed on Nov 12, 2014 at 1:35:54 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

Please try to login using the Guest Account and see if you can reproduce the issue here. I suspect an interoperability issue with some installed third party component.

Changed on Nov 12, 2014 at 1:48:12 PM by jesús quintana

crash reporter Versión 4.5.3 (15682)

comment:14 follow-up: Changed on Nov 12, 2014 at 1:50:31 PM by jesús quintana

ok, with guest user goes ok,

but issue having just upgraded to yosemite..., and after donate, and the boot apps are the same.........

Please, if you can see in reporter what can be... I thank you very much, it is very important, because all connections are closed when i edit multiple files......,

and always on third click....,

thank u very much

Last edited on Nov 12, 2014 at 2:31:16 PM by jesús quintana (previous) (diff)

comment:15 in reply to: ↑ 14 Changed on Nov 12, 2014 at 2:41:05 PM by jesús quintana

ok, with guest user goes ok,

but issue having just upgraded to yosemite..., and after donate, and the boot apps are the same.........

Please, if you can see in reporter what can be... I thank you very much, it is very important, because all connections are closed when i edit multiple files......,

and always on third click....,

thank u very much

Replying to jesús quintana:

ok, with guest user goes ok,

but issue having just upgraded to yosemite..., and after donate, and the boot apps are the same.........

Please, if you can see in reporter what can be... I thank you very much, it is very important, because all connections are closed when i edit multiple files......,

and always on third click....,

thank u very much

comment:16 Changed on Nov 12, 2014 at 2:52:42 PM by jesús quintana

12/11/14 15:47:03,165 Cyberduck[815]: [background-4] FATAL ch.cyberduck.ui.AbstractController - Unhandled exception running background task null

java.lang.NullPointerException
	at ch.cyberduck.core.Path.setPath(Path.java:114)
	at ch.cyberduck.core.Path.<init>(Path.java:78)
	at ch.cyberduck.core.Path.setPath(Path.java:118)
	at ch.cyberduck.core.Path.<init>(Path.java:88)
	at ch.cyberduck.core.serializer.PathDictionary.deserialize(PathDictionary.java:65)
	at ch.cyberduck.core.serializer.PathDictionary.deserialize(PathDictionary.java:75)
	at ch.cyberduck.core.serializer.TransferDictionary.deserialize(TransferDictionary.java:75)
	at ch.cyberduck.core.serializer.impl.TransferPlistReader.deserialize(TransferPlistReader.java:32)
	at ch.cyberduck.core.serializer.impl.TransferPlistReader.deserialize(TransferPlistReader.java:28)
	at ch.cyberduck.core.serializer.impl.PlistReader.read(PlistReader.java:74)
	at ch.cyberduck.core.FolderTransferCollection.load(FolderTransferCollection.java:150)
	at ch.cyberduck.core.TransferCollection.load(TransferCollection.java:203)
	at ch.cyberduck.ui.cocoa.MainController$14.run(MainController.java:993)
	at ch.cyberduck.ui.cocoa.MainController$14.run(MainController.java:990)
	at ch.cyberduck.core.threading.AbstractBackgroundAction.call(AbstractBackgroundAction.java:119)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:171)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:724)
12/11/14 15:49:02,488 Console[825]: Failed to connect (_consoleX) outlet from (NSApplication) to (ConsoleX): missing setter or instance variable
12/11/14 15:49:43,001 Cyberduck[815]: assertion failed: 14A389: libxpc.dylib + 97940 [9437C02E-A07B-38C8-91CB-299FAA63083D]: 0x89
12/11/14 15:50:24,513 Cyberduck[815]: An uncaught exception was raised
12/11/14 15:50:24,513 Cyberduck[815]: *** Collection <__NSArrayM: 0x618000859620> was mutated while being enumerated.
12/11/14 15:50:24,514 Cyberduck[815]: (
	0   CoreFoundation                      0x00007fff8bd4164c __exceptionPreprocess + 172
	1   libobjc.A.dylib                     0x00007fff96e996de objc_exception_throw + 43
	2   CoreFoundation                      0x00007fff8bd40ee5 __NSFastEnumerationMutationHandler + 309
	3   AppKit                              0x00007fff8c960d74 -[NSView _recursiveSendViewDidChangeAppearance:] + 193
	4   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	5   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	6   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	7   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	8   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	9   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	10  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	11  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	12  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	13  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	14  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	15  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	16  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	17  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	18  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	19  AppKit                              0x00007fff8c960a91 -[NSView setAppearance:] + 205
	20  AppKit                              0x00007fff8cf630fc -[NSThemeFrame setAppearance:] + 52
	21  AppKit                              0x00007fff8c8df51a -[NSWindow setAppearance:] + 44
	22  AppKit                              0x00007fff8ce43033 +[NSSavePanel _crunchyRawUnbonedPanel] + 298
	23  libjnidispatch.dylib                0x000000010cc0d94c ffi_call_unix64 + 76
	24  ???                                 0x00007fff5fbf9fb0 0x0 + 140734799781808
)
12/11/14 15:50:24,514 Cyberduck[815]: *** Terminating app due to uncaught exception 'NSGenericException', reason: '*** Collection <__NSArrayM: 0x618000859620> was mutated while being enumerated.'
*** First throw call stack:
(
	0   CoreFoundation                      0x00007fff8bd4164c __exceptionPreprocess + 172
	1   libobjc.A.dylib                     0x00007fff96e996de objc_exception_throw + 43
	2   CoreFoundation                      0x00007fff8bd40ee5 __NSFastEnumerationMutationHandler + 309
	3   AppKit                              0x00007fff8c960d74 -[NSView _recursiveSendViewDidChangeAppearance:] + 193
	4   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	5   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	6   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	7   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	8   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	9   AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	10  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	11  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	12  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	13  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	14  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	15  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	16  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	17  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	18  AppKit                              0x00007fff8c960d8b -[NSView _recursiveSendViewDidChangeAppearance:] + 216
	19  AppKit                              0x00007fff8c960a91 -[NSView setAppearance:] + 205
	20  AppKit                              0x00007fff8cf630fc -[NSThemeFrame setAppearance:] + 52
	21  AppKit                              0x00007fff8c8df51a -[NSWindow setAppearance:] + 44
	22  AppKit                              0x00007fff8ce43033 +[NSSavePanel _crunchyRawUnbonedPanel] + 298
	23  libjnidispatch.dylib                0x000000010cc0d94c ffi_call_unix64 + 76
	24  ???                                 0x00007fff5fbf9fb0 0x0 + 140734799781808
)
12/11/14 15:50:24,528 com.apple.xpc.launchd[1]: (com.apple.ReportCrash[834]) Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.ReportCrash
12/11/14 15:50:27,959 CoreServicesUIAgent[519]: unexpected message <OS_xpc_error: <error: 0x7fff7885dc60> { count = 1, contents =
	"XPCErrorDescription" => <string: 0x7fff7885df70> { length = 18, contents = "Connection invalid" }
}>
12/11/14 15:50:28,020 com.apple.xpc.launchd[1]: (ch.sudo.cyberduck.46324[815]) Service exited due to signal: Abort trap: 6
12/11/14 15:50:28,155 ReportCrash[834]: Saved crash report for Cyberduck[815] version 4.5.3 (15682) to /Users/jquin/Library/Logs/DiagnosticReports/Cyberduck_2014-11-12-155028_MacBook-Pro-de-Jesus-Quintana.crash

Last edited on Nov 12, 2014 at 3:20:48 PM by dkocher (previous) (diff)

comment:17 Changed on Nov 21, 2014 at 9:03:08 AM by dkocher

  • Milestone set to 4.7
  • Resolution thirdparty deleted
  • Status changed from closed to reopened

comment:18 Changed on Nov 25, 2014 at 3:30:04 PM by dkocher

  • Milestone changed from 4.7 to 4.6.1
  • Summary changed from Crashes clicking upload button to Null pointer in TransferDictionary

comment:19 Changed on Nov 25, 2014 at 3:36:39 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r15842.

comment:20 Changed on Nov 25, 2014 at 4:52:18 PM by jesús quintana

BRAVO!

now please, delete all my sensible info please..., in report files and etc, if is sensible...,

GREETINGSSSSSSS

Changed on Nov 27, 2014 at 12:02:29 AM by jesús quintana

continues Versión 4.6.1 (15849)

comment:21 Changed on Nov 27, 2014 at 12:03:36 AM by jesús quintana

sorry, continues,

generally on third click but now o 6

Note: See TracTickets for help on using tickets.
swiss made software