Cyberduck Mountain Duck CLI

#8334 closed defect (duplicate)

Crashes with CLR20r3 problem event name

Reported by: aleli linis Owned by:
Priority: highest Milestone:
Component: core Version: 4.5.2
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 7

Description (last modified by dkocher)

Hi Cyberduck Support:

I've installed the new version...it worked for a while and then it keeps on crashing again. Please advise.

Thank you.

------------------------
Problem signature:
  Problem Event Name:	CLR20r3
  Problem Signature 01:	cyberduck.exe
  Problem Signature 02:	4.5.2.15058
  Problem Signature 03:	53fc8695
  Problem Signature 04:	Cyberduck
  Problem Signature 05:	4.5.2.15058
  Problem Signature 06:	53fc8695
  Problem Signature 07:	176b
  Problem Signature 08:	2de
  Problem Signature 09:	PSZQOADHX1U5ZAHBHOHGHLDGIY4QIXHX
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

Attachments (1)

635519161785611951.txt (5.5 KB) - added by aleli linis on Nov 18, 2014 at 10:08:12 PM.

Download all attachments as: .zip

Change History (15)

comment:1 Changed on Nov 18, 2014 at 10:03:11 AM by dkocher

  • Summary changed from Cyberduck keeps on crashing to Crashes with CLR20r3 problem event name

comment:2 Changed on Nov 18, 2014 at 10:04:26 AM by dkocher

  • Description modified (diff)

comment:3 Changed on Nov 18, 2014 at 10:06:50 AM by dkocher

Previously reported in #8298.

comment:4 Changed on Nov 18, 2014 at 11:06:02 AM by yla

Please check if there are any crash reports available and attach them.

comment:5 Changed on Nov 18, 2014 at 11:24:04 AM by aleli linis

Problem signature:
  Problem Event Name:	CLR20r3
  Problem Signature 01:	cyberduck.exe
  Problem Signature 02:	4.5.2.15058
  Problem Signature 03:	53fc8695
  Problem Signature 04:	Cyberduck
  Problem Signature 05:	4.5.2.15058
  Problem Signature 06:	53fc8695
  Problem Signature 07:	176b
  Problem Signature 08:	2de
  Problem Signature 09:	PSZQOADHX1U5ZAHBHOHGHLDGIY4QIXHX
  OS Version:	6.1.7601.2.1.0.256.48
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt

Last edited on Nov 18, 2014 at 4:14:01 PM by dkocher (previous) (diff)

comment:6 Changed on Nov 18, 2014 at 11:37:31 AM by yla

That's what you've already posted. I mean, can you find any file in C:\Users\[username]\AppData\Roaming\Cyberduck\CrashReporter?

Last edited on Nov 18, 2014 at 4:14:27 PM by dkocher (previous) (diff)

comment:7 Changed on Nov 18, 2014 at 12:54:52 PM by aleli linis

Sorry. I did not find any crash report? and did not see C:\Users\[username]\AppData\Roaming\Cyberduck\CrashReporter? I saw C:\Users\[username]\Roaming\Intel\Wireless.

Last edited on Nov 18, 2014 at 4:15:10 PM by dkocher (previous) (diff)

comment:8 Changed on Nov 18, 2014 at 7:01:03 PM by yla

That seems to be the wrong location. To easily find the Cyberduck AppData folder you can run the command %APPDATA%\cyberduck by pressing the Start button and the choose Run... After pressing OK an Explorer window should open showing the Cyberduck settings folder. From there you can navigate to the CrashReporter folder.

Changed on Nov 18, 2014 at 10:08:12 PM by aleli linis

comment:9 Changed on Nov 18, 2014 at 10:09:59 PM by aleli linis

Hi yla,

Thank you for providing the instruction in retrieving the crash report. Please see attachment for reference.

comment:10 Changed on Nov 20, 2014 at 11:18:43 AM by yla

  • Milestone set to 4.7

Thanks for providing the crash report. We are aware of this issue but it's pretty rare and we were unable yet to find the cause. Will need some more investigation.

comment:11 Changed on Dec 9, 2014 at 1:51:09 PM by dkocher

Top-level Exception
Type:        System.Runtime.InteropServices.COMException
Message:     The current process has used all of its system allowance of handles for Window Manager objects. (Exception from HRESULT: 0x80070486)
Source:      Cyberduck
Stack Trace: at Ch.Cyberduck.Ui.Winforms.Taskdialog.VistaUnsafeNativeMethods.TaskDialogIndirect(TASKDIALOGCONFIG& pTaskConfig, Int32& pnButton, Int32& pnRadioButton, Boolean& pfVerificationFlagChecked)
   at Ch.Cyberduck.Ui.Winforms.Taskdialog.VistaTaskDialog.PrivateShow(IntPtr hwndOwner, Boolean& verificationFlagChecked, Int32& radioButtonResult)
   at Ch.Cyberduck.Ui.Winforms.Taskdialog.VistaTaskDialog.Show(IWin32Window owner, Boolean& verificationFlagChecked, Int32& radioButtonResult)
   at Ch.Cyberduck.Ui.Winforms.Taskdialog.TaskDialog.ShowTaskDialogBox(IWin32Window Owner, String Title, String MainInstruction, String Content, String ExpandedInfo, String Footer, String VerificationText, String RadioButtons, String CommandButtons, TaskDialogButtons Buttons, SysIcons MainIcon, SysIcons FooterIcon, Int32 DefaultIndex)
   at Ch.Cyberduck.Ui.Winforms.Taskdialog.TaskDialog.ShowTaskDialogBox(IWin32Window Owner, String Title, String MainInstruction, String Content, String ExpandedInfo, String Footer, String VerificationText, String RadioButtons, String CommandButtons, TaskDialogButtons Buttons, SysIcons MainIcon, SysIcons FooterIcon)
   at Ch.Cyberduck.Ui.Winforms.Taskdialog.TaskDialog.ShowCommandBox(IWin32Window Owner, String Title, String MainInstruction, String Content, String ExpandedInfo, String Footer, String VerificationText, String CommandButtons, Boolean ShowCancelButton, SysIcons MainIcon, SysIcons FooterIcon)
   at Ch.Cyberduck.Core.CrashReporter.Write(Exception e)
   at Ch.Cyberduck.Ui.Controller.MainController.ExceptionHandler(Object sender, ThreadExceptionEventArgs e)
   at System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t)
   at System.Windows.Forms.Control.WndProcException(Exception e)
   at System.Windows.Forms.Control.ControlNativeWindow.OnThreadException(Exception e)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.Run(ApplicationContext context)
   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun()
   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel()
   at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(String[] commandLine)
   at Ch.Cyberduck.Ui.Controller.MainController.Run(ICollection commandLineArgs)
   at Ch.Cyberduck.Ui.Controller.MainController.Run()
   at Ch.Cyberduck.Ui.Controller.MainController.Main()

comment:12 Changed on Dec 9, 2014 at 1:51:26 PM by dkocher

Duplicate for #6550.

comment:13 Changed on Dec 9, 2014 at 1:51:43 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

comment:14 Changed on Jan 28, 2015 at 8:55:02 AM by dkocher

  • Milestone 4.7 deleted
Note: See TracTickets for help on using tickets.
swiss made software