Cyberduck Mountain Duck CLI

#8351 closed defect (wontfix)

Edited file no longer uploaded when parent directory name changes

Reported by: alessandro volz Owned by:
Priority: normal Milestone:
Component: core Version: 4.6
Severity: major Keywords:
Cc: Architecture:
Platform:

Description

Everything works as expected when editing some html files. But when I edit a file with an uncommon file extension, when I save it Cyberduck doesn't upload it to the FTP server.

Attachments (4)

cyberduck2.jpg (202.7 KB) - added by nugget on Nov 26, 2014 at 5:05:32 PM.
log.jpg (209.5 KB) - added by nugget on Nov 26, 2014 at 5:06:09 PM.
cyberduck3.jpg (197.7 KB) - added by nugget on Nov 26, 2014 at 8:08:45 PM.
Screen Shot 2014-12-05 at 13.47.53.png (34.9 KB) - added by dkocher on Dec 5, 2014 at 12:48:15 PM.

Download all attachments as: .zip

Change History (8)

comment:1 Changed on Nov 21, 2014 at 3:15:40 PM by alessandro volz

After more testing, I noticed that the description isn't correct, but the bug is on a different level. It is not about file extensions. The local version of the directory I was working on (inside /private/var) hadn't followed a rename on the server: I had renamed 'contents' to 'Contents', and Cyberduck stopped receiving notifications about local file changes. So, the bug is: case change on the server side don't seem to be properly followed in the temporary local directory.

comment:2 Changed on Nov 26, 2014 at 8:14:29 AM by dkocher

  • Summary changed from No upload after save when editing files with uncommon extension to Edited file no longer uploaded when parent directory name changes

Changed on Nov 26, 2014 at 5:05:32 PM by nugget

Changed on Nov 26, 2014 at 5:06:09 PM by nugget

Changed on Nov 26, 2014 at 8:08:45 PM by nugget

comment:4 in reply to: ↑ 3 Changed on Nov 26, 2014 at 8:55:32 PM by dkocher

Replying to nugget:

I just tried the history log to see what happens. The result is the screenshot cyberduck2(access denied 530 error message). The second screenshot is ( I hope) the log you requested. When I tried the history log try the last day I was able to successfully log in was 11/21/2014. Hope this helps.

I think this was comment was intended for #8348.

comment:5 Changed on Dec 5, 2014 at 12:48:54 PM by dkocher

  • Resolution set to wontfix
  • Status changed from new to closed

An error message like

is expected in this case as the file cannot be uploaded to the previous location.

Note: See TracTickets for help on using tickets.
swiss made software