Cyberduck Mountain Duck CLI

#8360 closed defect (fixed)

Null pointer in DownloadRootPathsNormalizer

Reported by: dansoper Owned by: dkocher
Priority: normal Milestone: 4.6.1
Component: core Version: 4.6
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

The Transfers window has a constant spinning loading icon in the middle of it - even if nothing is loading.

Change History (8)

comment:1 Changed on Nov 24, 2014 at 11:36:32 AM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:2 Changed on Nov 24, 2014 at 11:36:48 AM by dkocher

Try to remove all transfer files from ~/Library/Application Support/Cyberduck/Transfers.

comment:3 Changed on Nov 24, 2014 at 11:44:06 AM by dansoper

Thanks. I have deleted all the transfer files in that location, still has the spinning icon.

From the Console, the following appears when I open Cyberduck:

24/11/2014 11:42:07.664 Cyberduck[16195]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.1 instead of 10.10.1. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
24/11/2014 11:42:07.664 Cyberduck[16195]: 0   CarbonCore                          0x00007fff87f88dc3 ___Gestalt_SystemVersion_block_invoke + 113
24/11/2014 11:42:07.664 Cyberduck[16195]: 1   libdispatch.dylib                   0x00007fff92900c13 _dispatch_client_callout + 8
24/11/2014 11:42:07.664 Cyberduck[16195]: 2   libdispatch.dylib                   0x00007fff92900b26 dispatch_once_f + 117
24/11/2014 11:42:07.664 Cyberduck[16195]: 3   CarbonCore                          0x00007fff87f314da _Gestalt_SystemVersion + 987
24/11/2014 11:42:07.664 Cyberduck[16195]: 4   CarbonCore                          0x00007fff87f310c7 Gestalt + 144
24/11/2014 11:42:07.665 Cyberduck[16195]: 5   librococoa.dylib                    0x00000001095f53ff UKGetSystemVersionComponents + 33
24/11/2014 11:42:07.665 Cyberduck[16195]: 6   librococoa.dylib                    0x00000001095f1003 -[UKCrashReporter checkForCrash] + 135
24/11/2014 11:42:07.960 Cyberduck[16195]: [main] ERROR ch.cyberduck.core.aquaticprime.LicenseFactory - Failure finding receipt Access denied
24/11/2014 11:42:10.277 Cyberduck[16195]: [main] ERROR ch.cyberduck.core.aquaticprime.LicenseFactory - Failure finding receipt Access denied
24/11/2014 11:42:13.983 Cyberduck[16195]: [background-4] FATAL ch.cyberduck.ui.AbstractController - Unhandled exception running background task null

java.lang.NullPointerException
	at ch.cyberduck.core.transfer.normalizer.DownloadRootPathsNormalizer.normalize(DownloadRootPathsNormalizer.java:53)
	at ch.cyberduck.core.transfer.DownloadTransfer.<init>(DownloadTransfer.java:81)
	at ch.cyberduck.core.serializer.TransferDictionary.deserialize(TransferDictionary.java:122)
	at ch.cyberduck.core.serializer.impl.TransferPlistReader.deserialize(TransferPlistReader.java:32)
	at ch.cyberduck.core.serializer.impl.TransferPlistReader.deserialize(TransferPlistReader.java:28)
	at ch.cyberduck.core.serializer.impl.PlistReader.readCollection(PlistReader.java:53)
	at ch.cyberduck.core.TransferCollection.load(TransferCollection.java:199)
	at ch.cyberduck.ui.cocoa.MainController$14.run(MainController.java:993)
	at ch.cyberduck.ui.cocoa.MainController$14.run(MainController.java:990)
	at ch.cyberduck.core.threading.AbstractBackgroundAction.call(AbstractBackgroundAction.java:119)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:171)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:724)

Last edited on Nov 24, 2014 at 12:21:01 PM by dkocher (previous) (diff)

comment:4 follow-up: Changed on Nov 24, 2014 at 8:31:46 PM by wallenium

Same error for me. I cannot use cyberduck any longer. Need an urgent fix to be able to work again.

24.11.14 21:26:47,015 Cyberduck[19864]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.1 instead of 10.10.1. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
24.11.14 21:26:47,016 Cyberduck[19864]: 0   CarbonCore                          0x00007fff8a83edc3 ___Gestalt_SystemVersion_block_invoke + 113
24.11.14 21:26:47,016 Cyberduck[19864]: 1   libdispatch.dylib                   0x00007fff8ef52c13 _dispatch_client_callout + 8
24.11.14 21:26:47,016 Cyberduck[19864]: 2   libdispatch.dylib                   0x00007fff8ef52b26 dispatch_once_f + 117
24.11.14 21:26:47,017 Cyberduck[19864]: 3   CarbonCore                          0x00007fff8a7e74da _Gestalt_SystemVersion + 987
24.11.14 21:26:47,017 Cyberduck[19864]: 4   CarbonCore                          0x00007fff8a7e70c7 Gestalt + 144
24.11.14 21:26:47,017 Cyberduck[19864]: 5   librococoa.dylib                    0x0000000109a273ff UKGetSystemVersionComponents + 33
24.11.14 21:26:47,017 Cyberduck[19864]: 6   librococoa.dylib                    0x0000000109a23003 -[UKCrashReporter checkForCrash] + 135
24.11.14 21:26:57,474 Cyberduck[19864]: [background-1] FATAL ch.cyberduck.ui.AbstractController - Unhandled exception running background task Expected scheme name at index 0: ://(null):(null)

java.lang.IllegalArgumentException: Expected scheme name at index 0: ://(null):(null)
	at java.net.URI.create(URI.java:859)
	at ch.cyberduck.core.SystemConfigurationProxy.find(SystemConfigurationProxy.java:67)
	at ch.cyberduck.core.ProxySocketFactory.factory(ProxySocketFactory.java:70)
	at ch.cyberduck.core.ProxySocketFactory.createSocket(ProxySocketFactory.java:89)
	at net.schmizz.sshj.SocketClient.connect(SocketClient.java:49)
	at net.schmizz.sshj.SocketClient.connect(SocketClient.java:57)
	at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:160)
	at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:123)
	at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:75)
	at ch.cyberduck.core.Session.open(Session.java:112)
	at ch.cyberduck.core.LoginConnectionService.connect(LoginConnectionService.java:151)
	at ch.cyberduck.core.LoginConnectionService.check(LoginConnectionService.java:98)
	at ch.cyberduck.core.LoginConnectionService.check(LoginConnectionService.java:105)
	at ch.cyberduck.core.threading.SessionBackgroundAction.connect(SessionBackgroundAction.java:198)
	at ch.cyberduck.ui.threading.BrowserBackgroundAction.connect(BrowserBackgroundAction.java:59)
	at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:166)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:171)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:724)
Caused by: java.net.URISyntaxException: Expected scheme name at index 0: ://(null):(null)
	at java.net.URI$Parser.fail(URI.java:2829)
	at java.net.URI$Parser.failExpecting(URI.java:2835)
	at java.net.URI$Parser.parse(URI.java:3027)
	at java.net.URI.<init>(URI.java:595)
	at java.net.URI.create(URI.java:857)
	... 21 more

Last edited on Nov 24, 2014 at 8:33:15 PM by wallenium (previous) (diff)

comment:5 in reply to: ↑ 4 Changed on Nov 25, 2014 at 3:22:08 PM by dkocher

Replying to wallenium:

Same error for me. I cannot use cyberduck any longer. Need an urgent fix to be able to work again.

24.11.14 21:26:47,015 Cyberduck[19864]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.1 instead of 10.10.1. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:
24.11.14 21:26:47,016 Cyberduck[19864]: 0   CarbonCore                          0x00007fff8a83edc3 ___Gestalt_SystemVersion_block_invoke + 113
24.11.14 21:26:47,016 Cyberduck[19864]: 1   libdispatch.dylib                   0x00007fff8ef52c13 _dispatch_client_callout + 8
24.11.14 21:26:47,016 Cyberduck[19864]: 2   libdispatch.dylib                   0x00007fff8ef52b26 dispatch_once_f + 117
24.11.14 21:26:47,017 Cyberduck[19864]: 3   CarbonCore                          0x00007fff8a7e74da _Gestalt_SystemVersion + 987
24.11.14 21:26:47,017 Cyberduck[19864]: 4   CarbonCore                          0x00007fff8a7e70c7 Gestalt + 144
24.11.14 21:26:47,017 Cyberduck[19864]: 5   librococoa.dylib                    0x0000000109a273ff UKGetSystemVersionComponents + 33
24.11.14 21:26:47,017 Cyberduck[19864]: 6   librococoa.dylib                    0x0000000109a23003 -[UKCrashReporter checkForCrash] + 135
24.11.14 21:26:57,474 Cyberduck[19864]: [background-1] FATAL ch.cyberduck.ui.AbstractController - Unhandled exception running background task Expected scheme name at index 0: ://(null):(null)

java.lang.IllegalArgumentException: Expected scheme name at index 0: ://(null):(null)
	at java.net.URI.create(URI.java:859)
	at ch.cyberduck.core.SystemConfigurationProxy.find(SystemConfigurationProxy.java:67)
	at ch.cyberduck.core.ProxySocketFactory.factory(ProxySocketFactory.java:70)
	at ch.cyberduck.core.ProxySocketFactory.createSocket(ProxySocketFactory.java:89)
	at net.schmizz.sshj.SocketClient.connect(SocketClient.java:49)
	at net.schmizz.sshj.SocketClient.connect(SocketClient.java:57)
	at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:160)
	at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:123)
	at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:75)
	at ch.cyberduck.core.Session.open(Session.java:112)
	at ch.cyberduck.core.LoginConnectionService.connect(LoginConnectionService.java:151)
	at ch.cyberduck.core.LoginConnectionService.check(LoginConnectionService.java:98)
	at ch.cyberduck.core.LoginConnectionService.check(LoginConnectionService.java:105)
	at ch.cyberduck.core.threading.SessionBackgroundAction.connect(SessionBackgroundAction.java:198)
	at ch.cyberduck.ui.threading.BrowserBackgroundAction.connect(BrowserBackgroundAction.java:59)
	at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:166)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:171)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:724)
Caused by: java.net.URISyntaxException: Expected scheme name at index 0: ://(null):(null)
	at java.net.URI$Parser.fail(URI.java:2829)
	at java.net.URI$Parser.failExpecting(URI.java:2835)
	at java.net.URI$Parser.parse(URI.java:3027)
	at java.net.URI.<init>(URI.java:595)
	at java.net.URI.create(URI.java:857)
	... 21 more

Fix in r15840. Please reopen a new issue if this persists with the latest snapshot build.

comment:6 Changed on Nov 25, 2014 at 3:22:28 PM by dkocher

  • Summary changed from Spinning Symbol in Transfers Window to Null pointer in DownloadRootPathsNormalizer

comment:7 Changed on Nov 25, 2014 at 3:22:35 PM by dkocher

  • Milestone set to 4.6.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:8 Changed on Nov 25, 2014 at 3:25:39 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r15841.

Note: See TracTickets for help on using tickets.
swiss made software