Cyberduck Mountain Duck CLI

#8364 closed defect (fixed)

Container listing stalled

Reported by: jklovanc Owned by: dkocher
Priority: highest Milestone: 4.6.1
Component: cloudfiles Version: 4.6
Severity: normal Keywords: Rackspace
Cc: Architecture: Intel
Platform: Windows 7

Description

Connects correctly but directory download stalled. Stopped after about 5 minutes and only a couple hundred container listings downloaded.

Attachments (1)

Screen Shot 2014-12-05 at 12.41.23.png (65.0 KB) - added by dkocher on Dec 5, 2014 at 11:45:04 AM.

Download all attachments as: .zip

Change History (14)

comment:1 follow-up: Changed on Nov 25, 2014 at 8:58:54 AM by dkocher

  • Component changed from core to cloudfiles
  • Owner set to dkocher
  • Summary changed from Rackspace Cloud Files not working to Container listing stalled

Do you get a prompt that asks if you want to continue listing containers after the first 100?

comment:2 Changed on Nov 25, 2014 at 3:04:04 PM by dkocher

  • Milestone set to 4.6.1
  • Status changed from new to assigned

comment:3 in reply to: ↑ 1 Changed on Nov 25, 2014 at 5:11:43 PM by jklovanc

Replying to dkocher:

Do you get a prompt that asks if you want to continue listing containers after the first 100?

No all that happened was the downloading spinner kept flickering on and off. If you are going to the 100 at a time listing, the same way Rackspace does it, then it becomes unusable as I have a couple thousand containers. Clicking "continue" after each 100 would mean that I would have to babysit the download and click twenty times to get a complete listing.

comment:4 Changed on Dec 4, 2014 at 3:44:52 PM by dkocher

We cannot reproduce the issue that no prompt is shown to Cancel or Continue when listing all containers. When choosing Cancel, it will display the first 100 containers in the browser. Set the container you want to access in the Path bookmark setting to connect directly to the container without listing all containers in the account.

You can further speed up the container listing by setting the following hidden configuration options.

  • Disable preloading container size using the property openstack.container.size.preload
defaults write ch.sudo.cyberduck openstack.container.size.preload false
  • Disable reading CDN conifguration for container using the property openstack.cdn.preload
defaults write ch.sudo.cyberduck openstack.cdn.preload false

comment:5 Changed on Dec 4, 2014 at 3:47:51 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:6 Changed on Dec 4, 2014 at 5:26:19 PM by jklovanc

Sorry but "worksforme" is rarely an actual solution. Did you create an account with a couple thousand containers? Also, crippling the download is just an admission that your new release has issues that you will not fix. I am using 4.4.5 which works fine while 4.6 does not work. This leads me to believe that there is an issue with 4.6. I will even privately send you a login to our account so you can see the problem in action.

comment:7 Changed on Dec 5, 2014 at 11:40:09 AM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:8 Changed on Dec 5, 2014 at 11:44:30 AM by dkocher

Reducing the number of HTTP requests by factor 10 in r16022.

comment:9 Changed on Dec 5, 2014 at 11:45:26 AM by dkocher

Can you confirm you get the prompt

comment:10 Changed on Dec 5, 2014 at 11:47:05 AM by dkocher

Disable size preload by default in r16023. Reverted in r16027.

Last edited on Dec 5, 2014 at 11:58:46 AM by dkocher (previous) (diff)

comment:12 Changed on Dec 5, 2014 at 11:58:55 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:13 Changed on Dec 5, 2014 at 12:05:14 PM by dkocher

Please update to the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software