Cyberduck Mountain Duck CLI

#8383 closed defect (worksforme)

Application hangs with "caught burning CPU" message

Reported by: rexemtrebor Owned by:
Priority: normal Milestone:
Component: core Version: 4.6
Severity: major Keywords: crash, 10.10
Cc: Architecture:
Platform:

Description

I upgraded to OS 10.10 recently. Now I have the problem that cyberduck stucks while I am trying to upload a file with ssh on my server. The CPU-usage goes up to 100% for the cyberduck process and the only way to close it is to force it to quit via "force quit"

Everything else works fine - I can connect my server, I can compress files etc.

I tried to go back to 4.5.2 and move forward to the snapshot 4.6.1 without any success.

I can give you my log file - but I don´t want to upload it in this public forum, so maybe you can give me a email adress for this.

Change History (8)

comment:1 Changed on Dec 2, 2014 at 3:58:30 PM by dkocher

Please mail to feedback@….

comment:2 Changed on Dec 2, 2014 at 3:58:47 PM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:3 Changed on Dec 2, 2014 at 3:58:55 PM by dkocher

Please attach the crash report.

comment:4 follow-up: Changed on Dec 4, 2014 at 4:38:26 PM by dkocher

  • Summary changed from Crashes while trying to upload a file to Application terminated by launchd while trying to upload a file with signal 15
Dec  3 14:23:47 notebook-2 kernel[0]: process Cyberduck[22743] thread 2897123 caught burning CPU!; EXC_RESOURCE supressed due to audio playback
Dec  3 14:26:53 notebook-2 com.apple.xpc.launchd[1] (ch.sudo.cyberduck.229788[22743]): Service exited due to signal: Terminated: 15 

comment:5 Changed on Dec 4, 2014 at 4:39:37 PM by dkocher

  • Severity changed from normal to major

comment:6 Changed on Dec 8, 2014 at 1:05:28 PM by dkocher

  • Summary changed from Application terminated by launchd while trying to upload a file with signal 15 to Application hangs with "caught burning CPU" message

comment:7 in reply to: ↑ 4 Changed on Dec 8, 2014 at 1:05:53 PM by dkocher

Replying to dkocher:

Dec 3 14:26:53 notebook-2 com.apple.xpc.launchd[1] (ch.sudo.cyberduck.229788[22743]): Service exited due to signal: Terminated: 15 }}}

Caused by force quitting the application.

comment:8 Changed on Dec 10, 2014 at 12:40:47 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I was able to fix the problem: After deleting the file transmission history the problem vanished - there were a lot of transfers in there, dating back until 2010. So maybe there is a problem with many files in the history, or maybe the history file was somehow corrupt,…

We are aware that loading the transfer history should be more efficient.

Note: See TracTickets for help on using tickets.
swiss made software