Cyberduck Mountain Duck CLI

#8393 closed defect (fixed)

Wrong timestamp in tempurl. Ticket #8384 fixed not correctly

Reported by: aivaras.sukackas Owned by: dkocher
Priority: normal Milestone: 4.6.1
Component: openstack Version: 4.6
Severity: normal Keywords:
Cc: aivaras.sukackas@… Architecture: Intel
Platform: Windows 8.1

Description (last modified by aivaras.sukackas)

Hello, in ticket #8384 was mentioned, that timestamp is generating not correctly. After fix, time stamp is generated: 'temp_url_expires=3600' which is not correct. It should be formatted in UNIX timestamp (seconds since Jan 01 1970 until now plus hour, week and etc. in seconds).

still using miliseconds not seconds in time stamp

Change History (7)

comment:1 Changed on Dec 3, 2014 at 7:58:03 AM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed on Dec 3, 2014 at 12:12:07 PM by dkocher

Sorry for the additional regression. Fixed in r15968.

comment:3 Changed on Dec 5, 2014 at 9:24:45 AM by aivaras.sukackas

  • Description modified (diff)
  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:4 Changed on Dec 5, 2014 at 9:25:31 AM by aivaras.sukackas

  • Description modified (diff)

comment:5 Changed on Dec 5, 2014 at 9:28:48 AM by aivaras.sukackas

  • Description modified (diff)

comment:6 Changed on Dec 5, 2014 at 12:24:55 PM by dkocher

Fix and test in r16028.

comment:7 Changed on Dec 5, 2014 at 12:25:22 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software