Cyberduck Mountain Duck CLI

#8409 closed defect (fixed)

Exception reading proxy settings with "Auto Proxy Discovery" enabled

Reported by: peter huss Owned by:
Priority: normal Milestone: 4.6.1
Component: core Version: 4.6
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

I upgraded to 4.6 today (I believe I was on 4.5.x previously), and now I am unable to connect to any FTP / SFTP server. I tried using bookmarks that worked prior to upgrading, as well as the Open Connection dialog. I removed the preferences .plist file and reinstalled the app but still encounter the error.

When you click Connect, the message 'Opening SFTP connection to [...]' appears for a few milliseconds in the bottom status bar then silently fails.

There is no output in the Log Drawer, but the exception backtrace does appear in Console.app:

Cyberduck[2274]: [background-1] FATAL ch.cyberduck.ui.AbstractController - Unhandled exception running background task Expected scheme name at index 0: ://(null):(null)
	
	java.lang.IllegalArgumentException: Expected scheme name at index 0: ://(null):(null)
		at java.net.URI.create(URI.java:859)
		at ch.cyberduck.core.SystemConfigurationProxy.find(SystemConfigurationProxy.java:67)
		at ch.cyberduck.core.ProxySocketFactory.factory(ProxySocketFactory.java:70)
		at ch.cyberduck.core.ProxySocketFactory.createSocket(ProxySocketFactory.java:89)
		at net.schmizz.sshj.SocketClient.connect(SocketClient.java:49)
		at net.schmizz.sshj.SocketClient.connect(SocketClient.java:57)
		at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:160)
		at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:123)
		at ch.cyberduck.core.sftp.SFTPSession.connect(SFTPSession.java:75)
		at ch.cyberduck.core.Session.open(Session.java:112)
		at ch.cyberduck.core.LoginConnectionService.connect(LoginConnectionService.java:151)
		at ch.cyberduck.core.LoginConnectionService.check(LoginConnectionService.java:98)
		at ch.cyberduck.core.LoginConnectionService.check(LoginConnectionService.java:105)
		at ch.cyberduck.core.threading.SessionBackgroundAction.connect(SessionBackgroundAction.java:198)
		at ch.cyberduck.ui.threading.BrowserBackgroundAction.connect(BrowserBackgroundAction.java:59)
		at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:166)
		at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:171)
		at java.util.concurrent.FutureTask.run(FutureTask.java:262)
		at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
		at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
		at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
		at java.lang.Thread.run(Thread.java:724)
	Caused by: java.net.URISyntaxException: Expected scheme name at index 0: ://(null):(null)
		at java.net.URI$Parser.fail(URI.java:2829)
		at java.net.URI$Parser.failExpecting(URI.java:2835)
		at java.net.URI$Parser.parse(URI.java:3027)
		at java.net.URI.<init>(URI.java:595)
		at java.net.URI.create(URI.java:857)
		... 21 more

Attachments (1)

Screen Shot 2014-12-10 at 11.05.09 AM.png (90.2 KB) - added by peter huss on Dec 10, 2014 at 7:15:26 PM.
OS X network proxy settings

Download all attachments as: .zip

Change History (10)

comment:1 Changed on Dec 10, 2014 at 9:25:50 AM by dkocher

Can you please make a screenshot of your proxy settings in System Preferences → Network → Advanced… → Proxies and attach it here.

comment:2 Changed on Dec 10, 2014 at 9:27:20 AM by dkocher

  • Summary changed from Unable to connect after upgrading to 4.6 to Exception reading proxy settings

comment:3 Changed on Dec 10, 2014 at 9:28:02 AM by dkocher

  • Milestone set to 4.6.1
  • Resolution set to fixed
  • Status changed from new to closed

In r15840.

comment:4 Changed on Dec 10, 2014 at 9:28:21 AM by dkocher

Please update to the latest snapshot build available and let me know if that fixes the issue.

Changed on Dec 10, 2014 at 7:15:26 PM by peter huss

OS X network proxy settings

comment:5 follow-up: Changed on Dec 10, 2014 at 7:17:44 PM by peter huss

Thanks for the fast response! The latest snapshot build resolved the issue. I've also attached my proxy settings to the ticket.

comment:6 in reply to: ↑ 5 Changed on Dec 10, 2014 at 7:33:33 PM by dkocher

Replying to peter huss:

Thanks for the fast response! The latest snapshot build resolved the issue. I've also attached my proxy settings to the ticket.

Thanks for providing the details of your configuration.

comment:7 Changed on Dec 10, 2014 at 7:35:09 PM by dkocher

  • Summary changed from Exception reading proxy settings to Exception reading proxy settings with "Auto Proxy Discovery" enabled

comment:8 Changed on Dec 12, 2014 at 10:07:09 AM by dkocher

#8417 closed as duplicate.

comment:9 Changed on Dec 12, 2014 at 10:07:35 AM by dkocher

Fix reading type regression from r15777. Handle failures parsing proxy URL and fail silently with direct connection in r16121.

Note: See TracTickets for help on using tickets.