Cyberduck Mountain Duck CLI

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8414 closed defect (fixed)

Crash reading proxy settings

Reported by: wallenium Owned by: dkocher
Priority: high Milestone: 4.6.2
Component: core Version: 4.6
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description (last modified by dkocher)

I am using the latest nightly build (Version 4.6.1 (16109)) because of the other issue/crash i had. sftp is working fine, but normal ftp crashes after the warning message that the password will be transferred insecure. not sure why. Crash log sent a couple of times, attached again:

Process:               Cyberduck [33824]
Path:                  /Applications/Cyberduck.app/Contents/MacOS/Cyberduck
Identifier:            ch.sudo.cyberduck
Version:               4.6.1 (16109)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Cyberduck [33824]
User ID:               501

Date/Time:             2014-12-10 18:23:39.303 +0100
OS Version:            Mac OS X 10.10.1 (14B25)
Report Version:        11
Anonymous UUID:        533B50E2-3232-2B68-F81A-57202CD355D2

Sleep/Wake UUID:       6912A8F0-E31F-4ADB-AF59-75C91B4C62B3

Time Awake Since Boot: 130000 seconds
Time Since Wake:       570 seconds

Crashed Thread:        31  Java: background-1

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x00005d4900000018

VM Regions Near 0x5d4900000018:
    VM_ALLOCATE (reserved) 00000007fed00000-0000000800000000 [ 19.0M] rw-/rwx SM=NUL  reserved VM address space (unallocated)
--> 
    MALLOC_NANO            0000600000000000-0000600000600000 [ 6144K] rw-/rwx SM=COW  

Application Specific Information:
abort() called

Thread 31 Crashed:: Java: background-1
0   libsystem_kernel.dylib        	0x00007fff93b07282 __pthread_kill + 10
1   libsystem_c.dylib             	0x00007fff92fa4b73 abort + 129
2   libjvm.dylib                  	0x0000000103266709 os::abort(bool) + 25
3   libjvm.dylib                  	0x000000010336db74 VMError::report_and_die() + 2316
4   libjvm.dylib                  	0x000000010326801b JVM_handle_bsd_signal + 1073
5   libsystem_platform.dylib      	0x00007fff8a1fff1a _sigtramp + 26
6   libobjc.A.dylib               	0x00007fff91a7b0dd objc_msgSend + 29
7   libProxy.dylib                	0x0000000109e9e268 Java_ch_cyberduck_core_SystemConfigurationProxy_findNative + 62
8   ???                           	0x0000000103a35738 0 + 4356003640
9   ???                           	0x0000000103a29233 0 + 4355953203
10  ???                           	0x0000000103a298e1 0 + 4355954913
11  ???                           	0x0000000103a29233 0 + 4355953203
12  ???                           	0x0000000103a29233 0 + 4355953203
13  ???                           	0x0000000103a29233 0 + 4355953203
14  ???                           	0x0000000103a29233 0 + 4355953203
15  ???                           	0x0000000103a29233 0 + 4355953203
16  ???                           	0x0000000103a29233 0 + 4355953203
17  ???                           	0x0000000103a29233 0 + 4355953203
18  ???                           	0x0000000103a29233 0 + 4355953203
19  ???                           	0x0000000103a29233 0 + 4355953203
20  ???                           	0x0000000103a298e1 0 + 4355954913
21  ???                           	0x0000000103a29233 0 + 4355953203
22  ???                           	0x0000000103a298e1 0 + 4355954913
23  ???                           	0x0000000103a29233 0 + 4355953203
24  ???                           	0x0000000103a29233 0 + 4355953203
25  ???                           	0x0000000103a29233 0 + 4355953203
26  ???                           	0x0000000103a29233 0 + 4355953203
27  ???                           	0x0000000103a29233 0 + 4355953203
28  ???                           	0x0000000103a29233 0 + 4355953203
29  ???                           	0x0000000103a29233 0 + 4355953203
30  ???                           	0x0000000103a29233 0 + 4355953203
31  ???                           	0x0000000103a298e1 0 + 4355954913
32  ???                           	0x0000000103a298e1 0 + 4355954913
33  ???                           	0x0000000103a29706 0 + 4355954438
34  ???                           	0x0000000103a29058 0 + 4355952728
35  ???                           	0x0000000103a29706 0 + 4355954438
36  ???                           	0x0000000103a29706 0 + 4355954438
37  ???                           	0x0000000103a234f7 0 + 4355929335
38  libjvm.dylib                  	0x0000000103140954 JavaCalls::call_helper(JavaValue*, methodHandle*, JavaCallArguments*, Thread*) + 554
39  libjvm.dylib                  	0x0000000103140e6b JavaCalls::call_virtual(JavaValue*, KlassHandle, Symbol*, Symbol*, JavaCallArguments*, Thread*) + 283
40  libjvm.dylib                  	0x0000000103140fa8 JavaCalls::call_virtual(JavaValue*, Handle, KlassHandle, Symbol*, Symbol*, Thread*) + 74
41  libjvm.dylib                  	0x0000000103174088 thread_entry(JavaThread*, Thread*) + 173
42  libjvm.dylib                  	0x0000000103338ba5 JavaThread::thread_main_inner() + 155
43  libjvm.dylib                  	0x000000010333a27f JavaThread::run() + 417
44  libjvm.dylib                  	0x0000000103266c95 java_start(Thread*) + 213
45  libsystem_pthread.dylib       	0x00007fff873ff2fc _pthread_body + 131
46  libsystem_pthread.dylib       	0x00007fff873ff279 _pthread_start + 176
47  libsystem_pthread.dylib       	0x00007fff873fd4b1 thread_start + 13


Attachments (2)

Cyberduck_2014-12-12-172749_Simons-MacBook-Pro.crash (93.6 KB) - added by wallenium 4 years ago.
New crash log
system.log (943 bytes) - added by wallenium 4 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 4 years ago by dkocher

Please attach any related output in the system.log (/Applications/Utilities/Console.app).

comment:2 Changed 4 years ago by dkocher

  • Description modified (diff)

comment:3 Changed 4 years ago by dkocher

  • Description modified (diff)

comment:4 Changed 4 years ago by dkocher

  • Summary changed from crash when connecting to insecure ftp connection to Crash in SystemConfigurationProxy_find

comment:5 Changed 4 years ago by dkocher

#8415 closed as duplicate.

comment:6 Changed 4 years ago by dkocher

Please post a screenshot of your settings in System Preferences → Network → Advanced… → Proxies.

comment:7 Changed 4 years ago by wallenium

Screenshot of Proxy settings. http://note.io/13edsGO

https://www.evernote.com/shard/s234/sh/500a1fc2-4e8b-4be9-be64-6ddf2982e7f8/2dcd5c54e5a368308aea765d70b3024f/res/d46415c3-dadb-4938-8862-3593f5aa780d/skitch.png

maybe i got the cause. when i uncheck the PASV, it seems to work (http://note.io/12A2ACi). But i need PASV for some wifi networks...

Dec 12 00:43:18 Simons-MBP.fritz.box Cyberduck[5597]: -[NSInvocation objectForKey:]: unrecognized selector sent to instance 0x600000470200
Dec 12 00:43:18 Simons-MBP.fritz.box Cyberduck[5597]: An uncaught exception was raised
Dec 12 00:43:18 Simons-MBP.fritz.box Cyberduck[5597]: -[NSInvocation objectForKey:]: unrecognized selector sent to instance 0x600000470200
Dec 12 00:43:18 Simons-MBP.fritz.box Cyberduck[5597]: (
		0   CoreFoundation                      0x00007fff91be064c __exceptionPreprocess + 172
		1   libobjc.A.dylib                     0x00007fff92aba6de objc_exception_throw + 43
		2   CoreFoundation                      0x00007fff91be36bd -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
		3   CoreFoundation                      0x00007fff91b2aa84 ___forwarding___ + 1028
		4   CoreFoundation                      0x00007fff91b2a5f8 _CF_forwarding_prep_0 + 120
		5   libProxy.dylib                      0x00000001003c5381 +[Proxy find:] + 249
		6   libProxy.dylib                      0x00000001003c5268 Java_ch_cyberduck_core_SystemConfigurationProxy_findNative + 62
		7   ???                                 0x0000000103a35738 0x0 + 4356003640
	)
Dec 12 00:43:18 Simons-MBP.fritz.box Cyberduck[5597]: *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[NSInvocation objectForKey:]: unrecognized selector sent to instance 0x600000470200'
	*** First throw call stack:
	(
		0   CoreFoundation                      0x00007fff91be064c __exceptionPreprocess + 172
		1   libobjc.A.dylib                     0x00007fff92aba6de objc_exception_throw + 43
		2   CoreFoundation                      0x00007fff91be36bd -[NSObject(NSObject) doesNotRecognizeSelector:] + 205
		3   CoreFoundation                      0x00007fff91b2aa84 ___forwarding___ + 1028
		4   CoreFoundation                      0x00007fff91b2a5f8 _CF_forwarding_prep_0 + 120
		5   libProxy.dylib                      0x00000001003c5381 +[Proxy find:] + 249
		6   libProxy.dylib                      0x00000001003c5268 Java_ch_cyberduck_core_SystemConfigurationProxy_findNative + 62
		7   ???                                 0x0000000103a35738 0x0 + 4356003640
	)
Dec 12 00:43:18 Simons-MBP com.apple.xpc.launchd[1] (com.apple.ReportCrash[5606]): Endpoint has been activated through legacy launch(3) APIs. Please switch to XPC or bootstrap_check_in(): com.apple.ReportCrash
Dec 12 00:43:19 Simons-MBP.fritz.box CoreServicesUIAgent[2035]: unexpected message <OS_xpc_error: <error: 0x7fff77f02c60> { count = 1, contents =
		"XPCErrorDescription" => <string: 0x7fff77f02f70> { length = 18, contents = "Connection invalid" }
	}>
Dec 12 00:43:19 Simons-MBP com.apple.xpc.launchd[1] (ch.sudo.cyberduck.44620[5597]): Service exited due to signal: Abort trap: 6
Dec 12 00:43:19 Simons-MBP.fritz.box ReportCrash[5606]: Saved crash report for Cyberduck[5597] version 4.6.1 (16109) to /Users/swallmann/Library/Logs/DiagnosticReports/Cyberduck_2014-12-12-004319_Simons-MacBook-Pro.crash
Dec 12 00:43:19 Simons-MBP.fritz.box Problem Reporter[5607]: Failed to connect (_imageWell) outlet from (ProblemReportWindowController) to (NSImageView): missing setter or instance variable
Dec 12 00:43:20 Simons-MBP.fritz.box system_profiler[5609]: platformPluginDictionary: Can't get X86PlatformPlugin, return value 0
Last edited 4 years ago by dkocher (previous) (diff)

comment:8 Changed 4 years ago by dkocher

  • Owner set to dkocher
  • Status changed from new to assigned

comment:9 Changed 4 years ago by dkocher

Fix reading type regression from r15777. Handle failures parsing proxy URL and fail silently with direct connection in r16121.

comment:10 Changed 4 years ago by dkocher

Can you please test the latest snapshot build 4.6.1 (16121).

Changed 4 years ago by wallenium

New crash log

Changed 4 years ago by wallenium

comment:11 Changed 4 years ago by wallenium

still crashing. Added the system.log and the crash report.

comment:12 Changed 4 years ago by dkocher

As a workaround in the meantime, please disable Cyberduck → Preferences → Connection → Proxies → Use system proxy settings .

comment:13 Changed 4 years ago by wallenium

I disabled the PASV checkbox on the bottom, this is working as workaround, too.

comment:14 Changed 4 years ago by dkocher

Can you attach the file /Library/Preferences/SystemConfiguration/preferences.plist.

comment:15 Changed 4 years ago by dkocher

#8458 closed as duplicate.

comment:16 Changed 4 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r16453.

comment:17 Changed 4 years ago by dkocher

Please try the latest snapshot build available (r16452 or later).

comment:18 Changed 4 years ago by dkocher

Please update to the latest snapshot build available and post a comment if the issue is fixed.

comment:19 Changed 4 years ago by dkocher

  • Summary changed from Crash in SystemConfigurationProxy_find to Crash reading proxy settings
Note: See TracTickets for help on using tickets.
swiss made software