Cyberduck Mountain Duck CLI

#8415 closed defect (duplicate)

Crash in Java_ch_cyberduck_core_SystemConfigurationProxy_findNative

Reported by: jtowers100 Owned by:
Priority: high Milestone: 4.6.1
Component: core Version: 4.6
Severity: critical Keywords:
Cc: Architecture:
Platform: Mac OS X 10.10

Description (last modified by dkocher)

When I attempt to open a connection via a bookmark (double click) the application looks like it's working then stops although the log drawer remains empty. If I double click on the bookmark for a second time the application crashes. Crash report attached.

Thread 29 Crashed:: Java: background-1
0   libsystem_kernel.dylib        	0x00007fff8657b282 __pthread_kill + 10
1   libsystem_c.dylib             	0x00007fff869bdb73 abort + 129
2   libjvm.dylib                  	0x0000000107047709 os::abort(bool) + 25
3   libjvm.dylib                  	0x000000010714eb74 VMError::report_and_die() + 2316
4   libjvm.dylib                  	0x000000010704901b JVM_handle_bsd_signal + 1073
5   libsystem_platform.dylib      	0x00007fff90039f1a _sigtramp + 26
6   libobjc.A.dylib               	0x00007fff8bd2a0dd objc_msgSend + 29
7   libProxy.dylib                	0x0000000132bc92d4 Java_ch_cyberduck_core_SystemConfigurationProxy_findNative + 62
8   ???                           	0x0000000107866698 0 + 4421215896
9   ???                           	0x000000010785a233 0 + 4421165619
10  ???                           	0x000000010785a8e1 0 + 4421167329
11  ???                           	0x000000010785a233 0 + 4421165619
12  ???                           	0x000000010785a233 0 + 4421165619
13  ???                           	0x000000010785a058 0 + 4421165144
14  ???                           	0x000000010785a058 0 + 4421165144
15  ???                           	0x000000010785a233 0 + 4421165619
16  ???                           	0x000000010785a233 0 + 4421165619
17  ???                           	0x000000010785a233 0 + 4421165619
18  ???                           	0x000000010785a058 0 + 4421165144
19  ???                           	0x000000010785a350 0 + 4421165904
20  ???                           	0x000000010785a9fe 0 + 4421167614
21  ???                           	0x000000010785a350 0 + 4421165904
22  ???                           	0x000000010785a350 0 + 4421165904
23  ???                           	0x000000010785a8e1 0 + 4421167329
24  ???                           	0x000000010785a8e1 0 + 4421167329
25  ???                           	0x000000010785a706 0 + 4421166854
26  ???                           	0x000000010785a058 0 + 4421165144
27  ???                           	0x000000010785a706 0 + 4421166854
28  ???                           	0x000000010785a706 0 + 4421166854
29  ???                           	0x00000001078544f7 0 + 4421141751
30  libjvm.dylib                  	0x0000000106f21954 JavaCalls::call_helper(JavaValue*, methodHandle*, JavaCallArguments*, Thread*) + 554
31  libjvm.dylib                  	0x0000000106f21e6b JavaCalls::call_virtual(JavaValue*, KlassHandle, Symbol*, Symbol*, JavaCallArguments*, Thread*) + 283
32  libjvm.dylib                  	0x0000000106f21fa8 JavaCalls::call_virtual(JavaValue*, Handle, KlassHandle, Symbol*, Symbol*, Thread*) + 74
33  libjvm.dylib                  	0x0000000106f55088 thread_entry(JavaThread*, Thread*) + 173
34  libjvm.dylib                  	0x0000000107119ba5 JavaThread::thread_main_inner() + 155
35  libjvm.dylib                  	0x000000010711b27f JavaThread::run() + 417
36  libjvm.dylib                  	0x0000000107047c95 java_start(Thread*) + 213
37  libsystem_pthread.dylib       	0x00007fff8cb222fc _pthread_body + 131
38  libsystem_pthread.dylib       	0x00007fff8cb22279 _pthread_start + 176
39  libsystem_pthread.dylib       	0x00007fff8cb204b1 thread_start + 13

Attachments (3)

Cyberduck Crash Report.txt (96.5 KB) - added by jtowers100 on Dec 10, 2014 at 5:54:04 PM.
Crash Reports
Advanced Network Settings.tiff (80.0 KB) - added by jtowers100 on Dec 11, 2014 at 5:21:41 PM.
System Log.txt (4.0 KB) - added by jtowers100 on Dec 11, 2014 at 5:27:27 PM.

Download all attachments as: .zip

Change History (10)

Changed on Dec 10, 2014 at 5:54:04 PM by jtowers100

Crash Reports

comment:1 Changed on Dec 11, 2014 at 4:36:59 PM by dkocher

Please attach any related output in the system.log (/Applications/Utilities/Console.app).

comment:2 Changed on Dec 11, 2014 at 4:37:36 PM by dkocher

  • Description modified (diff)

comment:3 Changed on Dec 11, 2014 at 4:37:55 PM by dkocher

  • Summary changed from Crash when attempting to open a connection for 2nd time to Crash in Java_ch_cyberduck_core_SystemConfigurationProxy_findNative

comment:4 Changed on Dec 11, 2014 at 4:39:59 PM by dkocher

  • Milestone set to 4.6.1
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #8414.

comment:5 Changed on Dec 11, 2014 at 4:42:05 PM by dkocher

Please post a screenshot of your settings in System Preferences → Network → Advanced… → Proxies.

Changed on Dec 11, 2014 at 5:21:41 PM by jtowers100

Changed on Dec 11, 2014 at 5:27:27 PM by jtowers100

comment:6 Changed on Jan 14, 2015 at 10:30:20 AM by dkocher

Please update to the latest snapshot build available and post a comment if the issue is fixed.

Note: See TracTickets for help on using tickets.
swiss made software