Cyberduck Mountain Duck CLI

#8419 closed defect (thirdparty)

Some images are displaying older versions on site after overwritting existing ones

Reported by: anna.vandyke Owned by: dkocher
Priority: normal Milestone:
Component: sftp Version: 4.6
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Hi,

We have an issue with Cyberduck - if we overwrite an image with a newer version (same name), some of the images are still displayed as an older version on the site even after clearing the cache. Sometimes it takes up to 24 hours to see the image being updated, but on one of them it has been over 48 hours and i don't see the new one. If I download the image from the server through Cyberduck, it displays the correct one.

The issue is experienced on both Mac and PC with 2 different sites/ servers setup - one with Varnish cache and one without. Cyberduck versions we are using 4.6 and 4.3.1. The issue has been around for a while, but no one actually tried to get it sovled until I came onboard.

There is no image caching site up. The issue is not present with FileZilla or if we SSH through PuTTY. However not all our designers are comfortable with command line and to use FileZilla I have to lock the server in Live Dev (we are currently moving to Acquia) which means no code commits are allowed during that time.

The only way around at this point is to rename the images and then update the file paths, but for a site with over 600 nodes this is getting very time consuming and we'll need to be able to update the images on the fly.

Any help will be appreciated.

Thanks.

Change History (1)

comment:1 Changed on Dec 12, 2014 at 9:09:21 AM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

Maybe Preserve modification dates for uploads in Preferences → Transfers is the culprit that the server does not invalidate the files.

Note: See TracTickets for help on using tickets.