Cyberduck Mountain Duck CLI

#8437 closed defect (fixed)

Null pointer in Host.serialize

Reported by: lumigraphics Owned by: dkocher
Priority: normal Milestone: 4.6.2
Component: ftp Version: 4.6.1
Severity: critical Keywords: login, logout, connection
Cc: Architecture: Intel
Platform: Windows 7

Description (last modified by dkocher)

Tested on multiple servers, when logging in, I get logged out immediately. Changing the preference to require logout verification doesn't help.

Cyberduck 4.6.1, Windows 7 Professional SP1

220 XXX XXXXXX
USER XXXXXXX
331 User XXXXXXX OK. Password required
PASS ********
230-User XXXXXXX has group access to:  ftpgroup  
230 OK. Current directory is /
FEAT
211-Extensions supported:
 EPRT
 IDLE
 MDTM
 SIZE
 REST STREAM
 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
 MLSD
 ESTA
 PASV
 EPSV
 SPSV
 ESTP
211 End.
SYST
215 UNIX Type: L8
QUIT
221-Goodbye. You uploaded 0 and downloaded 0 kbytes.
221 Logout.

Attachments (1)

cyberduck.log (706.1 KB) - added by lumigraphics on Dec 22, 2014 at 4:47:06 PM.

Download all attachments as: .zip

Change History (15)

comment:1 Changed on Dec 22, 2014 at 3:23:17 PM by lumigraphics

This is the log from the same ftp site, using ws_ftp. If I check the option for Cyberduck to use passive mode, it crashes as soon as I try to connect.

Finding Host ftp.xxxxxxx.com ...
Connecting to xxxxxxxx
Connected to xxxxxxxxx in 0.027000 seconds, Waiting for Server Response
220 xxxxxx
Host type (1): AUTO
USER xxxxxxx
331 User xxxxxxx OK. Password required
PASS (hidden)
230-User xxxxxxx has group access to:  ftpgroup  
230 OK. Current directory is /
SYST
215 UNIX Type: L8
Host type (2): Unix (Standard)
Sending "FEAT" command to determine what features this server supports.
FEAT
211-Extensions supported:
 EPRT
 IDLE
 MDTM
 SIZE
 REST STREAM
 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
 MLSD
 ESTA
 PASV
 EPSV
 SPSV
 ESTP
211 End.
Finished interpreting "FEAT" response.
Sending the FEAT command is optional.  You can disable it in the site options of the profile.
PWD
257 "/" is your current location
TYPE A200 TYPE is now ASCII
PASV
227 Entering Passive Mode (xxxxxx)
connecting data channel to xxxxxx
data channel connected to xxxxxxx
LIST
150 Accepted data connection
transferred 0 bytes in < 0.001 seconds, 0.000 bps ( 0.000 Bps), transfer succeeded.
226-Options: -l 
226 0 matches total

Last edited on Dec 22, 2014 at 3:25:08 PM by dkocher (previous) (diff)

comment:2 Changed on Dec 22, 2014 at 3:25:31 PM by dkocher

  • Component changed from core to ftp
  • Description modified (diff)
  • Owner set to dkocher

comment:3 Changed on Dec 22, 2014 at 3:27:03 PM by dkocher

Please attach the file cyberduck.log in the application support directory.

comment:4 Changed on Dec 22, 2014 at 3:27:10 PM by dkocher

  • Milestone set to 4.6.2

Changed on Dec 22, 2014 at 4:47:06 PM by lumigraphics

comment:5 follow-ups: Changed on Dec 22, 2014 at 4:48:56 PM by lumigraphics

Log attached. Please note also that I updated to the current Java release Version 8 Update 25 (32-bit) with no changes to the issue.

comment:6 in reply to: ↑ 5 Changed on Dec 22, 2014 at 4:54:59 PM by dkocher

Replying to lumigraphics:

Log attached. Please note also that I updated to the current Java release Version 8 Update 25 (32-bit) with no changes to the issue.

Cyberduck requires no Java installation.

comment:7 Changed on Dec 22, 2014 at 4:55:52 PM by dkocher

  • Status changed from new to assigned
  • Summary changed from Windows - logged out immediately to Null pointer in Host.serialize

comment:8 Changed on Dec 22, 2014 at 5:01:36 PM by lumigraphics

Ok thank you. I saw the null pointer exception listed as java.lang.NullPointerException

Glad we could ID a bug :)

comment:9 Changed on Dec 22, 2014 at 8:12:38 PM by dkocher

Can you attach the bookmark that is causing the problem. You can find them in the application support directory.

comment:10 in reply to: ↑ 5 Changed on Jan 5, 2015 at 2:01:31 PM by dkocher

Replying to lumigraphics:

Log attached. Please note also that I updated to the current Java release Version 8 Update 25 (32-bit) with no changes to the issue.

Caused by: java.lang.NullPointerException
	at ch.cyberduck.core.Host.serialize(Host.java:279)
	at ch.cyberduck.ui.threading.BrowserBackgroundAction.connect(BrowserBackgroundAction.java:67)
	at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:166)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:175)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:167)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:604)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:937)

comment:11 Changed on Jan 5, 2015 at 10:43:34 PM by dkocher

#8460 closed as duplicate.

comment:12 Changed on Jan 6, 2015 at 11:06:07 AM by dkocher

  • Severity changed from normal to critical

comment:13 Changed on Jan 6, 2015 at 11:25:01 AM by yla

  • Resolution set to fixed
  • Status changed from assigned to closed

In r16263.

comment:14 Changed on Jan 6, 2015 at 11:35:32 AM by dkocher

Please update to the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software