Cyberduck Mountain Duck CLI

#8438 closed defect (fixed)

Transfers window stops refreshing

Reported by: bmscavo Owned by: bmscavo
Priority: normal Milestone: 4.7.1
Component: interface Version: 4.6.1
Severity: normal Keywords: transfers, uploads, upload,
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

After uploading for a while, all of the status information in the Transfers window stops refreshing. I am unable to track down what triggers this.

For example, the amount uploaded, the upload speed, and the estimated time are frozen. This occurs for all transfers in the window. It seems to just be a rendering issue, because I can do several things to refresh it manually: 1) I can close the Transfers window and reopen it, 2) I can hit any of the buttons at the top of the Transfers window, such as "Show" or "Stop", or 3) I can scroll down the list until a particular transfer is not visible and then scroll back up. When I do either of these things, all of the affected data updates once, but then remains frozen. Alternatively, I can quit Cyberduck and then resume transfers and the status information will constantly refresh as normal.

I am confident that the transfers themselves are not actually affected, as they still continue and complete as normal.

There are no logs available to attach.

Change History (17)

comment:1 Changed on Dec 22, 2014 at 3:49:18 PM by dkocher

I can confirm that we have seen this occasionally since 10.10.

comment:2 Changed on Jan 20, 2015 at 1:17:39 PM by dkocher

  • Milestone set to 4.6.4
  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen this issue if you still see this on 10.10.1.

comment:3 Changed on Feb 9, 2015 at 12:41:02 PM by dkocher

#8567 closed as duplicate.

comment:4 Changed on Feb 16, 2015 at 2:28:07 PM by dkocher

  • Milestone 4.6.4 deleted
  • Resolution worksforme deleted
  • Status changed from closed to reopened

#8583 closed as duplicate.

comment:5 Changed on Mar 31, 2015 at 10:24:31 AM by dkocher

#8666 closed as duplicate.

comment:6 Changed on Apr 2, 2015 at 7:59:44 AM by dkocher

  • Milestone set to 4.7
  • Resolution set to fixed
  • Status changed from reopened to closed

Will close this with changeset r17210. Please reopen if the issue occurs again.

comment:7 Changed on Apr 7, 2015 at 1:34:48 PM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 follow-up: Changed on Apr 7, 2015 at 1:39:28 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Disabled view based cell handling in transfer table view in r17260.

comment:9 Changed on Apr 17, 2015 at 8:09:13 AM by dkocher

#8751 closed as duplicate.

comment:10 Changed on Apr 27, 2015 at 8:55:40 AM by dkocher

  • Milestone changed from 4.7 to 4.8
  • Resolution fixed deleted
  • Status changed from closed to reopened

#8768 closed as duplicate.

comment:11 in reply to: ↑ 8 Changed on May 13, 2015 at 1:50:11 PM by dkocher

Replying to dkocher:

Disabled view based cell handling in transfer table view in r17260.

Reverted in r17505.

comment:12 Changed on May 19, 2015 at 12:35:33 PM by dkocher

#8817 closed as duplicate.

comment:13 follow-up: Changed on Jun 3, 2015 at 7:22:15 PM by dkocher

#8858 closed as duplicate.

comment:14 in reply to: ↑ 13 Changed on Jun 3, 2015 at 8:23:30 PM by Longinotto

Replying to dkocher:

#8858 closed as duplicate.

I made a video of the bug. Dont know if it helps debugging... ​https://vimeo.com/129618191

comment:15 Changed on Jun 9, 2015 at 8:05:07 PM by dkocher

#8871 closed as duplicate.

comment:16 Changed on Jun 18, 2015 at 11:14:30 AM by dkocher

#8884 closed as duplicate.

comment:17 Changed on Jun 25, 2015 at 3:37:04 PM by dkocher

  • Milestone changed from 4.8 to 4.7.1
  • Resolution set to fixed
  • Status changed from reopened to closed

Please update to the latest snapshot build available; r17840 or later.

Note: See TracTickets for help on using tickets.
swiss made software