Cyberduck Mountain Duck CLI

#8446 closed defect (fixed)

Layout issue in Open Connection sheet

Reported by: cmsklar Owned by: dkocher
Priority: normal Milestone: 4.6.2
Component: core Version: 4.6.1
Severity: major Keywords:
Cc: cmsklar@… Architecture: Intel
Platform: Mac OS X 10.10

Description

OS X 10.10.1, Standard user account

"Open Connection" window does not display properly, if it displays at all, when Terminal.app is open. Close Terminal.app and everything is OK.

Attachments (1)

CyberduckDisplay.pdf (154.5 KB) - added by cmsklar on Dec 29, 2014 at 8:38:10 PM.

Download all attachments as: .zip

Change History (11)

comment:1 follow-up: Changed on Dec 28, 2014 at 7:58:17 PM by dkocher

I can hardly believe that there is a problem with the layout in the Open Connection window is connected to the Terminal. Can you post a screenshot of the issue and let me know what your language setting is in System Preferences → Language and in Cyberduck → Preferences → Language.

comment:2 Changed on Dec 28, 2014 at 8:00:15 PM by dkocher

  • Summary changed from Conflict with Terminal.app to Layout issue in Open Connection sheet

comment:3 in reply to: ↑ 1 Changed on Dec 29, 2014 at 8:36:05 PM by cmsklar

Replying to dkocher:

I can hardly believe that there is a problem with the layout in the Open Connection window is connected to the Terminal. Can you post a screenshot of the issue and let me know what your language setting is in System Preferences → Language and in Cyberduck → Preferences → Language.

My MacBook Pro is set as follows: System Preferences → Language = English Cyberduck → Preferences → Language = English

After taking a close look at my issue I have to say you are correct. Terminal.app is not involved. This is totally a Cyberduck thing. I will attach a PDF of the four different displays that I get. Please let me know if my attachment does not reach you. If I launch Cyberduck and it behaves correctly the complete "Open Connection" window (OC) displays as represented on page 1 of my PDF. Then I quit Cyberduck and relaunch it again. The OC display is as represented on page 2 of my PDF. Quit Cyberduck, relaunch and the OC is as represented on page 3. Quit Cyberduck and relaunch and the OC doesn't appear to open at all; page 4. From all the testing I've done I know that once the OC does not display at all and I quit Cyberduck, the next time I launch Cyberduck, the OC will display correctly. This cycle is perfectly repeatable.

Changed on Dec 29, 2014 at 8:38:10 PM by cmsklar

comment:4 Changed on Dec 30, 2014 at 10:11:30 AM by dkocher

  • Owner set to dkocher
  • Status changed from new to assigned

comment:5 Changed on Dec 30, 2014 at 10:15:05 AM by dkocher

The issue applies to other windows as well that do no longer seem to have a minimum size set such as Preferences and Info. This was most possibly introduced with changeset r16002.

comment:6 Changed on Dec 30, 2014 at 11:08:28 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r16246.

comment:7 Changed on Jan 2, 2015 at 1:40:46 PM by dkocher

#8454 closed as duplicate.

comment:8 Changed on Jan 7, 2015 at 3:07:36 PM by dudepron

I can confirm this is in 4.6.1 (16121). I have updated to 16280 and the issue is fixed. I did not have any terminal windows open.

comment:9 Changed on Jan 19, 2015 at 11:10:20 AM by dkocher

#8503 closed as duplicate.

comment:10 Changed on Jan 19, 2015 at 11:10:30 AM by dkocher

#8502 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software