Cyberduck Mountain Duck CLI

#8447 closed defect (worksforme)

Exhausted available authentication methods

Reported by: aberna Owned by:
Priority: high Milestone: 4.6.2
Component: appstore Version: 4.6.1
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description (last modified by aberna)

I bought Cyberduck from Apple Store and some weeks ago it was running fine.

Now Cyberduck give the following messages when I access a server with my login name:

Login failed Exhausted available authentication methods. Please contact your web hosting service provider for assistance.

Note that if I access the same server with my login name using ssh from Apple Terminal there are no login problems. Note also that FileZilla (an equivalent of Cyberduck) works also fine but for some obscure reason I prefer Cyberduck!

If you have any suggestion please let me know.

Change History (7)

comment:1 Changed on Dec 28, 2014 at 3:27:45 PM by aberna

  • Description modified (diff)

comment:2 Changed on Dec 28, 2014 at 8:05:26 PM by dkocher

Please enable debug logging and post the output in the system.log (/Applications/Utilities/Console.app) after relaunching Cyberduck.

comment:3 Changed on Dec 28, 2014 at 8:06:12 PM by dkocher

Please post the output when connecting with ssh -v from Terminal.app.

comment:4 Changed on Dec 29, 2014 at 1:52:28 PM by aberna

After

defaults write ch.sudo.cyberduck logging debug

I obtained the enclosed output from /Applications/Utilities/Console.app , but this time I was able to login !!!???

29/12/14 10:56:18.512 sandboxd[133]: ([492]) Cyberduck(492) deny file-write-data /Applications/Cyberduck.app/Contents/_MASReceipt/receipt
29/12/14 10:56:19.043 sandboxd[133]: ([492]) Cyberduck(492) deny file-write-data /Applications/Cyberduck.app/Contents/_MASReceipt/receipt
29/12/14 10:56:19.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/Library/Application Support/Firefox/Profiles
29/12/14 10:56:19.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/Library/Application Support/Firefox/Profiles
29/12/14 10:56:19.000 kernel[0]: Sandbox: Cyberduck(492) deny file-write-create /Applications/Cyberduck.app/Contents/Resources/Bookmarks
29/12/14 10:56:19.000 kernel[0]: Sandbox: Cyberduck(492) deny file-write-create /Applications/Cyberduck.app/Contents/Resources/Bookmarks
29/12/14 10:56:19.143 Cyberduck[492]: [background-8] ERROR ch.cyberduck.ui.AbstractController - Unhandled exception running background task Access denied

java.lang.Exception
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.<init>(AbstractController.java:151)
	at ch.cyberduck.ui.AbstractController.background(AbstractController.java:110)
	at ch.cyberduck.ui.cocoa.MainController.applicationDidFinishLaunching(MainController.java:1167)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:170)
	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:470)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:500)
	at com.sun.jna.Native.invokeVoid(Native Method)
	at com.sun.jna.Function.invoke(Function.java:367)
	at com.sun.jna.Function.invoke(Function.java:315)
	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
	at com.sun.jna.Library$Handler.invoke(Library.java:210)
	at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source)
	at org.rococoa.Foundation.send(Foundation.java:208)
	at org.rococoa.Foundation.send(Foundation.java:194)
	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:269)
	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:232)
	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:191)
	at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:72)
Caused by: ch.cyberduck.core.exception.AccessDeniedException{detail='Create directory /Applications/Cyberduck.app/Contents/Resources/Bookmarks failed', cause='null', message='Access denied'}
	at ch.cyberduck.core.Local.mkdir(Local.java:179)
	at ch.cyberduck.core.AbstractFolderHostCollection.load(AbstractFolderHostCollection.java:118)
	at ch.cyberduck.ui.cocoa.MainController$19.run(MainController.java:1190)
	at ch.cyberduck.ui.cocoa.MainController$19.run(MainController.java:1167)
	at ch.cyberduck.core.threading.AbstractBackgroundAction.call(AbstractBackgroundAction.java:119)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:175)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:724)
29/12/14 10:56:19.275 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:56:19.400 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:56:19.408 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:56:19.414 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:56:19.419 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/Library/Preferences/com.fetchsoftworks.Fetch.Shortcuts.plist
29/12/14 10:56:19.423 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/Library/Preferences/com.fetchsoftworks.Fetch.Shortcuts.plist
29/12/14 10:57:50.695 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:50.838 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:51.096 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:51.110 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:51.291 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:51.309 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:54.322 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:54.335 sandboxd[133]: ([492]) Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:54.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:54.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:55.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:55.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:55.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:55.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:55.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:55.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:57.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:57.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:57.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:57.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:57.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:57:57.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:58:21.116 CalendarAgent[218]: [com.apple.calendar.store.log.caldav.coredav] [Refusing to parse response to PROPPATCH because of content-type: [text/html; charset=UTF-8].]
29/12/14 10:58:21.157 CalendarAgent[218]: [com.apple.calendar.store.log.caldav.coredav] [Refusing to parse response to PROPPATCH because of content-type: [text/html; charset=UTF-8].]
29/12/14 10:58:28.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/known_hosts
29/12/14 10:58:28.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/known_hosts
29/12/14 10:58:28.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/known_hosts
29/12/14 10:58:28.209 Cyberduck[492]: [main] ERROR ch.cyberduck.core.local.PanelSandboxBookmarkResolver - Error resolving bookmark for FinderLocal{bookmark=, path='/Users/andreabernasconidg/.ssh/known_hosts'} to URL Error Domain=NSCocoaErrorDomain Code=259 "The file couldn’t be opened because it isn’t in the correct format."
29/12/14 10:58:28.227 Cyberduck[492]: [main] ERROR ch.cyberduck.core.sftp.openssh.OpenSSHHostKeyVerifier - Cannot read known hosts file FinderLocal{bookmark=, path='/Users/andreabernasconidg/.ssh/known_hosts'}
29/12/14 10:58:29.000 kernel[0]: Sandbox: Cyberduck(492) deny network-outbound /private/tmp/com.apple.launchd.I9KtLqjJiV/Listeners
29/12/14 10:58:29.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:58:29.000 kernel[0]: Sandbox: Cyberduck(492) deny file-read-data /Users/andreabernasconidg/.ssh/config
29/12/14 10:58:31.319 WindowServer[120]: disable_update_timeout: UI updates were forcibly disabled by application "Cyberduck" for over 1.00 seconds. Server has re-enabled them.
29/12/14 10:58:32.007 WindowServer[120]: common_reenable_update: UI updates were finally reenabled by application "Cyberduck" after 1.69 seconds (server forcibly re-enabled them after 1.00 seconds)

Last edited on Dec 29, 2014 at 2:06:49 PM by dkocher (previous) (diff)

comment:5 Changed on Dec 29, 2014 at 2:12:09 PM by aberna

Output when connecting with ssh -v from Terminal.app

~ : ssh -v -Y USERNAME@SERVERNAME
OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /Users/andreUSERNAMEsconidg/.ssh/config
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: /etc/ssh_config line 53: Applying options for *
debug1: Connecting to SERVERNAME [148.187.1.7] port 22.
debug1: Connection established.
debug1: identity file /Users/andreUSERNAMEsconidg/.ssh/id_rsa type -1
debug1: identity file /Users/andreUSERNAMEsconidg/.ssh/id_rsa-cert type -1
debug1: identity file /Users/andreUSERNAMEsconidg/.ssh/id_dsa type -1
debug1: identity file /Users/andreUSERNAMEsconidg/.ssh/id_dsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.2
debug1: match: OpenSSH_6.2 pat OpenSSH*
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-sha1 none
debug1: kex: client->server aes128-ctr hmac-sha1 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<2048<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA 61:ac:1a:78:bb:1b:a8:02:5d:31:f6:7d:b8:0e:18:83
debug1: Host 'SERVERNAME' is known and matches the RSA host key.
debug1: Found key in /Users/andreUSERNAMEsconidg/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: publickey
debug1: Trying private key: /Users/andreUSERNAMEsconidg/.ssh/id_rsa
debug1: Trying private key: /Users/andreUSERNAMEsconidg/.ssh/id_dsa
debug1: Next authentication method: password
USERNAME@SERVERNAME's password: 
debug1: Authentication succeeded (password).
Authenticated to SERVERNAME ([148.187.1.7]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Requesting X11 forwarding with authentication spoofing.
debug1: Sending environment.
debug1: Sending env LC_CTYPE = UTF-8
Last login: Mon Dec 29 15:01:36 2014 from 77-57-64-153.dclient.hispeed.ch
/usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

=================================================================
      IMPORTANT REMINDER FOR USERS of CSCS facilities

    help@cscs.ch - +41 91 610 82 10 - http://user.cscs.ch
=================================================================

     CSCS next preventive maintenance is scheduled for:          

                     >>>  January 14, 2015 <<<

ela2 USERNAME ~ :-)

Last edited on Dec 29, 2014 at 2:20:32 PM by dkocher (previous) (diff)

comment:6 Changed on Dec 30, 2014 at 11:16:10 AM by dkocher

  • Milestone set to 4.6.2
  • Resolution set to worksforme
  • Status changed from new to closed

I suppose this issue is resolved if you can no longer reproduce.

comment:7 Changed on Jan 13, 2015 at 10:40:16 PM by dkocher

Possible duplicate of #8463.

Note: See TracTickets for help on using tickets.
swiss made software