Cyberduck Mountain Duck CLI

#8460 closed defect (duplicate)

Fails to stay connected to FTP-SSL site

Reported by: steve75228 Owned by: dkocher
Priority: high Milestone: 4.6.2
Component: ftp Version: 4.6.1
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description (last modified by dkocher)

I'm computer support for Southern Methodist University where we've adopted CyberDuck for our campus wide FTP client. Recently our Windows clients updated to the latest version and can no longer connect to our server using FTP - SSL Our Mac clients updated but do connect just fine.

I just downloaded version 4.6.1 (16121) for Windows 7 64bit Looking at the log drawer, I see that it connects with my username/password, shows 211 Extended features supported, shows 200 OPTS UTF8 command successful, then

Syst
215 Window_NT
Quit
221 Goodbye

No explanation why it would just quit.

We have an older version of Cyberduck that we've had to install on some people's computers to get them working again but wondering why this version is giving us problems.

Attachments (1)

cyberduck.log (18.9 KB) - added by steve75228 on Jan 5, 2015 at 10:22:13 PM.

Download all attachments as: .zip

Change History (14)

comment:1 Changed on Jan 5, 2015 at 9:48:46 PM by dkocher

  • Component changed from core to ftp
  • Description modified (diff)
  • Owner set to dkocher

comment:2 Changed on Jan 5, 2015 at 9:48:58 PM by dkocher

Please attach the file cyberduck.log in the application support directory.

Changed on Jan 5, 2015 at 10:22:13 PM by steve75228

comment:3 follow-ups: Changed on Jan 5, 2015 at 10:23:55 PM by steve75228

Thanks for responding so quickly. I've attached the log file as requested. Could it be related to the version of Java I'm running?

comment:4 in reply to: ↑ 3 Changed on Jan 5, 2015 at 10:40:38 PM by dkocher

Replying to steve75228:

Thanks for responding so quickly. I've attached the log file as requested. Could it be related to the version of Java I'm running?

No Java installation is required.

comment:5 in reply to: ↑ 3 Changed on Jan 5, 2015 at 10:41:49 PM by dkocher

Replying to steve75228:

Thanks for responding so quickly. I've attached the log file as requested. Could it be related to the version of Java I'm running?

Caused by: java.lang.NullPointerException
	at ch.cyberduck.core.Host.serialize(Host.java:279)
	at ch.cyberduck.ui.threading.BrowserBackgroundAction.connect(BrowserBackgroundAction.java:67)
	at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:166)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:175)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:167)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:604)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:937)

comment:6 Changed on Jan 5, 2015 at 10:42:04 PM by dkocher

Duplicate for #8437.

comment:7 Changed on Jan 5, 2015 at 10:44:07 PM by dkocher

  • Milestone set to 4.6.2
  • Resolution set to duplicate
  • Status changed from new to closed

comment:8 follow-up: Changed on Jan 5, 2015 at 10:50:28 PM by steve75228

Why was this closed as a duplicate? I didn't open #8437 and am still not sure what is causing the problem?

comment:9 in reply to: ↑ 8 Changed on Jan 6, 2015 at 9:38:49 AM by dkocher

Replying to steve75228:

Why was this closed as a duplicate? I didn't open #8437 and am still not sure what is causing the problem?

This means we are already tracking the same issue reported by someone else. We will close the referenced ticket when the bug has been identified and fixed.

comment:10 Changed on Jan 6, 2015 at 11:25:59 AM by dkocher

Fixed in r16263.

comment:11 Changed on Jan 6, 2015 at 11:35:29 AM by dkocher

Please update to the latest snapshot build available.

comment:12 follow-up: Changed on Jan 6, 2015 at 4:09:53 PM by steve75228

I installed Cyberduck-Installer-4.6.2.16264.exe and that seems to have fixed the bug. will this version be available to auto update from within the application?

comment:13 in reply to: ↑ 12 Changed on Jan 6, 2015 at 4:56:01 PM by dkocher

Replying to steve75228:

I installed Cyberduck-Installer-4.6.2.16264.exe and that seems to have fixed the bug. will this version be available to auto update from within the application?

Thanks for the confirmation that the fix works for you. You can update from within the application by choosing "Snapshot Builds" in the "Update" tab. It will be pushed to the "Release" channel later this month.

Note: See TracTickets for help on using tickets.
swiss made software