Cyberduck Mountain Duck CLI

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#8463 closed defect (fixed)

Updating password for server access fails

Reported by: richard marcucella Owned by:
Priority: high Milestone: 4.6.2
Component: core Version: 4.6.1
Severity: blocker Keywords:
Cc: Architecture:
Platform: Windows 7

Description

I tried connecting to an existing bookmark, and tried to update my password (it had recently changed), and any attempt to login to server with the new password fails. Also, the new password is not being saved in the keychain.

I had experienced this same issue on an earlier version of Cyberduck, but it was fixed in version 4.5.x I believe.

Change History (15)

comment:1 Changed 3 years ago by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed

comment:2 follow-up: Changed 3 years ago by richard marcucella

Why did you close this bug? please provide some comment on why you've closed it. Is is fixed, functions as designed? or what?

comment:3 in reply to: ↑ 2 Changed 3 years ago by dkocher

Replying to richard marcucella:

Why did you close this bug? please provide some comment on why you've closed it. Is is fixed, functions as designed? or what?

Please contact your hosting service provider to assist with resetting your credentials.

comment:4 Changed 3 years ago by richard marcucella

Maybe I was not clear in stating the problem. I can log into this server with my LDAP credentials either directly, or through other file transfer programs. Once my credentials had changed, I could not log in using Cyberduck only. Cyberduck is not properly sending my new credentials when I try to establish a session. It seems to be sending my old credentials even when I enter in my new password in the cyberduck initiated login screen.

I have successfully connected to the server using bitkinex and transferred files. But I cannot do this in Cyberduck now. This has happened before using cyberduck.

comment:5 Changed 3 years ago by dkocher

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

comment:6 Changed 3 years ago by dkocher

  • Milestone set to 4.6.2

comment:7 Changed 3 years ago by dkocher

#8484 closed as duplicate.

comment:8 Changed 3 years ago by dkocher

Regression from r15305.

comment:9 Changed 3 years ago by lrivas@…

I have/had the same problem. Could not wait for this issue to be resolved, so a workaround is to uninstall cyberduck, blow away all directories in users/roaming, reinstall cyberduck, the Oracle Cloud Storage profile from the wiki, and re-create the bookmark. This time when you go in for the first time, the password field will be empty, type in the new password and you will be able to connect. cheers.

comment:10 Changed 3 years ago by dkocher

In r16436.

comment:11 Changed 3 years ago by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:12 Changed 3 years ago by dkocher

#8486 closed as duplicate.

comment:13 Changed 3 years ago by dkocher

Test in r16467.

comment:14 Changed 3 years ago by yuan yuan

I don't think it is fixed. I have updated to the latest snapshot but still experience the same problem. If this cannot be fixed soon, how can I uninstall cyberduck completely so that I can start a clean reinstall? Thanks! Anxiously waiting for this to be fixed!

comment:15 Changed 3 years ago by yuan yuan

If you are using Mac, in addition to reinstalling cyberduck, also remember to remove the old credentials from keychain before you relaunch cyberduck. It solves the issue for me. Hope it helps.

Note: See TracTickets for help on using tickets.
swiss made software