Cyberduck Mountain Duck CLI

#8520 closed defect (fixed)

Invalid temporary signed URL for keys with delimiter

Reported by: aivaras.sukackas Owned by: dkocher
Priority: high Milestone: 4.6.4
Component: openstack Version: 4.6.3
Severity: normal Keywords:
Cc: aivaras.sukackas@… Architecture: Intel
Platform: Windows 8.1

Description (last modified by dkocher)

Hello,

i tried to generate tempurl under path "container/folder/file" from cyberduck (connected to openstack swift). When į opened it in browser it says "Unauthorized" when į generate it from swift-temp-url it works. There examples:

generated with cyberduck:

https://domain.com/v1/account/test_tmp/1ld_algoritmai%2FDebug%2F1ld_algoritmai.log?temp_url_sig=59e20676edb584750100cc5d3b40ec89115776c7&temp_url_expires=1422016325

generated with swift cli:

https://domain.com/v1/account/test_tmp/1ld_algoritmai/Debug/1ld_algoritmai.log?temp_url_sig=fbaa9a535d9eeaf8e9567d242689fb64261a995d&temp_url_expires=1422016411359

Change History (7)

comment:1 Changed on Jan 23, 2015 at 12:00:38 PM by dkocher

  • Description modified (diff)

comment:2 follow-up: Changed on Jan 23, 2015 at 2:29:08 PM by dkocher

  • Milestone set to 4.6.4
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the issue here. I must note that I don't see the URI path being escaped as in your example.

comment:3 in reply to: ↑ 2 Changed on Jan 23, 2015 at 2:32:43 PM by aivaras.sukackas

upload file into folder on bucket and from there try to copy signed url for file. it generates "%2F" insted of "/"

comment:4 Changed on Jan 23, 2015 at 2:33:21 PM by aivaras.sukackas

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:5 Changed on Jan 23, 2015 at 2:38:58 PM by dkocher

  • Status changed from reopened to new

comment:6 Changed on Jan 23, 2015 at 2:55:25 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Fix in r16567.

comment:7 Changed on Jan 23, 2015 at 2:55:54 PM by dkocher

  • Summary changed from Wrong url for tempurl to Invalid temporary signed URL for keys with delimiter
Note: See TracTickets for help on using tickets.
swiss made software