Cyberduck Mountain Duck CLI

#8531 closed defect (worksforme)

md5sum and file size for duck-4.6.4.16609.amd64.deb don't match between repo and apt-cache show output

Reported by: matt wodrich Owned by:
Priority: normal Milestone:
Component: cli Version: 4.6.4
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Trying to update duck with apt-get always fails at the moment, so I decided to look at what was going on:

$ md5sum duck-4.6.4.16609.amd64.deb 
b2c694201f1d9fb0038d078b02cae968  duck-4.6.4.16609.amd64.deb
$ ls -go duck-4.6.4.16609.amd64.deb 
-rw-rw-r-- 1 77845234 Jan 27 08:00 duck-4.6.4.16609.amd64.deb

$ apt-cache show duck
Package: duck
Version: 4.6.4.16609
License: GPL
Vendor: none
Architecture: amd64
Maintainer: cyberduck.io <feedback@cyberduck.io>
Installed-Size: 185874
Provides: duck
Section: 
Priority: optional
Homepage: https://cyberduck.io
Filename: pool/d/du/duck-4.6.4.16609.amd64.deb
Size: 77845326
SHA1: c660bf4654f93488ab2cb4a07a2e49621a42ef3c
SHA256: 79db9beb112b94a484f5add529f3ea22e572ddb88477039c729552966f14330f
MD5sum: f14ac19b962c9938ce9e95e472a83d9d
Description: Cyberduck
Description-md5: 929c0fcef62426b5e3fdaea0626d6534

I couldn't see a published md5sum for the deb file other than the one in the apt-cache show output, so I'm not actually sure if the deb I've downloaded is intact. I also downloaded the deb from the manual download page (https://dist.duck.sh/duck-4.6.4.16609.amd64.deb), and its size and md5sum match that of the one I downloaded directly from the apt source (https://s3.amazonaws.com/repo.deb.cyberduck.io/pool/d/du/duck-4.6.4.16609.amd64.deb).

Change History (8)

comment:1 Changed on Feb 2, 2015 at 10:22:12 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the issue with the current snapshot build 4.7.16656.amd64.deb. Can you please try to to update your index with apt-get update.

comment:2 Changed on Feb 2, 2015 at 10:22:19 AM by dkocher

  • Component changed from core to cli

comment:3 Changed on Feb 2, 2015 at 10:52:06 AM by matt wodrich

Tried updating my index to no avail. apt-cache show duck output is unchanged, and as such, apt-get install duck is still trying to download the old package. Has the "deb https://s3.amazonaws.com/repo.deb.cyberduck.io stable main" source (added per the instructions at duck.sh) been updated to a snapshot build? I wonder if it's gotten out of date, but having the snapshot source available masks that for you?

comment:4 Changed on Feb 2, 2015 at 10:54:51 AM by matt wodrich

I'm not currently using "deb https://s3.amazonaws.com/repo.deb.cyberduck.io nightly main", the alternate source mentioned at https://trac.cyberduck.io/wiki/help/en/howto/cli#DEBPackageRepository

Do you recommend using it?

comment:5 Changed on Feb 2, 2015 at 11:09:06 AM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:6 Changed on Feb 2, 2015 at 8:11:03 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

We couldn't determine why the meta information for build 16609 was broken. We have now updated the stable source to build 4.7.16658 and verified checksums are fine.

comment:7 follow-up: Changed on Feb 3, 2015 at 12:30:43 AM by matt wodrich

Thank you very much, I was able to update successfully to that version, though, it seemed to take a great deal of time to start the download of the deb, not sure if that's a known issue or deserves a ticket of its own.

comment:8 in reply to: ↑ 7 Changed on Feb 3, 2015 at 2:55:25 PM by dkocher

Replying to matt wodrich:

Thank you very much, I was able to update successfully to that version, though, it seemed to take a great deal of time to start the download of the deb, not sure if that's a known issue or deserves a ticket of its own.

I have seen this as well but couldn't find an issue with our repository.

Note: See TracTickets for help on using tickets.
swiss made software