Cyberduck Mountain Duck CLI

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8532 closed defect (fixed)

Connection attempt should be repeated when server is closing remote connection

Reported by: doughemi Owned by:
Priority: high Milestone: 4.7
Component: ftp Version: 4.6.4
Severity: major Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

version 4.6.4 (16610) OS X 10.10.2 Editor: Komodo Edit version 8.5.4, build 14424. After editing a file, the file is not uploaded to the host when it is saved. This occurs intermittently. When it happens, the upload icon in the upper right of the window does not change to a stop sign logo. This appears to be a problem in this version. I have never had the problem until just recently (the last two weeks or so).

log drawer:

STAT /public_html/theamya.org/regatta/olr
421 No transfer timeout (300 seconds): closing control connection
220 ProFTPD 1.3.2b Server (Southwest Cyberport FTP) [216.184.2.162]
USER usvmyg
331 Password required for usvmyg
PASS ********
230 User usvmyg logged in
FEAT
211-Features:
 LANG bg-BG;en-US*;zh-CN;fr-FR;it-IT;ko-KR;ru-RU
 MDTM
 MFMT
 UTF8
 AUTH TLS
 MFF modify;UNIX.group;UNIX.mode;
 MLST modify*;perm*;size*;type*;unique*;UNIX.group*;UNIX.mode*;UNIX.owner*;
 PBSZ
 PROT
 REST STREAM
 SIZE
211 End
SYST
215 UNIX Type: L8

Change History (10)

comment:1 Changed 4 years ago by dkocher

  • Description modified (diff)

comment:2 Changed 4 years ago by dkocher

  • Summary changed from Intermittent can't save edited file to Intermittent no upload on save

comment:3 Changed 4 years ago by dkocher

  • Milestone set to 4.7
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue. Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:4 Changed 4 years ago by doughemi

When it fails, nothing appears in the Cyberduck log drawer, but the following appears in the system.log:

2/9/15 8:35:00.336 PM Cyberduck[18406]: [main] ERROR ch.cyberduck.core.Cache - Lookup failed for NSObjectPathReference{reference=[file]-/public_html/theamya.org/regatta/olr/PayWithOptions.php, hashcode=968997113} in cache

The only way I have found to work around the problem is to copy the text of the file, close it in the editor, and download it again from the server. Upon pasting the clipboard into the new editor tab, I can save the file and it uploads properly.

Version 1, edited 4 years ago by doughemi (previous) (next) (diff)

comment:5 follow-up: Changed 4 years ago by doughemi

New information:

Log drawer shows

421 Idle timeout (600 seconds): closing control connection

Is this a setting in Cyberduck, or is it a setting in the host?

Last edited 4 years ago by dkocher (previous) (diff)

comment:6 in reply to: ↑ 5 Changed 4 years ago by dkocher

Replying to doughemi:

New information:

Log drawer shows "421 Idle timeout (600 seconds): closing control connection". Is this a setting in Cyberduck, or is it a setting in the host?

This is a setting on the server that it closes the connection after a timeout.

comment:7 Changed 4 years ago by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:8 Changed 4 years ago by doughemi

Thanks for the quick response.

When I am editing a file, I often pass the idle timeout limit before trying to save. Thus, my changes are not saved on the server. The editor program, Komodo Edit, does save to its temp file, but I cannot find a way to get to that file to send it to the server. Is there a way in Cyberduck to automatically access the host so that the timeout doesn't occur?

comment:9 Changed 4 years ago by dkocher

  • Component changed from core to ftp
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Summary changed from Intermittent no upload on save to Connection attempt should be repeated when server is closing remote connection

In r17160.

comment:10 Changed 4 years ago by dkocher

#8740 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software