Cyberduck Mountain Duck CLI

#8539 closed defect (fixed)

No longer appears to support alternate connection profiles

Reported by: matt wodrich Owned by: dkocher
Priority: high Milestone: 4.7
Component: cli Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Before upgrade to 4.7.16658, I saw the rackspace connection profile in duck --help as a protocol, and the dreamhost connection profile I had added in the same directory as well; after the upgrade, neither is present. I hoped there had just been a change in help text generation, so I tried the protocol, and it was unrecognized. Is there a mechanism for re-registering connection profiles, or has the support been removed or broken between versions? I have verified that both files are still there. I was previously running version 4.6.2.16478.

command to verify connection profile presence:

$ ls /opt/duck/app/profiles/
DreamObjects.cyberduckprofile  Rackspace US.cyberduckprofile

Pre-upgrade connection protocols:

	URLs must be fully qualified. Paths can either denote a remote file (ftps://user@example.net/resource) or folder ftps://user@example.net/directory/) with a trailing slash.
Supported protocols
ftp	FTP (File Transfer Protocol)
	ftp://<hostname>/<folder>/<file>
ftps	FTP-SSL (Explicit AUTH TLS)
	ftps://<hostname>/<folder>/<file>
sftp	SFTP (SSH File Transfer Protocol)
	sftp://<hostname>/<folder>/<file>
dav	WebDAV (Web-based Distributed Authoring and Versioning)
	dav://<hostname>/<folder>/<file>
davs	WebDAV (HTTP/SSL)
	davs://<hostname>/<folder>/<file>
swift	Swift (OpenStack Object Storage)
	swift://<container>/<key>
s3	S3 (Amazon Simple Storage Service)
	s3://<container>/<key>
gs	Google Cloud Storage
	gs://<container>/<key>
azure	Windows Azure Storage
	azure://<container>/<key>
rackspace	Rackspace Cloud Files (US)
	rackspace://<container>/<key>
dreamhost	DreamObjects Cloud Storage (S3)
	dreamhost://<container>/<key>

Post-upgrade connection protocols:

	URLs must be fully qualified. Paths can either denote a remote file (ftps://user@example.net/resource) or folder ftps://user@example.net/directory/) with a trailing slash.
Supported protocols
ftp	FTP (File Transfer Protocol)
	ftp://<hostname>/<folder>/<file>
ftps	FTP-SSL (Explicit AUTH TLS)
	ftps://<hostname>/<folder>/<file>
sftp	SFTP (SSH File Transfer Protocol)
	sftp://<hostname>/<folder>/<file>
dav	WebDAV (Web-based Distributed Authoring and Versioning)
	dav://<hostname>/<folder>/<file>
davs	WebDAV (HTTP/SSL)
	davs://<hostname>/<folder>/<file>
swift	Swift (OpenStack Object Storage)
	swift://<container>/<key>
s3	S3 (Amazon Simple Storage Service)
	s3://<container>/<key>
gs	Google Cloud Storage
	gs://<container>/<key>
azure	Windows Azure Storage
	azure://<container>/<key>

Change History (12)

comment:1 Changed on Feb 3, 2015 at 10:04:29 AM by dkocher

  • Milestone set to 4.7
  • Owner set to dkocher
  • Priority changed from normal to high
  • Status changed from new to assigned

comment:2 Changed on Feb 3, 2015 at 10:25:59 AM by dkocher

Additional path for profiles is ~/.duck/profiles/.

comment:3 Changed on Feb 3, 2015 at 10:28:15 AM by dkocher

Broken for case sensitive file systems with changeset r16497.

comment:4 Changed on Feb 3, 2015 at 10:36:10 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r16670.

comment:5 Changed on Feb 26, 2015 at 11:52:13 PM by matt wodrich

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 follow-up: Changed on Feb 26, 2015 at 11:52:43 PM by matt wodrich

This appears to be a problem again as of r17009.

comment:7 Changed on Feb 27, 2015 at 8:21:48 AM by dkocher

  • Summary changed from duck cli no longer appears to support alternate connection profiles after upgrade to 4.7.16658 on stable to No longer appears to support alternate connection profiles

comment:8 in reply to: ↑ 6 Changed on Feb 27, 2015 at 2:45:54 PM by dkocher

Replying to matt wodrich:

This appears to be a problem again as of r17009.

The issue is not related to this changeset.

comment:9 follow-up: Changed on Feb 27, 2015 at 8:06:29 PM by matt wodrich

Sorry, I should have said I upgraded to 4.7.17009 and found that it was the case again, not that it was specifically that changeset. I'm not sure what intermediate changeset might have caused it, just that that's the version I'm running at the moment.

comment:10 in reply to: ↑ 9 Changed on Feb 27, 2015 at 8:20:44 PM by dkocher

Replying to matt wodrich:

Sorry, I should have said I upgraded to 4.7.17009 and found that it was the case again, not that it was specifically that changeset. I'm not sure what intermediate changeset might have caused it, just that that's the version I'm running at the moment.

I can confirm it no longer works loading profiles from ~/.duck/profiles. We have yet to find the regression.

I can confirm it no longer works loading profiles from /opt/duck/app/profiles. We have yet to find the regression.

Last edited on Feb 27, 2015 at 9:45:46 PM by dkocher (previous) (diff)

comment:11 Changed on Feb 27, 2015 at 9:54:18 PM by dkocher

Regression in r16803.

comment:12 Changed on Feb 27, 2015 at 9:56:24 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r17049.

Note: See TracTickets for help on using tickets.
swiss made software