Cyberduck Mountain Duck CLI

#8546 closed defect (fixed)

Upload button greyed out

Reported by: crc123 Owned by:
Priority: normal Milestone: 6.4.6
Component: cloudfiles Version: 4.6.4
Severity: normal Keywords: upload bug
Cc: crc123@… Architecture:
Platform: Windows 7

Description

The upload button is greyed out in 4.6.4. An earlier version of Cyberduck on another computer works fine (4.4.3)

Attachments (2)

screenshot_greyed_out.png (125.2 KB) - added by ul. chłodna on Feb 13, 2015 at 10:55:57 AM.
screenshot of issue
cyberduck.log (847.4 KB) - added by ul. chłodna on Feb 13, 2015 at 10:57:49 AM.
logfile

Download all attachments as: .zip

Change History (26)

comment:1 Changed on Feb 4, 2015 at 5:05:58 PM by crc123

The button briefly displays as functional before rackspace login is attempted. The problem is evident on two separate computers running 4.6.4

comment:2 Changed on Feb 4, 2015 at 5:18:36 PM by crc123

I have downloaded 4.4.3 from oldapps and it works fine on both machines which are failing with 4.6.4

comment:3 Changed on Feb 4, 2015 at 6:20:53 PM by dkocher

Please post a screenshot that shows the issue.

comment:4 Changed on Feb 4, 2015 at 6:21:10 PM by dkocher

Please attach the file cyberduck.log in the application support directory.

comment:5 Changed on Feb 4, 2015 at 7:01:27 PM by crc123

Unfortunately I cannot do either - I have removed 4.6.4 and replaced it with the earlier version which works well. I found the earlier version superior in terms of uploading functionality also, significantly faster.

comment:6 follow-up: Changed on Feb 5, 2015 at 9:55:55 PM by chaoix

I am also having issues with Rackspace on 4.6.4 on Windows. I can not save a Rackspace bookmark.

comment:7 in reply to: ↑ 6 Changed on Feb 10, 2015 at 1:57:43 PM by dkocher

Replying to chaoix:

I am also having issues with Rackspace on 4.6.4 on Windows. I can not save a Rackspace bookmark.

Presumably a duplicate for #8563.

comment:8 Changed on Feb 10, 2015 at 1:57:53 PM by dkocher

  • Milestone set to 4.6.5
  • Resolution set to worksforme
  • Status changed from new to closed

comment:9 Changed on Feb 12, 2015 at 11:38:27 PM by ul. chłodna

  • Platform set to Windows 7

I had exactly the same experience on Windows 7.

Connecting to Rackspace, the upload button was greyed out in 4.6.4 I tried 4.6.3 - same issue. Then 4.5.2 - same issue.

So I installed 4.4.3 and now it uploads fine. It would be a bit of a pain to upgrade to 4.6.4, upload the cyberduck.log and then downgrade back to 4.4.3 but I will if someone promises to look at it!

comment:10 Changed on Feb 13, 2015 at 8:45:54 AM by dkocher

  • Component changed from core to cloudfiles
  • Summary changed from Cannot upload to Rackspace from 4.6.4 to Upload button greyed out

comment:11 Changed on Feb 13, 2015 at 8:46:37 AM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

This is possibly because you have selected the container you want to upload a file to. Please selected a file inside the container to make the upload button active as a workaround.

comment:12 Changed on Feb 13, 2015 at 8:57:13 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r16782.

comment:13 follow-up: Changed on Feb 13, 2015 at 9:17:56 AM by crc123

This resolution did not work for me - selecting a file inside the container did not restore the button. It is also counterintuitive. Selecting the container surely makes more sense in design terms.

comment:14 in reply to: ↑ 13 Changed on Feb 13, 2015 at 9:22:39 AM by dkocher

Replying to crc123:

This resolution did not work for me - selecting a file inside the container did not restore the button. It is also counterintuitive. Selecting the container surely makes more sense in design terms.

We changed this behaviour in r16782.

comment:15 Changed on Feb 13, 2015 at 9:56:37 AM by crc123

Selecting a file inside the container did not work for me anyway.

comment:16 Changed on Feb 13, 2015 at 10:28:42 AM by dkocher

Please update to the latest snapshot build available.

comment:17 Changed on Feb 13, 2015 at 10:35:40 AM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:18 Changed on Feb 13, 2015 at 10:38:29 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r16784.

Changed on Feb 13, 2015 at 10:55:57 AM by ul. chłodna

screenshot of issue

Changed on Feb 13, 2015 at 10:57:49 AM by ul. chłodna

logfile

comment:19 Changed on Feb 13, 2015 at 11:00:02 AM by ul. chłodna

  • Resolution fixed deleted
  • Status changed from closed to reopened

I updated to r16783 and the problem persists. A screenshot and the logfile can be found attached.

Last edited on Dec 19, 2018 at 1:47:40 PM by dkocher (previous) (diff)

comment:20 Changed on Feb 13, 2015 at 11:22:45 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Please make sure to update to r16784.

comment:21 Changed on Feb 13, 2015 at 11:31:00 AM by ul. chłodna

Where can I download a build r16784?

When I set auto-update to check for Beta or Snapshots, it offers to download r16785. I don't see a build of r16784 at your link or at https://update.cyberduck.io/windows/nightly/

comment:22 Changed on Feb 13, 2015 at 1:39:43 PM by ul. chłodna

OK, it's no longer greyed out in r16785. Thank you!

comment:23 Changed on Apr 3, 2018 at 10:33:20 AM by dkocher

  • Milestone changed from 4.6.5 to 6.4.5

Revert in r44054.

comment:24 Changed on Apr 5, 2018 at 7:02:39 PM by dkocher

  • Milestone changed from 6.4.5 to 6.4.6

Milestone renamed

Note: See TracTickets for help on using tickets.