Cyberduck Mountain Duck CLI

#8548 closed enhancement (fixed)

Support new OpenSSH key format

Reported by: DrWhoZee Owned by: dkocher
Priority: low Milestone: 5.2.2
Component: sftp Version: 4.7.3
Severity: normal Keywords: openssh, key format
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

More recent OpenSSH version are using a new OpenSSH key format (see http://www.tedunangst.com/flak/post/new-openssh-key-format-and-bcrypt-pbkdf) - Cyberduck currently does not understand that version and comes back with

Exhausted available authentication methods. Unrecognised object: OPENSSH PRIVATE KEY.

Change History (10)

comment:1 Changed on Feb 6, 2015 at 9:29:55 AM by lbort

Hi DrWhoZee,

I didn't see your ticket before I opened #8553. Your link talks about ecdsa and ed25519 keys. According to https://stribika.github.io/2015/01/04/secure-secure-shell.html, only the latter is really secure. In case you want support for ed25519 keys, my ticket is a duplicate of yours. If you want ecdsa, you might want to change your mind about that ;-)

comment:2 Changed on Feb 6, 2015 at 10:44:46 AM by DrWhoZee

No, this is not about ecdsa, this ticket is about the new OpenSSH private key format - the link just serves as the reference to the new format.

Last edited on Feb 6, 2015 at 10:45:39 AM by DrWhoZee (previous) (diff)

comment:3 Changed on Jan 19, 2016 at 3:19:40 PM by dkocher

  • Priority changed from normal to low
  • Version changed from Nightly Build to 4.7.3

comment:4 Changed on Apr 1, 2016 at 4:00:45 PM by theirix

Support for ed25519 keys (#8553) must require this issue because newly generated ed25519 keys are only in new OpenSSH format.

I receive

Login failed. Exhausted available authentication methods. Unrecognised object: OPENSSH PRIVATE KEY. Please contact your web hosting service provider for assistance.

error in nighly duck cli or OS X Version 4.8.4 (19355)

comment:5 Changed on Apr 12, 2016 at 8:26:47 AM by dkocher

#9440 closed as duplicate.

comment:6 Changed on Oct 17, 2016 at 7:48:26 AM by dkocher

  • Milestone set to 6.0
  • Status changed from new to assigned

comment:7 Changed on Oct 19, 2016 at 2:17:19 PM by dkocher

  • Milestone changed from 6.0 to 5.2

Milestone renamed

comment:8 Changed on Oct 19, 2016 at 6:51:44 PM by dkocher

  • Milestone changed from 5.2 to 6.0

Ticket retargeted after milestone closed

comment:9 Changed on Oct 28, 2016 at 1:29:12 PM by dkocher

  • Milestone changed from 6.0 to 5.2.2

comment:10 Changed on Oct 29, 2016 at 11:20:14 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r21849.

Note: See TracTickets for help on using tickets.
swiss made software