Cyberduck Mountain Duck CLI

#8563 closed defect (fixed)

Bookmark not displayed if custom nickname is set

Reported by: dincsi Owned by:
Priority: normal Milestone: 4.6.5
Component: core Version: 4.6.4
Severity: normal Keywords: bookmark nickname
Cc: Architecture: Intel
Platform: Windows 8.1

Description (last modified by dkocher)

Steps to reproduce:

  • Create new bookmark
  • Exit Cyberduck
  • Run Cyberduck

Now you can see the bookmark

  • Add nickname in the UI
  • Quit Cyberduck
  • Run Cyberduck

Bookmark disapears

  • Quit Cyberduck
  • Edit bookmark file and delete Nickname
  • Run Cyberduck

Bookmark appears again.

Attachments (3)

cyberduck_1.log (776.9 KB) - added by dincsi on Feb 9, 2015 at 9:37:19 AM.
635589987698476615.txt (4.0 KB) - added by dincsi on Feb 9, 2015 at 9:40:30 AM.
Crash report
635589972045535355.txt (4.0 KB) - added by dincsi on Feb 9, 2015 at 9:41:07 AM.
Crash report

Download all attachments as: .zip

Change History (9)

comment:1 Changed on Feb 8, 2015 at 8:17:22 PM by dkocher

  • Description modified (diff)
  • Milestone set to 4.7
  • Summary changed from If Nickname exists in bookmark prefs file bookmark disapeaear from the list to Bookmark not displayed if custom nickname is set

comment:2 Changed on Feb 8, 2015 at 8:17:49 PM by dkocher

Please let me know what nickname you have chosen and attach the file cyberduck.log in the application support directory.

Changed on Feb 9, 2015 at 9:37:19 AM by dincsi

Changed on Feb 9, 2015 at 9:40:30 AM by dincsi

Crash report

Changed on Feb 9, 2015 at 9:41:07 AM by dincsi

Crash report

comment:3 Changed on Feb 9, 2015 at 9:44:47 AM by dincsi

I have added the log and two crash report file. I tried to reproduce it with a clean log file but I was not able, so I think this should be and upgrade problem. Hope the old log helps you to find out what the problem is.

comment:4 Changed on Feb 9, 2015 at 3:08:52 PM by dkocher

com.sun.org.apache.xerces.internal.impl.io.MalformedByteSequenceException: Invalid byte 1 of 1-byte UTF-8 sequence.
	at com.sun.org.apache.xerces.internal.impl.io.UTF8Reader.invalidByte(UTF8Reader.java:687)
	at com.sun.org.apache.xerces.internal.impl.io.UTF8Reader.read(UTF8Reader.java:557)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.load(XMLEntityScanner.java:1753)
	at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.skipChar(XMLEntityScanner.java:1426)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2754)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:607)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:489)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:835)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:125)
	at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:237)
	at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:301)
	at javax.xml.parsers.DocumentBuilder.parse(DocumentBuilder.java:121)
	at com.dd.plist.XMLPropertyListParser.parse(XMLPropertyListParser.java:129)
	at ch.cyberduck.core.serializer.impl.dd.PlistReader.parse(PlistReader.java:85)
	at ch.cyberduck.core.serializer.impl.dd.PlistReader.read(PlistReader.java:75)
	at ch.cyberduck.core.AbstractFolderHostCollection.load(AbstractFolderHostCollection.java:128)
	at cli.Ch.Cyberduck.Ui.Controller.MainController.<ApplicationDidFinishLaunching>b__b(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.AsyncDelegateBackgroundAction.run(Unknown Source)
	at ch.cyberduck.core.threading.AbstractBackgroundAction.call(AbstractBackgroundAction.java:119)
	at ch.cyberduck.core.AbstractController$BackgroundCallable.call(AbstractController.java:174)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:167)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:604)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:937)

comment:5 Changed on Feb 10, 2015 at 10:25:58 AM by yla

  • Resolution set to fixed
  • Status changed from new to closed

In r16741.

comment:6 Changed on Feb 10, 2015 at 1:11:06 PM by dkocher

  • Milestone changed from 4.7 to 4.6.5
Note: See TracTickets for help on using tickets.