Cyberduck Mountain Duck CLI

#8620 closed defect (worksforme)

Drag and drop broken

Reported by: mikedw Owned by:
Priority: normal Milestone: 4.7
Component: core Version: 4.6.5
Severity: normal Keywords: drag and drop
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

I tried to drag files from my desktop onto a file window of a local SFTP server, but when I did so Cyberduck hangs and I have to force-quit it. I just reinstalled an earlier version (4.6.3) and everything works fine with that older one.

I can login to the SFTP server just fine. The only problem I can see is that drag and drop doesn't work any more.

I hope this feedback helps. Thanks for the great application!

Mike Macbook Pro, OSX 10.10.2

Attachments (2)

Cyberduck_2015-03-01-102435_macbook-pro.hang (613.7 KB) - added by mikedw on Mar 2, 2015 at 9:28:02 AM.
from /Library/Logs/DiagnosticReports/Cyberduck_2015-03-01-114819_macbook-pro.hang
Cyberduck_2015-03-02-135825_macbook-pro.hang (607.6 KB) - added by mikedw on Mar 2, 2015 at 1:03:53 PM.
Second diagnostic report

Download all attachments as: .zip

Change History (7)

comment:1 Changed on Mar 2, 2015 at 8:19:25 AM by dkocher

  • Summary changed from Cyberduck 4.6.5 -- drag and drop broken? to Drag and drop broken

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

Changed on Mar 2, 2015 at 9:28:02 AM by mikedw

from /Library/Logs/DiagnosticReports/Cyberduck_2015-03-01-114819_macbook-pro.hang

comment:2 Changed on Mar 2, 2015 at 9:29:14 AM by mikedw

Here are the relevant lines from the system.log. Also the last line indicates that a hang report was saved in my computer. I have attached that to this ticket, too:

1/03/2015 11:46:10.074 AM com.github.norio-nomura.SIMBL-Agent[371]: warning: failed to get scripting definition from /Applications/ Internet/FTP/Cyberduck.app; it may not be scriptable.
1/03/2015 11:46:14.332 AM Cyberduck[505]: Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:
	/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
1/03/2015 11:46:15.054 AM Cyberduck[505]: Error loading /Users/mdwilliams/Library/ScriptingAdditions/24U Appearance OSAX.osax/Contents/MacOS/24U Appearance OSAX:  dlopen(/Users/mdwilliams/Library/ScriptingAdditions/24U Appearance OSAX.osax/Contents/MacOS/24U Appearance OSAX, 262): no suitable image found.  Did find:
	/Users/mdwilliams/Library/ScriptingAdditions/24U Appearance OSAX.osax/Contents/MacOS/24U Appearance OSAX: mach-o, but wrong architecture
1/03/2015 11:47:19.611 AM com.apple.xpc.launchd[1]: (ch.sudo.cyberduck.50584[505]) Service exited due to signal: Terminated: 15
1/03/2015 11:47:35.146 AM com.github.norio-nomura.SIMBL-Agent[371]: warning: failed to get scripting definition from /Applications/ Internet/FTP/Cyberduck.app; it may not be scriptable.
1/03/2015 11:47:38.619 AM Cyberduck[522]: Error loading /Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: dlopen(/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types, 262): no suitable image found.  Did find:
	/Library/ScriptingAdditions/Adobe Unit Types.osax/Contents/MacOS/Adobe Unit Types: no matching architecture in universal wrapper
1/03/2015 11:47:38.685 AM Cyberduck[522]: Error loading /Users/mdwilliams/Library/ScriptingAdditions/24U Appearance OSAX.osax/Contents/MacOS/24U Appearance OSAX:  dlopen(/Users/mdwilliams/Library/ScriptingAdditions/24U Appearance OSAX.osax/Contents/MacOS/24U Appearance OSAX, 262): no suitable image found.  Did find:
	/Users/mdwilliams/Library/ScriptingAdditions/24U Appearance OSAX.osax/Contents/MacOS/24U Appearance OSAX: mach-o, but wrong architecture
1/03/2015 11:48:19.885 AM spindump[513]: Saved hang report for Cyberduck version 4.6.5 (17000) to /Library/Logs/DiagnosticReports/Cyberduck_2015-03-01-114819_macbook-pro.hang

Hope this helps!

Mike

Last edited on Mar 2, 2015 at 10:28:46 AM by dkocher (previous) (diff)

comment:3 Changed on Mar 2, 2015 at 10:31:47 AM by dkocher

Can you uninstall com.github.norio-nomura.SIMBL-Agent and ~/Library/ScriptingAdditions/24U Appearance OSAX.osax to make sure we have no interoperability issue here.

Changed on Mar 2, 2015 at 1:03:53 PM by mikedw

Second diagnostic report

comment:4 Changed on Mar 2, 2015 at 1:07:13 PM by mikedw

I removed the files you mentioned and rebooted. Still the same problem, though. I've attached the new DiagnosticReport, and here is the latest system.log report:

2/03/2015 1:57:58.755 PM CoreServicesUIAgent[414]: unexpected message <OS_xpc_error: <error: 0x7fff7d99ac60> { count = 1, contents =

"XPCErrorDescription" => <string: 0x7fff7d99af70> { length = 18, contents = "Connection invalid" }

}> 2/03/2015 1:57:58.835 PM com.apple.xpc.launchd[1]: (ch.sudo.cyberduck.50584[455]) Service exited due to signal: Terminated: 15 2/03/2015 1:58:22.722 PM Console[467]: Failed to connect (_consoleX) outlet from (NSApplication) to (ConsoleX): missing setter or instance variable 2/03/2015 1:58:22.823 PM Console[467]: Error loading /Users/mdwilliams/Library/ColorPickers/paintersPicker.colorPicker/Contents/MacOS/paintersPicker: dlopen(/Users/mdwilliams/Library/ColorPickers/paintersPicker.colorPicker/Contents/MacOS/paintersPicker, 265): no suitable image found. Did find:

/Users/mdwilliams/Library/ColorPickers/paintersPicker.colorPicker/Contents/MacOS/paintersPicker: no matching architecture in universal wrapper

2/03/2015 1:58:25.149 PM spindump[452]: Saved hang report for Cyberduck version 4.6.5 (17000) to /Library/Logs/DiagnosticReports/Cyberduck_2015-03-02-135825_macbook-pro.hang

I notice that this time it says something about a "colorPicker". That's odd, because I was not using any other application at the time, except Cyberduck which I launched immediately after a reboot.

Good luck!

comment:5 Changed on Mar 4, 2015 at 4:01:45 PM by dkocher

  • Milestone set to 4.7
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue. Can you try if you also have this issue when using the Guest account on your computer.

Note: See TracTickets for help on using tickets.
swiss made software