Cyberduck Mountain Duck CLI

#8634 closed defect (fixed)

Connection lost regularly

Reported by: stefan jacobi Owned by: dkocher
Priority: normal Milestone: 4.7
Component: openstack Version: 4.6.5
Severity: normal Keywords: openstack swift connection
Cc: Architecture:
Platform:

Description

Since I updated to 4.6.5 (17000), I have huge problems with the connection via Swift Openstack. The connection is lost after nearly every step (change folder, up/download files, etc.). The initial connection need several tries until it's opened. Rolled back to 4.6.4 16110 - no problems there. Connecting via HTTP proxy (but also happening without proxy, direct network access to the storage).

I guess it has something to do with the new multiple transfers.

Change History (15)

comment:1 Changed on Mar 4, 2015 at 10:33:06 AM by dkocher

  • Component changed from core to openstack
  • Milestone set to 4.7
  • Owner set to dkocher
  • Summary changed from Swift Openstack: Since 4.7 connection lost regularly to Connection lost regularly

comment:2 Changed on Mar 4, 2015 at 2:43:03 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Please try r17124 or later.

Last edited on Mar 4, 2015 at 3:09:51 PM by dkocher (previous) (diff)

comment:3 Changed on Mar 4, 2015 at 7:07:40 PM by dkocher

#8635 closed as duplicate.

comment:4 Changed on Mar 5, 2015 at 1:57:43 PM by dkocher

#8637 closed as duplicate.

comment:5 Changed on Mar 5, 2015 at 8:17:39 PM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopen for #8635#comment:2.

comment:6 Changed on Mar 21, 2015 at 8:21:35 AM by dkocher

Other potential fix in r17154. From the Http Components release notes

Non-blocking connection should not trigger end-of-stream callback as long as there is still data in the session input buffer. This can cause a series of short pipelined requests to fail prematurely in case of an unexpected connection termination by the opposite endpoint.

comment:7 Changed on Mar 31, 2015 at 8:33:44 AM by dkocher

#8651 closed as duplicate.

comment:8 Changed on Mar 31, 2015 at 2:14:21 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Please try r17201 or later.

comment:9 Changed on Apr 1, 2015 at 5:57:08 PM by dkocher

This issue was caused by a bug in the HTTP library.

[HTTPCLIENT-1609] Stale connection check in PoolingHttpClientConnectionManager has no effect. Internal connection pool does not correctly implement connection validation.

comment:10 Changed on Apr 1, 2015 at 6:01:07 PM by dkocher

Reverted in r17224.

comment:11 Changed on Apr 1, 2015 at 6:01:49 PM by dkocher

Updated library dependency with fix in r17222.

comment:12 Changed on Apr 20, 2015 at 1:13:21 PM by dkocher

Please update to the latest snapshot build available.

comment:13 follow-up: Changed on Apr 20, 2015 at 2:26:23 PM by stefan jacobi

The file list still won't update after uploading a file, only restarting build 17342 helps with that. Also after deleting or moving a file.

Last edited on Apr 20, 2015 at 2:26:44 PM by stefan jacobi (previous) (diff)

comment:14 in reply to: ↑ 13 Changed on Apr 20, 2015 at 2:33:55 PM by dkocher

Replying to stefan jacobi:

The file list still won't update after uploading a file, only restarting build 17342 helps with that. Also after deleting or moving a file.

This separate issue #8651 just got fixed in r17355.

comment:15 Changed on May 13, 2015 at 1:36:24 PM by dkocher

#8697 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software