Cyberduck Mountain Duck CLI

#8648 closed defect (fixed)

Wildcard for local filename changed to `_`

Reported by: sebastien brusselle Owned by: yla
Priority: normal Milestone: 4.7
Component: cli Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 7

Description (last modified by dkocher)

I have a cmd file with this line

duck --upload ftps://ftp.blbblbl.be:990/ \\w2kfdf\public\DdfsS\Incdsf\Csdf\Bsf\*.txt -u 2sdfsdff -p sdfssdf

He connects perfectly but when trying to upload he changes the *.txt to _.txt. Off course he then gives error no files are found.. How can I solve this?

gr.

Sebastien

Change History (12)

comment:1 Changed on Mar 9, 2015 at 10:23:40 AM by sebastien brusselle

Could it be that there is a issue with character encoding? I saw that after every command it puts a weird sign like à and the progress bar is ??????????????????????

comment:2 Changed on Mar 9, 2015 at 8:01:25 PM by yla

The CLI output is always in UTF-8 encoding. You need to make sure that UTF-8 characters are correctly displayed in your command prompt. The default Windows command prompt has very limited support for alternative encodings though. You should give http://babun.github.io/ a try.

comment:3 Changed on Mar 9, 2015 at 9:11:06 PM by dkocher

  • Component changed from core to cli
  • Summary changed from Duck CLI - wildcard error to Wildcard error

comment:4 Changed on Mar 10, 2015 at 10:05:57 AM by sebastien brusselle

I do understand but we are talking about Duck CLI made for windows?? So If it doesn't understand basic signs like * what is the use of Duck CLI??

Or can I change something on the command prompt of my windows to see the characters displayed correctly..

So the issue is that I have the duck cli command in a cmd file. It just changes automatically the * into a _

comment:5 Changed on Mar 10, 2015 at 10:26:16 AM by sebastien brusselle

I've changed codepage to UTF-8 with CHCP 65001 command to no solution. He just shows the same issue. So he read the complete command, executes it fine, logs in and so on. But when uploading he changes the * to a _ and then says no files found off course..

comment:6 Changed on Mar 10, 2015 at 12:21:30 PM by yla

The encoding issue is not related to the wildcard problem you see. I'll try to reproduce your wildcard issue.

comment:7 Changed on Mar 10, 2015 at 6:00:03 PM by sebastien brusselle

Thank you very much for investigating.. You can test it out by just making a windows cmd file and try to upload from a unc path\*.txt for example. You will see that he changes the * to _ causing off course to find nothing.. I know its stupid but would really love to use CLI but this kind of breaks my usage ot the tool.. thnx for your effort..

comment:8 Changed on Mar 17, 2015 at 10:55:30 AM by sebastien brusselle

Any luck in reproducing this problem??? Really need to get this working..

comment:9 Changed on Mar 25, 2015 at 8:20:44 AM by sebastien brusselle

I'm sorry for pushing this.. Anyone has idea.. it's clearly a duck error since other ftp CLI doesn't have this issue.

So As mentioned above.. He changes my * to _ when executing the cmd file.

comment:10 Changed on Mar 31, 2015 at 12:58:17 PM by dkocher

  • Description modified (diff)
  • Owner changed from Sebastien to yla

comment:11 Changed on Mar 31, 2015 at 1:18:51 PM by dkocher

  • Summary changed from Wildcard error to Wildcard for local filename changed to `_`

comment:12 Changed on Apr 1, 2015 at 1:06:51 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Removed character substitution in r17217. However we rely on the terminal used to expand the globbing pattern in filenames and give multiple file arguments to the program. This is how it works for example with bash on Linux and OS X.

Note: See TracTickets for help on using tickets.
swiss made software