Cyberduck Mountain Duck CLI

#8654 closed defect (worksforme)

Repeated prompts for RSA fingerprint

Reported by: heod Owned by: dkocher
Priority: normal Milestone: 4.8
Component: sftp Version: 4.6.5
Severity: normal Keywords: rsa
Cc: Architecture: Intel
Platform: Mac OS X 10.11

Description

Each time when connecting to SFTP the "Changed fingerprint" dialogue is shown ticking the "Always" box and clicking "Allow" does not stop the dialogue from presenting itself next time the same host connected to.

The host is added to the ~/.ssh/knownhosts file

This has been observed in OS X 10.10.2 and 10.9.5

Attachments (1)

Screen Shot 2015-03-11 at 11.27.14.png (25.8 KB) - added by heod on Mar 11, 2015 at 10:33:46 AM.
Changed fingerprint dialogue box

Download all attachments as: .zip

Change History (16)

Changed on Mar 11, 2015 at 10:33:46 AM by heod

Changed fingerprint dialogue box

comment:1 Changed on Mar 21, 2015 at 8:12:45 PM by dkocher

  • Status changed from new to assigned
  • Summary changed from repeated prompts for rsa fingerprint to Repeated prompts for RSA fingerprint

comment:2 Changed on Mar 21, 2015 at 8:14:15 PM by dkocher

Test in r14986 was supposed to make sure we have no regression here.

comment:3 Changed on Mar 21, 2015 at 8:39:15 PM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:4 Changed on Mar 31, 2015 at 2:22:10 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot reproduce this issue. Please send your ~/.ssh/known_hosts file and the server DNS name to feedback@….

comment:5 follow-up: Changed on Apr 1, 2015 at 11:40:53 PM by bluecouchstudios

I have the same issue as submitted above. Here are a few errors from the system.log. It appears to be a permissions issue. I also had an issue with an upload completing. Restarting the app fixed it. NOTE: I downloaded Cyberduck from the website and NOT the App Store.

4/1/15 6:28:15.613 PM Cyberduck[1385]: [main] ERROR ch.cyberduck.core.aquaticprime.LicenseFactory - Failure finding receipt Access denied
4/1/15 6:28:16.271 PM Cyberduck[1385]: [background-3] ERROR ch.cyberduck.core.AbstractController - Unhandled exception running background task Comparison method violates its general contract!

java.lang.Exception
	at ch.cyberduck.core.AbstractController$BackgroundCallable.<init>(AbstractController.java:150)
	at ch.cyberduck.core.AbstractController.background(AbstractController.java:109)
	at ch.cyberduck.ui.cocoa.MainController.applicationDidFinishLaunching(MainController.java:973)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:170)
	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:470)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:500)
	at com.sun.jna.Native.invokeVoid(Native Method)
	at com.sun.jna.Function.invoke(Function.java:367)
	at com.sun.jna.Function.invoke(Function.java:315)
	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
	at com.sun.jna.Library$Handler.invoke(Library.java:210)
	at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source)
	at org.rococoa.Foundation.send(Foundation.java:208)
	at org.rococoa.Foundation.send(Foundation.java:194)
	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:269)
	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:232)
	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:191)
	at ch.cyberduck.binding.application.NSApplication$$ByRococoa.run(<generated>)
	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:80)
Caused by: java.lang.IllegalArgumentException: Comparison method violates its general contract!
	at java.util.TimSort.mergeLo(TimSort.java:747)
	at java.util.TimSort.mergeAt(TimSort.java:483)
	at java.util.TimSort.mergeForceCollapse(TimSort.java:426)
	at java.util.TimSort.sort(TimSort.java:223)
	at java.util.TimSort.sort(TimSort.java:173)
	at java.util.Arrays.sort(Arrays.java:659)
	at java.util.Collections.sort(Collections.java:217)
	at ch.cyberduck.core.HistoryCollection.sort(HistoryCollection.java:100)
	at ch.cyberduck.core.AbstractFolderHostCollection.load(AbstractFolderHostCollection.java:145)
	at ch.cyberduck.ui.cocoa.MainController$13.run(MainController.java:976)
	at ch.cyberduck.ui.cocoa.MainController$13.run(MainController.java:973)
	at ch.cyberduck.core.threading.AbstractBackgroundAction.call(AbstractBackgroundAction.java:119)
	at ch.cyberduck.core.AbstractController$BackgroundCallable.call(AbstractController.java:174)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:724)

4/1/15 6:32:20.778 PM Cyberduck[1385]: [main] ERROR ch.cyberduck.core.KeychainStore - KeychainStore Ignored Exception: java.security.cert.CertificateParsingException: java.io.IOException: Duplicate extensions not allowed

4/1/15 6:32:20.987 PM Cyberduck[1385]: [main] ERROR ch.cyberduck.ui.cocoa.delegate.AbstractMenuDelegate - Failed to attach key equivalent to menu item:c

4/1/15 6:32:22.175 PM WindowServer[131]: disable_update_timeout: UI updates were forcibly disabled by application "Cyberduck" for over 1.00 seconds. Server has re-enabled them.
4/1/15 6:32:23.075 PM WindowServer[131]: common_reenable_update: UI updates were finally reenabled by application "Cyberduck" after 1.90 seconds (server forcibly re-enabled them after 1.00 seconds)

Last edited on Apr 2, 2015 at 7:45:41 AM by dkocher (previous) (diff)

comment:6 in reply to: ↑ 5 Changed on Apr 2, 2015 at 7:47:18 AM by dkocher

Replying to bluecouchstudios:

4/1/15 6:28:16.271 PM Cyberduck[1385]: [background-3] ERROR ch.cyberduck.core.AbstractController - Unhandled exception running background task Comparison method violates its general contract!

}}}

This issue has been fixed in r17033.

comment:7 Changed on Apr 2, 2015 at 7:53:39 AM by dkocher

Please update to the latest snapshot build available and post or mail your ~/.ssh/known_hosts file.

comment:8 follow-up: Changed on Apr 2, 2015 at 1:06:46 PM by bluecouchstudios

I did update to the latest version, I guess after that error and before the 6:32 errors. Won't posting the file give everyone who checks the page access to my servers? Probably not a good idea. What is your email?

Last edited on Apr 2, 2015 at 1:30:42 PM by bluecouchstudios (previous) (diff)

comment:9 Changed on Apr 2, 2015 at 1:15:08 PM by bluecouchstudios

Last edited on Apr 2, 2015 at 1:30:19 PM by bluecouchstudios (previous) (diff)

comment:10 in reply to: ↑ 8 Changed on Apr 2, 2015 at 2:10:58 PM by dkocher

Replying to bluecouchstudios:

I did update to the latest version, I guess after that error and before the 6:32 errors. Won't posting the file give everyone who checks the page access to my servers? Probably not a good idea. What is your email?

Please send your ~/.ssh/known_hosts file and the server DNS name to feedback@….

comment:11 Changed on Jan 2, 2016 at 1:24:57 AM by tronster

  • Platform changed from Mac OS X 10.9 to Mac OS X 10.11
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I'm now receiving this issue as well with SFTP, using a Mac 10.11.2. Clicking "always" continues to receive a prompt every time I connect, upload, or download.

Is there a work-around?

comment:12 Changed on Jan 2, 2016 at 5:57:07 PM by dkocher

  • Milestone changed from 4.7 to 4.8
  • Resolution set to fixed
  • Status changed from reopened to closed

Please update to the latest snapshot build available.

comment:13 follow-up: Changed on Jan 2, 2016 at 11:51:08 PM by tronster

  • Resolution fixed deleted
  • Status changed from closed to reopened

Just downloaded and tried 4.8.0; still continues to prompt.

comment:14 in reply to: ↑ 13 Changed on Jan 4, 2016 at 1:31:07 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

Replying to tronster:

Just downloaded and tried 4.8.0; still continues to prompt.

Please try to remove your ~/.ssh/known_hosts file.

comment:15 Changed on Jan 5, 2016 at 3:20:47 AM by tronster

Thank you; that fixed it.

Note: See TracTickets for help on using tickets.
swiss made software