Cyberduck Mountain Duck CLI

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#8657 closed defect (fixed)

All files are damaged after being synchronized with mirror action

Reported by: help!! Owned by:
Priority: high Milestone: 4.7.3
Component: core Version: 4.6.5
Severity: critical Keywords: files damaged
Cc: Architecture:
Platform: Mac OS X 10.9

Description

After being synchronized, all files on the website show 0 B. And all original files on my personal computer can not open because they are damaged.

Attachments (1)

QQ20150307-3.png (132.7 KB) - added by help!! 4 years ago.
The icon of files are changed.

Download all attachments as: .zip

Change History (13)

Changed 4 years ago by help!!

The icon of files are changed.

comment:1 Changed 4 years ago by dkocher

The icon of files are changed.

comment:2 Changed 3 years ago by dkocher

  • Milestone set to 4.7.1
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot replicate this issue. Please update to the latest release and reopen this issue with exact steps to reproduce.

Last edited 3 years ago by dkocher (previous) (diff)

comment:3 Changed 3 years ago by dkocher

  • Priority changed from normal to high
  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:4 Changed 3 years ago by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Regression introduced in r16965 when local files are moved to Trash and the synchronisation transfer is repeated (possibly with automatic retry due to a network connectivity issue).

comment:5 Changed 3 years ago by dkocher

In r17833.

comment:6 follow-up: Changed 3 years ago by hal9000

Since this is closed, Trac is probably the wrong place to ask this... But I am currently experiencing this issue on 4.7.

I'm wondering if there might be a way to recover any of the affected files.

Here's what I'm looking at:

  • Action taken: Attempted to sync (down) from a remote ec2 server.
  • Affected data: ~2000 files — code/plaintext and images.
  • Outcome: 3 broken copies of each file; 0 original/working copies.
  • In the following locations:
    1. Remote (orig. source) — each file is either 0 B or 286 B
    2. Local project dir (orig. destination) — each file is 201 KB
    3. ~/.Trash — each file is 201 KB

If there's a better place to ask, please feel free to point me in that direction. Thanks.

Last edited 3 years ago by hal9000 (previous) (diff)

comment:7 Changed 3 years ago by dkocher

  • Milestone changed from 4.7.1 to 4.8
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Changed 3 years ago by dkocher

#9042 closed as duplicate.

comment:9 Changed 3 years ago by dkocher

#8993 closed as duplicate.

comment:10 in reply to: ↑ 6 Changed 3 years ago by dkocher

Replying to hal9000:

Since this is closed, Trac is probably the wrong place to ask this... But I am currently experiencing this issue on 4.7.

I'm wondering if there might be a way to recover any of the affected files.

Here's what I'm looking at:

  • Action taken: Attempted to sync (down) from a remote ec2 server.
  • Affected data: ~2000 files — code/plaintext and images.
  • Outcome: 3 broken copies of each file; 0 original/working copies.
  • In the following locations:
    1. Remote (orig. source) — each file is either 0 B or 286 B
    2. Local project dir (orig. destination) — each file is 201 KB
    3. ~/.Trash — each file is 201 KB

If there's a better place to ask, please feel free to point me in that direction. Thanks.

Thanks for the details. We are reopening this issue and hopefully find the issue and a fix. Assign higher priority.

comment:11 Changed 3 years ago by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r18330.

comment:12 Changed 3 years ago by dkocher

  • Summary changed from All files are damaged after being synchronized to All files are damaged after being synchronized with mirror action
Note: See TracTickets for help on using tickets.
swiss made software