Cyberduck Mountain Duck CLI

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#8676 closed defect (worksforme)

Application freezing after file download completes

Reported by: moghilemear Owned by:
Priority: normal Milestone: 4.7
Component: core Version: Nightly Build
Severity: normal Keywords: Freeze after File transfer
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

Version 4.7 (17149), Mac OSX 10.10.2, connecting to a linux server (GoDaddy), PASSIVE mode, SFTP

For a period of time (about 1-2 min) after a file transfer the Cyberduck app "Browser" window items are unselectable. Then selecting "Bookmarks" and attempting to connect with a bookmarked server, the book mark is unselectable. After about 1-2min the items become responsive and seemingly in correct working order again.

I repeated this sequence twice in a row: Open a bookmarked server, highlight a file with mouse and drag it to a subfolder on my local desktop. The file is transferred, the logs show nominal activity. All of the files and folders in the Cyberduck browser window are un-selectable, bookmarks button is selected, none of the bookmarks are selectable. After a time period of 1-2min *after the file transfer is finished* (and when the bookmarks button was not selected), then the folders & files become selectable again - seemingly with no other input or change.

This problem has been happening on an off over the last few weeks with the last few versions of Cyberduck.

Note: my Mac is experiencing the documented Yosemite folder-unresponsive bug (i.e. when you create a new folder, drag items to it, then the folder shows no items, until you leave the directory and come back, then the items are show. Don't know if these are related somehow via system libs, but thought it might help in tracking down the problem.

Note 2: GoDaddy FTP server is a bit flaky and has periodic slow-downs 4KB/sec. Requires passive mode, and seems to like SFTP better than FTP. But it is mostly a flaky ftp service.

Change History (6)

comment:1 Changed 4 years ago by dkocher

  • Summary changed from Cyberduck App freezing after file transfer completes to Application freezing after file transfer completes
  • Version changed from 4.6.5 to Nightly Build

comment:2 Changed 4 years ago by dkocher

  • Summary changed from Application freezing after file transfer completes to Application freezing after file download completes

comment:3 Changed 4 years ago by dkocher

  • Milestone set to 4.7

comment:4 Changed 4 years ago by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:5 Changed 4 years ago by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Can you try if you can reproduce this issue when running on a guest account on your Mac.

comment:6 Changed 4 years ago by moghilemear

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

Can you try if you can reproduce this issue when running on a guest account on your Mac.

RE logs Sorry I have no logs of the events. The Cyberduck log window shows no messages during the multiple freeze events.

RE guest account (aka OSX preferences testing) Sorry, since the problem is intermittent, I don't have the ability to work from a guest account for an extended period.

RE: worksforme status Probably not terribly applicable in the case of an intermittent failure. What I can tell you to look for though is a non-standard communication directive from a host like GoDaddy. They have been having severe problems with their FTP - it is documented and causing multiple prob reports for GoDaddy - this is obviously a problem with GoDaddy. However, when GoDaddy-FTP issues some sort of non-standard command, in general, an FTP client should not be expected to freeze for 90sec - there should be a "connection" warning or error, but freezing for 60-90 secs then unfreezing is non-intuitive behavior and suggests an error condition not being anticipated.

This is all I can offer. GoDaddy tech "support" is not being terribly supportive - they claim I should just stop using Cyberduck (which is my favorite FTP client BTW) - but they also claim they are working on their FTP issues.

Sorry, this is all I have for you.

Last edited 4 years ago by moghilemear (previous) (diff)
Note: See TracTickets for help on using tickets.
swiss made software