Cyberduck Mountain Duck CLI

#8701 closed enhancement (fixed)

ZIP package contains __MACOSX directory

Reported by: jerry Owned by: dkocher
Priority: normal Milestone: 4.7
Component: core Version: 4.6.5
Severity: trivial Keywords:
Cc: Architecture:
Platform:

Description

The zip file when unpack contains the following directories: Cyberduck.app MACOSX

The MACOSX folder should not be distributed (not required) Can be deleted once unpacked and it doesn't affect the application operations.

Change History (5)

comment:1 Changed on Mar 26, 2015 at 7:39:43 PM by dkocher

  • Milestone set to 4.7
  • Owner set to dkocher
  • Status changed from new to assigned
  • Type changed from defect to enhancement

comment:2 Changed on Mar 26, 2015 at 7:39:54 PM by dkocher

  • Summary changed from mac download zip contains __MACOSX directory to ZIP package contains __MACOSX directory

comment:3 Changed on Mar 26, 2015 at 7:40:42 PM by dkocher

The ZIP archive is created with

ditto -c -k --sequesterRsrc --keepParent

comment:4 Changed on Mar 26, 2015 at 7:43:15 PM by dkocher

This is caused by --sequesterRsrc option. I think this option was added to preserve the executable flags on the main program.

     --sequesterRsrc
                   When creating a PKZip archive, preserve resource forks and HFS meta-data in the subdirectory __MACOSX.  PKZip extraction will automatically find
                   these resources.

comment:5 Changed on Mar 30, 2015 at 12:57:04 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r17176.

Note: See TracTickets for help on using tickets.
swiss made software